Steam for Linux > Genel Başlıklar > Konu Detayları
Josh 7 Tem 2013 @ 12:56pm
AMD APU on Ubuntu?
Hi, I was wondering if anyone had successfully gotten an AMD APU to work in Ubuntu? I've tried the default drivers, the FGLRX drivers, the driver straight from AMD's site (which might be the same thing), and none of them can even play a video. I tried installing Red Orchestra, but it just showed the popup splash screen and froze. Steam can't even go into big picture mode with it, so I assume all accelerated rendering is nonfunctional.

Has anyone gotten an AMD APU to work on Linux?
36 yorumdan 1 ile 15 arası gösteriliyor
< >
DerRidda 7 Tem 2013 @ 1:19pm 
Oh hello, Josh. I'm currently running a Netbook (next to my desktop) with an AMD E-450 APU and it runs very well (for AMD on Linux) haven't tried RO:OST but CS:S is working, although at low fps, I'm either running the latest FGLRX provided by Jockey or just downloaded the debs right from the xorg egders PPA. http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu/pool/main/f/
They say you shouldn't use individual packages from the PPA but you know what you are doing I guess.

When you used the AMD provided installer, did you just install it or build packages and installed those?
En son DerRidda tarafından düzenlendi; 7 Tem 2013 @ 1:20pm
Josh 7 Tem 2013 @ 1:37pm 
I have an A series APU. I'm about to return it to the store since it doesn't seem to be supported in Linux.

I tried:
Both listed closed-source drivers in System Settings > Additional driver.
ATI current and beta drivers straight from their site.
Installing via "sudo apt-get install fglrx".
Installing from "xserver-xorg-graphics-amd" (or whatever it was).

None of these drivers can even play a YouTube video without freezing.
Doc Holliday 7 Tem 2013 @ 1:47pm 
Josh tarafından gönderilen ileti:
I have an A series APU. I'm about to return it to the store since it doesn't seem to be supported in Linux.

I tried:
Both listed closed-source drivers in System Settings > Additional driver.
ATI current and beta drivers straight from their site.
Installing via "sudo apt-get install fglrx".
Installing from "xserver-xorg-graphics-amd" (or whatever it was).

None of these drivers can even play a YouTube video without freezing.
you need the Catalyst 13.6 Beta to get APU's to work far as i know. Note from the AMD site AMD A10, A8, A6, and A4 Series APUs
En son Doc Holliday tarafından düzenlendi; 7 Tem 2013 @ 1:50pm
Josh 7 Tem 2013 @ 1:51pm 
Yep, I am running "amd-driver-installer-catalyst-13-6-beta-x86.x86_64.zip" right now and it says "Testing use only" in the lower right-hand corner. Same behavior, just a YouTube video makes it freeze.
Doc Holliday 7 Tem 2013 @ 2:04pm 
Josh tarafından gönderilen ileti:
Yep, I am running "amd-driver-installer-catalyst-13-6-beta-x86.x86_64.zip" right now and it says "Testing use only" in the lower right-hand corner. Same behavior, just a YouTube video makes it freeze.
i uninstall it and reinstall it using the wiki here http://wiki.cchtml.com/index.php/Ubuntu
Josh 7 Tem 2013 @ 2:08pm 
The last thing I can do is reinstall Ubuntu, then install the beta driver from AMD. Then I take the computer apart and return the pieces.
MarcoDePollo 7 Tem 2013 @ 2:18pm 
Just out of curiosity, which Ubuntu-version are you running?
John Noob doesn´t play ranked 7 Tem 2013 @ 2:46pm 
Is an graphic driver problem? or is a flash problem? which browser are you using? Chrome?
Josh 7 Tem 2013 @ 3:38pm 
Here's what I did:
-Performed a clean install of Ubuntu 12.04.
-Installed AMD beta driver from their site (amd-driver-installer-catalyst-13-6-beta-x86.x86_64.run).
-Restarted. The AMD "Testing use only" watermark appears, indicating the driver is active.
-Installed the latest version of the Flash plugin.
-Installed Steam.

Results:
-If I view a YouTube video in FireFox or Chromium, the program stops responding.
-If I switch Steam to Big Picture mode, nothing happens. The entire screen becomes nonresponsive.
-I didn't bother downloading a 2 gb game for the fifth time, but last time I tried launching Counterstrike: Source the screen turned black and nothing happened.
En son Josh tarafından düzenlendi; 7 Tem 2013 @ 3:38pm
MarcoDePollo 7 Tem 2013 @ 3:48pm 
Depending on the year/model of the APU, you might have more success with a newer Ubuntu.
Doc Holliday 7 Tem 2013 @ 4:12pm 
whats it install .Deb?, and, did you preinstall the 32bit packages?, in 12.04 you have to do a full update and upgrade befor installing Steam, or Driver's, or it will not pull in the package's needed. it's said to see them not update the installer, for there flag ship OS (AKA Lazy)
i say it is one of the following
A you was missing package's when installing the driver
B have a BAD APU
C Bios need's updated
D Ubuntu 12.04 is to far out of date
E AMD Catalyst Sucks

we know the AMD A10-6800K run's well on Linux http://www.phoronix.com/scan.php?page=article&item=amd_radeon_hd8670d&num=1
En son Doc Holliday tarafından düzenlendi; 7 Tem 2013 @ 4:18pm
RegSizedRudy 7 Tem 2013 @ 5:32pm 
Did anyone notice on the AMD APU you cant switch TTY sessions ?
DerRidda 7 Tem 2013 @ 6:48pm 
Works on my netbook. One thing I remembered: Whenever you install fglrx for the first time you should run "sudo aticonfig --initial" to write an initial xorg.conf.
Josh 7 Tem 2013 @ 8:53pm 
I reinstalled Ubuntu, ran the update manager, restarted, installed the ATI beta driver above, restarted...and got the exact same result.
DerRidda 7 Tem 2013 @ 9:27pm 
Just for the lols: Grab a really up-to-date distro that uses Kernel 3.10, like Arch or even the Ubuntu Saucy daily image, it doesn't have to be stable. And see how that video works with the free drivers only, there were some massive graphics improvements for Kernel 3.10.
36 yorumdan 1 ile 15 arası gösteriliyor
< >
Sayfa başına: 15 30 50
Gönderilme Tarihi: 7 Tem 2013 @ 12:56pm
İleti: 36