Steam for Linux > 一般討論 > 主題細節
Josh 2013 年 07 月 7 日 @ 下午 12 時 56 分
AMD APU on Ubuntu?
Hi, I was wondering if anyone had successfully gotten an AMD APU to work in Ubuntu? I've tried the default drivers, the FGLRX drivers, the driver straight from AMD's site (which might be the same thing), and none of them can even play a video. I tried installing Red Orchestra, but it just showed the popup splash screen and froze. Steam can't even go into big picture mode with it, so I assume all accelerated rendering is nonfunctional.

Has anyone gotten an AMD APU to work on Linux?
顯示 1-15,共 36 則回應
< >
DerRidda 2013 年 07 月 7 日 @ 下午 1 時 19 分 
Oh hello, Josh. I'm currently running a Netbook (next to my desktop) with an AMD E-450 APU and it runs very well (for AMD on Linux) haven't tried RO:OST but CS:S is working, although at low fps, I'm either running the latest FGLRX provided by Jockey or just downloaded the debs right from the xorg egders PPA. http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu/pool/main/f/
They say you shouldn't use individual packages from the PPA but you know what you are doing I guess.

When you used the AMD provided installer, did you just install it or build packages and installed those?
最後修改者:DerRidda; 2013 年 07 月 7 日 @ 下午 1 時 20 分
Josh 2013 年 07 月 7 日 @ 下午 1 時 37 分 
I have an A series APU. I'm about to return it to the store since it doesn't seem to be supported in Linux.

I tried:
Both listed closed-source drivers in System Settings > Additional driver.
ATI current and beta drivers straight from their site.
Installing via "sudo apt-get install fglrx".
Installing from "xserver-xorg-graphics-amd" (or whatever it was).

None of these drivers can even play a YouTube video without freezing.
Doc Holliday 2013 年 07 月 7 日 @ 下午 1 時 47 分 
Josh 發表:
I have an A series APU. I'm about to return it to the store since it doesn't seem to be supported in Linux.

I tried:
Both listed closed-source drivers in System Settings > Additional driver.
ATI current and beta drivers straight from their site.
Installing via "sudo apt-get install fglrx".
Installing from "xserver-xorg-graphics-amd" (or whatever it was).

None of these drivers can even play a YouTube video without freezing.
you need the Catalyst 13.6 Beta to get APU's to work far as i know. Note from the AMD site AMD A10, A8, A6, and A4 Series APUs
最後修改者:Doc Holliday; 2013 年 07 月 7 日 @ 下午 1 時 50 分
Josh 2013 年 07 月 7 日 @ 下午 1 時 51 分 
Yep, I am running "amd-driver-installer-catalyst-13-6-beta-x86.x86_64.zip" right now and it says "Testing use only" in the lower right-hand corner. Same behavior, just a YouTube video makes it freeze.
Doc Holliday 2013 年 07 月 7 日 @ 下午 2 時 04 分 
Josh 發表:
Yep, I am running "amd-driver-installer-catalyst-13-6-beta-x86.x86_64.zip" right now and it says "Testing use only" in the lower right-hand corner. Same behavior, just a YouTube video makes it freeze.
i uninstall it and reinstall it using the wiki here http://wiki.cchtml.com/index.php/Ubuntu
Josh 2013 年 07 月 7 日 @ 下午 2 時 08 分 
The last thing I can do is reinstall Ubuntu, then install the beta driver from AMD. Then I take the computer apart and return the pieces.
MarcoDePollo 2013 年 07 月 7 日 @ 下午 2 時 18 分 
Just out of curiosity, which Ubuntu-version are you running?
John Noob doesn´t play ranked 2013 年 07 月 7 日 @ 下午 2 時 46 分 
Is an graphic driver problem? or is a flash problem? which browser are you using? Chrome?
Josh 2013 年 07 月 7 日 @ 下午 3 時 38 分 
Here's what I did:
-Performed a clean install of Ubuntu 12.04.
-Installed AMD beta driver from their site (amd-driver-installer-catalyst-13-6-beta-x86.x86_64.run).
-Restarted. The AMD "Testing use only" watermark appears, indicating the driver is active.
-Installed the latest version of the Flash plugin.
-Installed Steam.

Results:
-If I view a YouTube video in FireFox or Chromium, the program stops responding.
-If I switch Steam to Big Picture mode, nothing happens. The entire screen becomes nonresponsive.
-I didn't bother downloading a 2 gb game for the fifth time, but last time I tried launching Counterstrike: Source the screen turned black and nothing happened.
最後修改者:Josh; 2013 年 07 月 7 日 @ 下午 3 時 38 分
MarcoDePollo 2013 年 07 月 7 日 @ 下午 3 時 48 分 
Depending on the year/model of the APU, you might have more success with a newer Ubuntu.
Doc Holliday 2013 年 07 月 7 日 @ 下午 4 時 12 分 
whats it install .Deb?, and, did you preinstall the 32bit packages?, in 12.04 you have to do a full update and upgrade befor installing Steam, or Driver's, or it will not pull in the package's needed. it's said to see them not update the installer, for there flag ship OS (AKA Lazy)
i say it is one of the following
A you was missing package's when installing the driver
B have a BAD APU
C Bios need's updated
D Ubuntu 12.04 is to far out of date
E AMD Catalyst Sucks

we know the AMD A10-6800K run's well on Linux http://www.phoronix.com/scan.php?page=article&item=amd_radeon_hd8670d&num=1
最後修改者:Doc Holliday; 2013 年 07 月 7 日 @ 下午 4 時 18 分
RegSizedRudy 2013 年 07 月 7 日 @ 下午 5 時 32 分 
Did anyone notice on the AMD APU you cant switch TTY sessions ?
DerRidda 2013 年 07 月 7 日 @ 下午 6 時 48 分 
Works on my netbook. One thing I remembered: Whenever you install fglrx for the first time you should run "sudo aticonfig --initial" to write an initial xorg.conf.
Josh 2013 年 07 月 7 日 @ 下午 8 時 53 分 
I reinstalled Ubuntu, ran the update manager, restarted, installed the ATI beta driver above, restarted...and got the exact same result.
DerRidda 2013 年 07 月 7 日 @ 下午 9 時 27 分 
Just for the lols: Grab a really up-to-date distro that uses Kernel 3.10, like Arch or even the Ubuntu Saucy daily image, it doesn't have to be stable. And see how that video works with the free drivers only, there were some massive graphics improvements for Kernel 3.10.
顯示 1-15,共 36 則回應
< >
每頁: 15 30 50
張貼日期: 2013 年 07 月 7 日 @ 下午 12 時 56 分
回覆: 36