Steam for Linux > 一般討論 > 主題細節
SLC00LJ 2013 年 07 月 5 日 @ 下午 12 時 37 分
Team Fortress 2: Graphical OpenGL error on linux. Refusing to let me play.
So, i've been forced to load a OS using a usb drive since my laptop is really jacked up meaning i can't run windows so i had to run linux and when i run tf2 on linux i get this.

Images of the glitches in order of loading screen to main menu[imgur.com]
顯示 1-9,共 9 則回應
< >
thetargos 2013 年 07 月 5 日 @ 下午 5 時 36 分 
What distribution, version, hardware specs, etc... Did you install any drivers or are you using the ones provided (most likely the OSS drivers)? etc.
SLC00LJ 2013 年 07 月 6 日 @ 下午 5 時 23 分 
Here is the raw info from terminal and if i'm correct the drivers have updated with ubuntu itself seeing as when i updated ubuntu last time it let me play minecraft which uses a opengl driver which wouldn't work before updating.

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=12.10

model name : Intel(R) Pentium(R) Dual CPU T3200 @ 2.00GHz
model name : Intel(R) Pentium(R) Dual CPU T3200 @ 2.00GHz

For the rest of the hardware specs it should be a un-modified K60IJ asus laptop using the CPU i listed above.


最後修改者:SLC00LJ; 2013 年 07 月 6 日 @ 下午 5 時 23 分
thetargos 2013 年 07 月 6 日 @ 下午 10 時 13 分 
Grapics adapter and drivers? If you are using nVidia or AMD graphics it would be adviasable to install their binary drivers.
SLC00LJ 2013 年 07 月 6 日 @ 下午 10 時 53 分 
Chipset Mobile Intel GM45 Express
Graphics Intel GMA 4500MHD
thetargos 2013 年 07 月 7 日 @ 下午 4 時 23 分 
Did you install S3TC support? Search for libtxc_dxtn
SLC00LJ 2013 年 07 月 7 日 @ 下午 5 時 58 分 
No, i never did. And after i get everything ready when i try to use make it just gives me a error. txc_dxtn.h:28:19: fatal error: GL/gl.h: No such file or directory
thetargos 2013 年 07 月 7 日 @ 下午 10 時 23 分 
You should be able to install it through the appcenter in Ubuntu, no need to build from source, just make sure it is the 32-bit (i686) version if you run on 64-bit OS
SLC00LJ 2013 年 07 月 8 日 @ 上午 12 時 25 分 
I downloaded them and made sure they were working right, and i started and it still was the same. I even started in window mode and it was still the same.
SLC00LJ 2013 年 07 月 13 日 @ 下午 8 時 22 分 
Bump, i really need a soloution to this.
顯示 1-9,共 9 則回應
< >
每頁: 15 30 50
張貼日期: 2013 年 07 月 5 日 @ 下午 12 時 37 分
回覆: 9