Steam for Linux > Általános témák > Téma részletei
slcoolj 2013. júl. 5. @ du. 12:37
Team Fortress 2: Graphical OpenGL error on linux. Refusing to let me play.
So, i've been forced to load a OS using a usb drive since my laptop is really jacked up meaning i can't run windows so i had to run linux and when i run tf2 on linux i get this.

Images of the glitches in order of loading screen to main menu[]
19/9 megjegyzés mutatása
< >
thetargos 2013. júl. 5. @ du. 5:36 
What distribution, version, hardware specs, etc... Did you install any drivers or are you using the ones provided (most likely the OSS drivers)? etc.
slcoolj 2013. júl. 6. @ du. 5:23 
Here is the raw info from terminal and if i'm correct the drivers have updated with ubuntu itself seeing as when i updated ubuntu last time it let me play minecraft which uses a opengl driver which wouldn't work before updating.


model name : Intel(R) Pentium(R) Dual CPU T3200 @ 2.00GHz
model name : Intel(R) Pentium(R) Dual CPU T3200 @ 2.00GHz

For the rest of the hardware specs it should be a un-modified K60IJ asus laptop using the CPU i listed above.

Legutóbb szerkesztette: slcoolj; 2013. júl. 6. @ du. 5:23
thetargos 2013. júl. 6. @ du. 10:13 
Grapics adapter and drivers? If you are using nVidia or AMD graphics it would be adviasable to install their binary drivers.
slcoolj 2013. júl. 6. @ du. 10:53 
Chipset Mobile Intel GM45 Express
Graphics Intel GMA 4500MHD
thetargos 2013. júl. 7. @ du. 4:23 
Did you install S3TC support? Search for libtxc_dxtn
slcoolj 2013. júl. 7. @ du. 5:58 
No, i never did. And after i get everything ready when i try to use make it just gives me a error. txc_dxtn.h:28:19: fatal error: GL/gl.h: No such file or directory
thetargos 2013. júl. 7. @ du. 10:23 
You should be able to install it through the appcenter in Ubuntu, no need to build from source, just make sure it is the 32-bit (i686) version if you run on 64-bit OS
slcoolj 2013. júl. 8. @ de. 12:25 
I downloaded them and made sure they were working right, and i started and it still was the same. I even started in window mode and it was still the same.
slcoolj 2013. júl. 13. @ du. 8:22 
Bump, i really need a soloution to this.
19/9 megjegyzés mutatása
< >
Laponként: 15 30 50
Küldés ideje: 2013. júl. 5. @ du. 12:37
Hozzászólások: 9