SLC00LJ 5. Juli 2013 um 12:37 Uhr
Team Fortress 2: Graphical OpenGL error on linux. Refusing to let me play.
So, i've been forced to load a OS using a usb drive since my laptop is really jacked up meaning i can't run windows so i had to run linux and when i run tf2 on linux i get this.

Images of the glitches in order of loading screen to main menu[imgur.com]
Beiträge 1-9 von 9
< >
thetargos 5. Juli 2013 um 17:36 Uhr 
What distribution, version, hardware specs, etc... Did you install any drivers or are you using the ones provided (most likely the OSS drivers)? etc.
SLC00LJ 6. Juli 2013 um 17:23 Uhr 
Here is the raw info from terminal and if i'm correct the drivers have updated with ubuntu itself seeing as when i updated ubuntu last time it let me play minecraft which uses a opengl driver which wouldn't work before updating.

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=12.10

model name : Intel(R) Pentium(R) Dual CPU T3200 @ 2.00GHz
model name : Intel(R) Pentium(R) Dual CPU T3200 @ 2.00GHz

For the rest of the hardware specs it should be a un-modified K60IJ asus laptop using the CPU i listed above.


Zuletzt bearbeitet von SLC00LJ; 6. Juli 2013 um 17:23 Uhr
thetargos 6. Juli 2013 um 22:13 Uhr 
Grapics adapter and drivers? If you are using nVidia or AMD graphics it would be adviasable to install their binary drivers.
SLC00LJ 6. Juli 2013 um 22:53 Uhr 
Chipset Mobile Intel GM45 Express
Graphics Intel GMA 4500MHD
thetargos 7. Juli 2013 um 16:23 Uhr 
Did you install S3TC support? Search for libtxc_dxtn
SLC00LJ 7. Juli 2013 um 17:58 Uhr 
No, i never did. And after i get everything ready when i try to use make it just gives me a error. txc_dxtn.h:28:19: fatal error: GL/gl.h: No such file or directory
thetargos 7. Juli 2013 um 22:23 Uhr 
You should be able to install it through the appcenter in Ubuntu, no need to build from source, just make sure it is the 32-bit (i686) version if you run on 64-bit OS
SLC00LJ 8. Juli 2013 um 0:25 Uhr 
I downloaded them and made sure they were working right, and i started and it still was the same. I even started in window mode and it was still the same.
SLC00LJ 13. Juli 2013 um 20:22 Uhr 
Bump, i really need a soloution to this.
Beiträge 1-9 von 9
< >
Pro Seite: 15 30 50
Geschrieben am: 5. Juli 2013 um 12:37 Uhr
Beiträge: 9