Steam for Linux > Obecné diskuze > Detaily tématu
SLC00LJ 5. čvc. 2013 v 12.37 odp.
Team Fortress 2: Graphical OpenGL error on linux. Refusing to let me play.
So, i've been forced to load a OS using a usb drive since my laptop is really jacked up meaning i can't run windows so i had to run linux and when i run tf2 on linux i get this.

Images of the glitches in order of loading screen to main menu[imgur.com]
Zobrazeno 1-9 z 9 komentářů
< >
thetargos 5. čvc. 2013 v 5.36 odp. 
What distribution, version, hardware specs, etc... Did you install any drivers or are you using the ones provided (most likely the OSS drivers)? etc.
SLC00LJ 6. čvc. 2013 v 5.23 odp. 
Here is the raw info from terminal and if i'm correct the drivers have updated with ubuntu itself seeing as when i updated ubuntu last time it let me play minecraft which uses a opengl driver which wouldn't work before updating.

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=12.10

model name : Intel(R) Pentium(R) Dual CPU T3200 @ 2.00GHz
model name : Intel(R) Pentium(R) Dual CPU T3200 @ 2.00GHz

For the rest of the hardware specs it should be a un-modified K60IJ asus laptop using the CPU i listed above.


Naposledy upravil SLC00LJ; 6. čvc. 2013 v 5.23 odp.
thetargos 6. čvc. 2013 v 10.13 odp. 
Grapics adapter and drivers? If you are using nVidia or AMD graphics it would be adviasable to install their binary drivers.
SLC00LJ 6. čvc. 2013 v 10.53 odp. 
Chipset Mobile Intel GM45 Express
Graphics Intel GMA 4500MHD
thetargos 7. čvc. 2013 v 4.23 odp. 
Did you install S3TC support? Search for libtxc_dxtn
SLC00LJ 7. čvc. 2013 v 5.58 odp. 
No, i never did. And after i get everything ready when i try to use make it just gives me a error. txc_dxtn.h:28:19: fatal error: GL/gl.h: No such file or directory
thetargos 7. čvc. 2013 v 10.23 odp. 
You should be able to install it through the appcenter in Ubuntu, no need to build from source, just make sure it is the 32-bit (i686) version if you run on 64-bit OS
SLC00LJ 8. čvc. 2013 v 12.25 dop. 
I downloaded them and made sure they were working right, and i started and it still was the same. I even started in window mode and it was still the same.
SLC00LJ 13. čvc. 2013 v 8.22 odp. 
Bump, i really need a soloution to this.
Zobrazeno 1-9 z 9 komentářů
< >
Na stránku: 15 30 50
Datum odeslání: 5. čvc. 2013 v 12.37 odp.
Počet příspěvků: 9