Botnet (Card Farming) Jul 5, 2013 @ 12:37pm
Team Fortress 2: Graphical OpenGL error on linux. Refusing to let me play.
So, i've been forced to load a OS using a usb drive since my laptop is really jacked up meaning i can't run windows so i had to run linux and when i run tf2 on linux i get this.

Images of the glitches in order of loading screen to main menu[imgur.com]
Showing 1-9 of 9 comments
< >
thetargos Jul 5, 2013 @ 5:36pm 
What distribution, version, hardware specs, etc... Did you install any drivers or are you using the ones provided (most likely the OSS drivers)? etc.
Botnet (Card Farming) Jul 6, 2013 @ 5:23pm 
Here is the raw info from terminal and if i'm correct the drivers have updated with ubuntu itself seeing as when i updated ubuntu last time it let me play minecraft which uses a opengl driver which wouldn't work before updating.

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=12.10

model name : Intel(R) Pentium(R) Dual CPU T3200 @ 2.00GHz
model name : Intel(R) Pentium(R) Dual CPU T3200 @ 2.00GHz

For the rest of the hardware specs it should be a un-modified K60IJ asus laptop using the CPU i listed above.


Last edited by Botnet (Card Farming); Jul 6, 2013 @ 5:23pm
thetargos Jul 6, 2013 @ 10:13pm 
Grapics adapter and drivers? If you are using nVidia or AMD graphics it would be adviasable to install their binary drivers.
Botnet (Card Farming) Jul 6, 2013 @ 10:53pm 
Chipset Mobile Intel GM45 Express
Graphics Intel GMA 4500MHD
thetargos Jul 7, 2013 @ 4:23pm 
Did you install S3TC support? Search for libtxc_dxtn
Botnet (Card Farming) Jul 7, 2013 @ 5:58pm 
No, i never did. And after i get everything ready when i try to use make it just gives me a error. txc_dxtn.h:28:19: fatal error: GL/gl.h: No such file or directory
thetargos Jul 7, 2013 @ 10:23pm 
You should be able to install it through the appcenter in Ubuntu, no need to build from source, just make sure it is the 32-bit (i686) version if you run on 64-bit OS
Botnet (Card Farming) Jul 8, 2013 @ 12:25am 
I downloaded them and made sure they were working right, and i started and it still was the same. I even started in window mode and it was still the same.
Botnet (Card Farming) Jul 13, 2013 @ 8:22pm 
Bump, i really need a soloution to this.
Showing 1-9 of 9 comments
< >
Per page: 15 30 50

Date Posted: Jul 5, 2013 @ 12:37pm
Posts: 9