Mr. Bean Jun 29, 2013 @ 5:06pm
Just switched to Linux Mint from Windows 8, and TF2 is unplayable. Could use some help.
First of all, thanks for supporting Linux. I've got a Dell Inspiron N5110 with integrated graphics. I was pretty surprised to see that, on Windows, Team Fortress 2 ran perfectly--even on medium-high video settings. I don't know what the framerate was, but everything was perfectly smooth.

Now I just installed Linux Mint 15 (Cinnamon) and expected to get the same results, but unfortunately it's unplayable. It seems that the frame rate is lower, and the game freezes every couple seconds, and is not smooth at all. I know it can't be the integrated card itself, since it played just fine on Windows.

I did run the driver update found here[wiki.ubuntu.com], but that didn't help. Are there any other graphics drivers I should install to make this work?

And lastly, as a last resort, will installing Steam using Wine, or running through virtualbox with windows make it run normally?

Thanks.

EDIT:

I apologize, I should have given more info on my setup:

Video card:
lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)

CPU: Intel(R) Core(TM) i5-2410M CPU @ 2.30GHz

glxinfo | grep OpenGL:
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Sandybridge Mobile
OpenGL version string: 3.0 Mesa 9.2.0-devel
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:

If there is anything else you'd like to know, let me know.
Last edited by Mr. Bean; Jun 29, 2013 @ 5:15pm
Showing 1-15 of 27 comments
< >
DerRidda Jun 29, 2013 @ 5:29pm 
You could try removing the x-swat PPA and instead use the xorg-edgers PPA (https://launchpad.net/~xorg-edgers/+archive/ppa) totally at your own risk as they use the latest stuff and that might come at the expense of stability.
Doc Holliday Jun 29, 2013 @ 5:33pm 
i'm sorry you had to use windows 8
Doc Holliday Jun 29, 2013 @ 5:36pm 
open your terminal to start steam and post what it say's
Lady From Hell Jun 29, 2013 @ 5:38pm 
Yeah running your driver update that way is likely what buggered it up, i did that once, and screwed up my graphics mode royally. I always install via ppa, its easier, quicker, and does it right, with the most up to date drivers. Terminal is a great tool.
Doc Holliday Jun 29, 2013 @ 6:03pm 
Originally posted by DerRidda:
You could try removing the x-swat PPA and instead use the xorg-edgers PPA (https://launchpad.net/~xorg-edgers/+archive/ppa) totally at your own risk as they use the latest stuff and that might come at the expense of stability.
eww x-swat is way out of date
Mr. Bean Jun 29, 2013 @ 6:09pm 
Thanks for the responses.

DerRidda: I believe I tried that. Would that be the same as following the instructions in the description written here? https://www.youtube.com/watch?v=58HF1i654fQ

I didn't remove the other packages though, I just installed those as mentioned in the description. It didn't make a difference.

Doc Holiday: looks like there are a bunch of errors. Here's what I got:

~ $ steam
Running Steam on linuxmint 15 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(1370553818_client)
Installing breakpad exception handler for appid(steam)/version(1370553818_client)
unlinked 0 orphaned pipes
Installing breakpad exception handler for appid(steam)/version(1370553818_client)
[0629/210434:WARNING:proxy_service.cc(646)] PAC support disabled because there is no system implementation
Installing breakpad exception handler for appid(steam)/version(1370553818_client)
Installing breakpad exception handler for appid(steam)/version(1370553818_client)
Installing breakpad exception handler for appid(steam)/version(1370553818_client)
Installing breakpad exception handler for appid(steam)/version(1370553818_client)
Installing breakpad exception handler for appid(steam)/version(1370553818_client)
Generating new string page texture 2: 48x256, total string texture memory is 49.15 KB
Generating new string page texture 3: 256x256, total string texture memory is 311.30 KB
Installing breakpad exception handler for appid(steam)/version(1370553818_client)

(steam:3750): GLib-GIO-WARNING **: g_simple_async_result_complete() called from wrong context!

(steam:3750): GLib-GIO-WARNING **: g_simple_async_result_complete() called from wrong context!

(steam:3750): GLib-GIO-WARNING **: g_simple_async_result_complete() called from wrong context!

(steam:3750): GLib-GIO-WARNING **: g_simple_async_result_complete() called from wrong context!
Installing breakpad exception handler for appid(steam)/version(1370553818_client)

(steam:3750): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(steam:3750): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(steam:3750): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(steam:3750): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(steam:3750): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(steam:3750): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(steam:3750): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(steam:3750): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(steam:3750): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(steam:3750): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(steam:3750): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.
Adding license for package 0
Adding license for package 8538
Adding license for package 28890
roaming config store loaded successfully - 776 bytes.
migrating temporary roaming config store
Installing breakpad exception handler for appid(steam)/version(1370553818_client)
ExecCommandLine: "/home/ephi/.local/share/Steam/ubuntu12_32/steam"
Generating new string page texture 74: 128x256, total string texture memory is 442.37 KB
Generating new string page texture 75: 128x256, total string texture memory is 131.07 KB
Generating new string page texture 76: 32x256, total string texture memory is 475.14 KB
Generating new string page texture 77: 64x256, total string texture memory is 540.67 KB
Installing breakpad exception handler for appid(steam)/version(1370553818_client)
Generating new string page texture 85: 8x256, total string texture memory is 548.86 KB
System startup time: 16.09 seconds
Running Steam on linuxmint 15 64-bit
STEAM_RUNTIME has been set by the user to: /home/ephi/.local/share/Steam/ubuntu12_32/steam-runtime
ExecCommandLine: "/home/ephi/.steam/root/ubuntu12_32/steam steam://open/driverhelperready"
ExecSteamURL: "steam://open/driverhelperready"

(steam:3750): GLib-GIO-WARNING **: g_simple_async_result_complete() called from wrong context!

(steam:3750): GLib-GIO-WARNING **: g_simple_async_result_complete() called from wrong context!

(steam:3750): GLib-GIO-WARNING **: g_simple_async_result_complete() called from wrong context!

(steam:3750): GLib-GIO-WARNING **: g_simple_async_result_complete() called from wrong context!
Mr. Bean Jun 29, 2013 @ 6:26pm 
I just tried to remove the x-swat ppa, but I get the following error:

~ $ sudo ppa-purge ppa:ubuntu-x-swat/x-updates
Updating packages lists
PPA to be removed: ubuntu-x-swat x-updates
Warning: Could not find package list for PPA: ubuntu-x-swat x-updates

Going to "Software Sources" still shows the x-swat and x-swat (sources) as enabled. Not sure what's going on. The xorg-edgers + (sources) is sill there.

Any idea how to get rid of the x-swat ppa and all the packages that came with it?
Doc Holliday Jun 29, 2013 @ 6:26pm 
do an sudo apt-get update than a sudo apt-get upgrade then do an sudo reboot and try to verifying integrety of tf2's cache you may have a bad file server.so or some junk i'm falling a sleep atm
aliceif Jun 29, 2013 @ 6:33pm 
Yep, those errors should not appear (I am using an acer notebook with the same CPU and launching steam on the integrated graphics. However, I find TF2 unplayable on both win7 and ubuntu linux 12.04 and 12.10 with just the integrated graphics. bumblebee + dedicated nvidia 540m with propietary driver makes a gigantic difference)
Mr. Bean Jun 29, 2013 @ 6:54pm 
Doc Holliday: well what do you know. Over a thousand files couldn't be verified, and it's redownloading TF2. However, how are the tf2 files related to all the steam errors? From what I understand it's only dealing with TF2, not steam itself.

Any idea how to fix the steam errors?
aliceif Jun 29, 2013 @ 7:05pm 
Actually, I was mistaken. Those messages are the same as i have, except for the lowest 6 or so. but those seem to be caused by using the driver update tool.
You should really *never* use steam's driver update tool. Simply using the x-swat ppa and upgrading normally with "sudo apt-get update && sudo apt-get upgrade" (or dist-upgrade) works just fine for me, on the intel driver side of things.
Mr. Bean Jun 29, 2013 @ 7:31pm 
aliceif: how do I know if I used steam's driver update tool? I only installed the ubuntu swap-x ppa, and then the xorg-edge ppa, as far as I know. How do I find out if steam updated any drivers?
bleedingpixel Jun 29, 2013 @ 11:10pm 
i don't think steam would update drivers unless you did so..
MrDread Jun 30, 2013 @ 1:00am 
Also, please make sure that CPU frequency scaling is NOT set to ondemand.
You can check by commands such as this for cpu0-4
cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor

If it is, chances are it's exactly what's causing low fps. I think someone stumbled upon this a month or so ago and was really frustrated :D

I can't point you to correct Mint specific solution though, try searching their forums/wiki or maybe local guys will step up to help.

As a temporary check you can try for cpu0-4
sudo echo performance > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
aliceif Jun 30, 2013 @ 1:24am 
Jupiter. It is a small systray applet that lets you control the whole CPU frequency adjustmment thing. available here: https://launchpad.net/~webupd8team/+archive/jupiter
And yes, it also works with sandybridge core i5 CPUs, and there is a noticeable difference between Power on Demand and Maximum Performance.
Showing 1-15 of 27 comments
< >
Per page: 15 30 50
Date Posted: Jun 29, 2013 @ 5:06pm
Posts: 27