ThePenciler Jun 21, 2013 @ 8:17am
[SOLVED] Problems running Steam in Ubuntu 13.04
[ This is not spam. I was redirected here. ]

Asus A7N8X-E Deluxe
AMD Athlon XP 3200+
XFX GeForce 6200 (using the proprietary drivers)
2GB RAM
80GB SATA HDD

Running Steam on ubuntu 13.04 32-bit
STEAM_RUNTIME is enabled automatically
/home/ryan/.local/share/Steam/steam.sh: line 704: 3276 Illegal instruction (core dumped) $STEAM_DEBUGGER "$STEAMROOT/$PLATFORM/$STEAMEXE" "$@"
Installing bootstrap /home/ryan/.local/share/Steam/bootstrap.tar.xz
Running Steam on ubuntu 13.04 32-bit
STEAM_RUNTIME has been set by the user to: /home/ryan/.local/share/Steam/ubuntu12_32/steam-runtime
/home/ryan/.local/share/Steam/steam.sh: line 704: 3362 Illegal instruction (core dumped) $STEAM_DEBUGGER "$STEAMROOT/$PLATFORM/$STEAMEXE" "$@"

STEAM_RUNTIME=0 steam does not work. I am aware that Big Picture and most modern games will not work on my old setup, I am just testing to see what does.

If a solution is found I will summarize it at the end of the topic for anybody who found this through a search engine and is having the same problem I am. I am sure we are all tired of the [SOLVED] topics that never go into detail about how the problem was solved. ;)

[UPDATE] CPU's just too old. http://steamcommunity.com/app/221410/discussions/0/864971287549327568/?tscn=1371828079#c864971287569846986 Oh well.
Last edited by ThePenciler; Jun 21, 2013 @ 12:26pm
Showing 1-15 of 19 comments
< >
Doc Holliday Jun 21, 2013 @ 8:21am 
did you install it as root?
Doc Holliday Jun 21, 2013 @ 8:25am 
open a terminal
sudo apt-get purge steam
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install steam-launcher
ThePenciler Jun 21, 2013 @ 8:29am 
Nope, I just went to the Ubuntu Software Center app and installed it from there (the first time) just as one would expect. Reinstalled Ubuntu (because of an unrelated problem), then installed Steam from the steam-latest.deb package. These installs are both on fresh installs of Ubuntu each time (login first time, activate nVidia driver, then attempt to install Steam). More work for me, but I wanted to rule everything else out. Same problem. Should I have? The Ubuntu Software Center Steam as well as the downloaded deb package both asked me to enter the current user's password (not root). The user account is part of the sudoers list.
Last edited by ThePenciler; Jun 21, 2013 @ 10:14am
ThePenciler Jun 21, 2013 @ 8:30am 
Originally posted by Doc Holliday:
open a terminal
sudo apt-get purge steam
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install steam-launcher

Ok, I'll try this. Thanks!
instabilis Jun 21, 2013 @ 8:32am 
Why are you running STEAM_RUNTIME=0 steam?

Usually it's STEAM_RUNTIME=1 steam, to force steam to use it's own libs.
Last edited by instabilis; Jun 21, 2013 @ 8:34am
ThePenciler Jun 21, 2013 @ 8:54am 
Originally posted by instabilis:
Why are you running STEAM_RUNTIME=0 steam?

Usually it's STEAM_RUNTIME=1 steam, to force steam to use it's own libs.

It was one of the solutions offered in other forums outside of steamcommunity.com (searching for a similar problem through Google). I had no idea what it did at the time though I suspected it did what you described, but it was one of the suggestions. So I tried it, I didn't see any difference. NOTE: I DID NOT use STEAM_RUNTIME=0 steam every time to start Steam. I used it upon finding that command online. Once I noticed it didn't do anything, I didn't use it again. I also used STEAM_RUNTIME=1 steam to force steam to use its own libraries or whatever it did. No difference. Same outcome.
Last edited by ThePenciler; Jun 21, 2013 @ 9:08am
instabilis Jun 21, 2013 @ 9:23am 
Try running DEBUGGER=gdb steam, hopefully that should give a more useful output.

Ref: https://github.com/ValveSoftware/steam-for-linux/issues/2019#issuecomment-14091779
Last edited by instabilis; Jun 21, 2013 @ 9:27am
Doc Holliday Jun 21, 2013 @ 9:56am 
i forgot to addon in once you do a upgrade you may need to reboot
ThePenciler Jun 21, 2013 @ 10:29am 
Originally posted by Doc Holliday:
open a terminal
sudo apt-get purge steam
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install steam-launcher

Ok, so I did all this and it looked like it was doing something, but when I entered the last line I got this:

Running Steam on ubuntu 13.04 32-bit
STEAM_RUNTIME is enabled automatically
/home/ryan/.local/share/Steam/steam.sh: line 700: 3755 Illegal instruction (core dumped) $STEAM_DEBUGGER "$STEAMROOT/$PLATFORM/$STEAMEXE" "$@"
Installing bootstrap /home/ryan/.local/share/Steam/bootstrap.tar.xz
Running Steam on ubuntu 13.04 32-bit
STEAM_RUNTIME has been set by the user to: /home/ryan/.local/share/Steam/ubuntu12_32/steam-runtime
/home/ryan/.local/share/Steam/steam.sh: line 704: 3841 Illegal instruction (core dumped) $STEAM_DEBUGGER "$STEAMROOT/$PLATFORM/$STEAMEXE" "$@"

I did nothing else and this is what it says in the Terminal right now. This is after installing from the proper Canonical location, the Ubuntu Software Center.
ThePenciler Jun 21, 2013 @ 10:34am 
Ran steam again, this time instead of line 700: 3755 it says line 704: 4150 and the second illegal instruction is line 704: 4236.
Last edited by ThePenciler; Jun 21, 2013 @ 10:34am
ThePenciler Jun 21, 2013 @ 10:36am 
Shoot, I forgot to restart. Sorry.
ThePenciler Jun 21, 2013 @ 10:42am 
Running DEBUGGER=gdb steam got me this:

Running Steam on ubuntu 13.04 32-bit
STEAM_RUNTIME is enabled automatically
GNU gdb (GDB) 7.5.91.20130417-cvs-ubuntu
Copyright (C) 2013 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /home/ryan/.local/share/Steam/ubuntu12_32/steam...(no debugging symbols found)...done.

Not much to go on.
ThePenciler Jun 21, 2013 @ 10:48am 
I'm not averse to trying other Linux distros if that will get Steam to work if you would suggest that.
Floop the Pig Jun 21, 2013 @ 11:05am 
go archlinux
ThePenciler Jun 21, 2013 @ 11:37am 
Steam works best with Arch Linux?
Last edited by ThePenciler; Jun 21, 2013 @ 11:46am
Showing 1-15 of 19 comments
< >
Per page: 15 30 50
Date Posted: Jun 21, 2013 @ 8:17am
Posts: 19