Steam for Linux

Steam for Linux

ngshap Jun 21, 2013 @ 8:04am
Help Please?
So Everything used to work, and some games (Dota 2 and Cubemen, for example) still do, but all others briefly turn the screen black or flash a loading screen before crashing. I run steam with optirun from the terminal; here is the output when trying to load TF2:



Game update: AppID 440 "Team Fortress 2", ProcID 3306, IP 0.0.0.0:0 (steam:2541): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent. (steam:2541): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent. (steam:2541): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent. (steam:2541): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent. (steam:2541): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent. (steam:2541): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent. (steam:2541): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent. (steam:2541): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent. (steam:2541): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent. (steam:2541): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent. (steam:2541): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent. (steam:2541): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent. (steam:2541): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent. (steam:2541): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent. (steam:2541): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent. (steam:2541): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent. (steam:2541): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent. (steam:2541): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent. (steam:2541): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent. (steam:2541): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent. (steam:2541): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent. (steam:2541): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent. (steam:2541): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent. (steam:2541): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent. (steam:2541): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent. (steam:2541): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent. (steam:2541): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent. (steam:2541): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent. (steam:2541): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent. (steam:2541): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent. SDL video target is 'x11' SDL video target is 'x11' SDL failed to create GL compatibility profile (whichProfile=0)! [VGL] NOTICE: Pixel format of 2D X server does not match pixel format of [VGL] Pbuffer. Disabling PBO readback. Installing breakpad exception handler for appid(gameoverlayui)/version(20130620130449_client) Installing breakpad exception handler for appid(gameoverlayui)/version(1.0_client) Installing breakpad exception handler for appid(gameoverlayui)/version(1.0_client) Installing breakpad exception handler for appid(gameoverlayui)/version(1.0_client) [0621/105720:WARNING:proxy_service.cc(958)] PAC support disabled because there is no system implementation Using breakpad crash handler Setting breakpad minidump AppID = 440 Forcing breakpad minidump interfaces to load Looking up breakpad interfaces from steamclient Calling BreakpadMiniDumpSystemInit Looking up breakpad interfaces from steamclient Calling BreakpadMiniDumpSystemInit Steam_SetMinidumpSteamID: Caching Steam ID: 76561198072516959 [API loaded yes] Steam_SetMinidumpSteamID: Setting Steam ID: 76561198072516959 Did not detect any valid joysticks. [0621/105724:ERROR:resource_bundle.cc(411)] Failed to load /home/**********/Steam/SteamApps/common/Team Fortress 2/cef_gtk.pak Some features may not be available. [0621/105724:WARNING:proxy_service.cc(646)] PAC support disabled because there is no system implementation The program 'hl2_linux' received an X Window System error. This probably reflects a bug in the program. The error was 'BadDrawable (invalid Pixmap or Window parameter)'. (Details: serial 139 error_code 9 request_code 14 minor_code 0) (Note to programmers: normally, X errors are reported asynchronously; that is, you will receive the error a while after causing it. To debug your program, run it with the --sync command line option to change this behavior. You can then get a meaningful backtrace from your debugger if you break on the gdk_x_error() function.) /home/**********/Steam/SteamApps/common/Team Fortress 2/hl2.sh: line 67: 3310 Segmentation fault (core dumped) ${GAME_DEBUGGER} "${GAMEROOT}"/${GAMEEXE} "$@" Game removed: AppID 440 "Team Fortress 2", ProcID 3310



I have Ubunutu 12.04 and proprietary drivers for an Nvidia 670m.

I tried purging and reinstalling Steam with no change.
< >
Showing 1-2 of 2 comments
Dusk of Oolacile Jun 21, 2013 @ 8:06am 
You should try reinstalling the nvidia driver instead.
gutigen Jun 21, 2013 @ 8:51am 
Your GPU is pretty recent so I advice to upgrade to Ubuntu 13.04 instead, update system, then install latest drivers from Xorg Edgers: https://launchpad.net/~xorg-edgers/+archive/ppa

However after adding that PPA, do not install all the updates it gives, just nvidia-319 package, then remove Xorg Edgers PPA (packages from that PPA are VERY experimental, you don't want to mess up your system for no reason).
Last edited by gutigen; Jun 21, 2013 @ 8:51am
< >
Showing 1-2 of 2 comments
Per page: 15 30 50

Date Posted: Jun 21, 2013 @ 8:04am
Posts: 2