Steam for Linux > Γενικές συζητήσεις > Λεπτομέρειες θέματος
/>yummypixza_ 12 Ιουν, 2013 @ 11:55πμ
no Steam tray or daemon on Fedora 19
same as title,
I just see many screenshot shows that tray icon is available, I can also find the icon it use under the folder.
but when I try to press close button, Steam quits instead of minimize to tray.
there's also no options for choose behaviors, any ideas?

using Skype Linux ver and Skype works well, so is there something wrong on my Steam setup?

spec: Fedora 19 x86_64
Gnome 3.8.2
SELinux: default (full-on I think?)
repo: "spot" 's Steam repo
Εμφάνιση 1-9 από 9 σχόλια
< >
/>yummypixza_ 12 Ιουν, 2013 @ 11:58πμ 
one more thing, if I don't want to change any SELinux settings, is that OK to just ignore every warning related to Steam?
instabilis 12 Ιουν, 2013 @ 12:03μμ 
When you run steam via terminal is the steam runtime being enabled? Also, have you checked you have all the 32-bit dependences installed?
/>yummypixza_ 12 Ιουν, 2013 @ 12:07μμ 
yes, i've tried both via Terminal or gnome-shell directly. and I've installed all dependences while yum install, unless the repo's dependences lacks other harmless stuff :P
instabilis 12 Ιουν, 2013 @ 12:10μμ 
When you launch via terminal there should be a message like "STEAM_RUNTIME is enabled automatically", even if you have Steam already running.
Τελευταία επεξεργασία από instabilis; 12 Ιουν, 2013 @ 12:11μμ
Shark 13 Ιουν, 2013 @ 12:44πμ 
Fedora uses gnome, move the mouse to the bottom right corner of the screen and you should see the system tray popping up.

You will need to change SElinux settings to install Steam games iirc.
Τελευταία επεξεργασία από Shark; 13 Ιουν, 2013 @ 12:46πμ
/>yummypixza_ 13 Ιουν, 2013 @ 4:11πμ 
@instabilis: uh... no, i don't got that message. should i reinstall again?
@Wouter: yes, i'm sure i got that, skype tray is there, too. so is that a "must" to turn off SELinux even before install Steam?
Shark 13 Ιουν, 2013 @ 5:14πμ 
Αναρτήθηκε αρχικά από />yummypixza_:
@instabilis: uh... no, i don't got that message. should i reinstall again?
@Wouter: yes, i'm sure i got that, skype tray is there, too. so is that a "must" to turn off SELinux even before install Steam?
You could program SELinux to accept Steam, but I personally just turned it off since there is also a small performance hit assosiated with running SELinux. Kinda weird that steam doesn't go into the tray though. I'm not sure if I have the same issue since I installed Fedora like yesterday and I'm currently using my laptop(which runs Ubuntu).
instabilis 13 Ιουν, 2013 @ 6:46πμ 
Αναρτήθηκε αρχικά από />yummypixza_:
@instabilis: uh... no, i don't got that message. should i reinstall again?
@Wouter: yes, i'm sure i got that, skype tray is there, too. so is that a "must" to turn off SELinux even before install Steam?
Try running Steam in terminal with the following:
STEAM_RUNTIME=1 steam
This should force the runtime to be enabled, without the runtime you won't get the tray icon.

SELinux shouldn't have a problem with Steam, at least it never did in Fedora 17 or 18. I doubt 19 is any different, and I wouldn't recommened turning SELinux off completely.
Τελευταία επεξεργασία από instabilis; 13 Ιουν, 2013 @ 6:53πμ
thetargos 15 Ιουν, 2013 @ 4:11μμ 
I remember I had to enable a boolean or two for Steam on F18 x86_64 or was it a policy? I don't remember, but going into troubleshoot (in setroubleshoot app) and following the instructions there will prevent SE to mess with Steam and never again have problems.
Εμφάνιση 1-9 από 9 σχόλια
< >
Ανά σελίδα: 15 30 50
Ημ/νία ανάρτησης: 12 Ιουν, 2013 @ 11:55πμ
Αναρτήσεις: 9