imok Mar 10, 2013 @ 7:13pm
Steam has caused serious issues for my PC
Hopefully someone will help me, as I had issues running games on steam(only loaded black screen), and eventually I followed some "advice" to install the mesa stack from the ubuntu wiki, then rebooted my laptop and all I see is a light blue screen. Now the details and the story how this all happened...

I was running xubuntu 12.04 LTS on the following laptop: Dell Inspiron 1545, intel core duo t6600 @ 2.20GHz (2 cpu) ~2.2GHZ(I recall linux telling me I had 2.4GHz or something like that - don't know as I can't check now) with 3GB of memory. As for the graphics card, all I know is: mobile intel 4 series express chipset family 1292mb 60hz. Sorry if this is not all what is needed, I am unable to access my specs on linux, so I had to use my brothers laptop(same one) and use dxdiag.

Now my "story". Yesterday I was running xubuntu 11.04. Last night I upgraded to 11.10 and then to 12.04 LTS, there were no problems doing this. Earlier I install steam, update it, and nearly everything went smooth from here. I had some minor issues, nothing major, just some blob issues when steam did not close properly. Besides that, well it went well. I downloaded cs:s and once it was finally finished I attempt to play it. I of course received the error telling me to install support for S3TC, which I of course looked into. I read several discussions on steam about potential fixes. I tried using the runtime line(right word?) in the terminal and installed some packages mentioned in discussion. The packages I installed:

sudo apt-get install libtxc-dxtn-s2tc0
[ "$(uname -m)" = "x86_64" ] && sudo apt-get install libtxc-dxtn-s2tc0:i386

Doing the above, along with:
force_s3tc_enable=true steam
I was able to "successfully" boot up cs:s, although it didn't exactly work. I tried starting it several times, only to have to close it and try again. All I would get was a black screen and see my mouse. So after this I continued to search around and found the following "advice"...

https://wiki.ubuntu.com/Valve (intel graphics)

I entered the following in terminal with no problems:

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get dist-upgrade

After I rebooted my computer like the instructions told me. I REALLY thought this would be the fix based off what I was reading, I didn't think this would go wrong, solely based on having an intel card. Boy was I wrong! I rebooted my computer(several times in fact) with the same result, it kept just pausing at the "intermediate" screen between logging in(showed the 12.04 LTS home(purple/orange) fine, and then just stayed there. That is now my desktop whenever I boot up. I can't do anything as far as I know. I can't enter terminal or do anything, as far as I understand. I am not the best with linux so I could really use the help!

I would GREATLY APPRECIATE someone helping me out with this. I was really looking forward to being able to play some great games on steam on the go, and most importantly I need this laptop functioning for school. I know my current situation is more of a "linux problem", versus a steam one, although I was in the process of following suggested advice to getting steam working, and now my computer is all weird.

Like I said before, I would greatly appreciate any advice how to begin fixing my problem, and if you need ANY more information(hardware etc) just let me know, I will do my best to obtain it.

Thank You!



Showing 1-15 of 23 comments
< >
HarlemSquirrel Mar 10, 2013 @ 7:16pm 
I would suggest starting with a clean slate: install a fresh copy of Ubuntu 12.10, download all updates, then install steam. I have had many issues with Ubuntu when upgrading to new versions.
Selthus Mar 10, 2013 @ 7:24pm 
I'd also do a fresh install if you have the time. I was thinking that the last command you used was for ati/Nvidia cards. I may be wrong. I'm pretty nooby. I usually just end up downloading my gfx driver from the additional drivers ubuntu offers. I'm guessing that wasn't an option for you?

imok Mar 10, 2013 @ 7:27pm 
I could do a fresh install, the problem is that there are important files on there for school that I would rather avoid having lost, if at all possible.
HarlemSquirrel Mar 10, 2013 @ 7:30pm 
the first 3 rules of computing: backup, backup, and backup. The more important the data, the more places you should have it. Burn a CD/DVD, thow the files on a flash drive, or email them to yourself (all depends on the type/size/quantity of files you have). If you have less than 5GB to backup and a strong internet connection, Ubuntu One can be great! Dropbox is also great if you have 2GB or less. Ubuntu One can also save your settings.
pepe33l Mar 10, 2013 @ 7:48pm 
READ all of this twice before even trying. I checked all the commands, although I'm not sure if I forgot something:
In the boot menu (if you have one, it's called the grub screen. If you can't see it, press shift when booting), go to the "ubuntu recovery" option (or whatever is called), and press enter.
If there isn't a recovery option, highlight "ubuntu..." in the list with the arrow keys, and press e, then remove "splash quiet" and add "init=/bin/bash", and you will get a console.
The sad part is that you'll need to revert the packages, but I guess you don't know how to use the console... but anyway, if you want to try, run this, but you will probably need internet (unless the packages are still in the cache):
sudo mount -o remount,rw /
sudo ppa-purge ppa:ubuntu-x-swat/x-updates
How to get an internet connection? if you are using wifi, then I don't know how to do it easily. If you are using the cable, from this command you will see the network interfaces:
ifconfig -a
from there, you'll see names like: eth0, eth1, lo, wlan0, etc.
if you see eth(something), run:
ifconfig eth(something) up; dhclient -v eth(something)
obviously, remove '(' and ')' and replace "something" with, 0 or 1 or whatever number you see.
After all of this (make sure the system isn't doing anything), reboot by pressing ctrl+alt+del, or type 'reboot' and press enter.
If you need more help, go to this website: http://webchat.freenode.net/?channels=#ubuntu , select a nickname and ask in that channel for help (and show them this post for reference).
I wrote this from memory, but I hope it helps.
imok Mar 10, 2013 @ 8:16pm 
Thank you pepe, a decent amount of that makes sense. I was wondering if you could help me with one small thing though, it turns out I have a "failsafe" account(apparently I thought ahead), and yes that means I am able to log into it fine, unlike my other one. It has steam installed, yet the issues don't apply to this one. I don't have much access, though is there anyway I could remove the package from this account? What I am asking(to put it simply, I am tired) is would it be possible to revert those changes to allow me to use that login normally again, and all through another login that boots fine?

Thank you for your help so far.
pepe33l Mar 10, 2013 @ 8:22pm 
Yes, just run "sudo ppa-purge ppa:ubuntu-x-swat/x-updates" from the console, enter your password, read the instructions (if any) and wait for it to remove the packages. after that, reboot.
imok Mar 10, 2013 @ 8:53pm 
Last update for the evening, that is if you don't mind... it told me that was a invalid command, so I went to the pkg manager and manually removed the ppa's from the list(both swats). I rebooted and things are a little better. On the previous account(the main one I always use, also the one with all the issues) I can now see the task bar at the top, browse file locations etc. Although I still have the loading screen as my wallpaper and I cannot see all of my files. I don't think I completely removed the package. Any ideas how to fix this? Do I need to completely remove it some how? Again, thank you for putting up with my tired self. I am going to bed, I am done playing around with this.

I should add I cannot use things like "File" etc once inside the package manager. For example, I can select a package, yet I cannot click view, edit, etc.
pepe33l Mar 11, 2013 @ 11:05am 
I guess the desktop environment got corrupted or something.
What error msg did you get? If it says: "ppa-purge: command not found", install the ppa-purge package in your package manager.
I don't use the graphical package manager or unity, so I don't know how are you doing things.. but you need to use ppa-purge to revert the changes, not just remove the ppa.
imok Mar 11, 2013 @ 11:26am 
I installed the package, only to have it tell me this:

mike@imok-laptop:~$ sudo ppa-purge ppa:ubuntu-x-swat/x-updates
[sudo] password for mike:
Updating packages lists
PPA to be removed: ubuntu-x-swat x-updates
Warning: Could not find package list for PPA: ubuntu-x-swat x-updates
mike@imok-laptop:~$

I even attempted to do it as the user(imok) who is having all the problems, I got the same issue with not being able to find the package list. I then thought of the idea to re add the PPA, in hopes that it would work, as I would think the pkg's are obviously still there. The result?

mike@imok-laptop:~$ sudo ppa-purge ppa:ubuntu-x-swat/x-updates
[sudo] password for mike:
Updating packages lists
PPA to be removed: ubuntu-x-swat x-updates
Package revert list generated:
libva1:i386/quantal nvidia-settings/quantal

Disabling ubuntu-x-swat PPA from
/etc/apt/sources.list.d/ubuntu-x-swat-x-updates-precise.list
Updating packages lists
Reading package lists... Done
Building dependency tree
Reading state information... Done
libva1 is already the newest version.
libva1 set to manually installed.
Selected version '1.0.15-4build1' (Ubuntu:12.10/quantal [i386]) for 'libva1'
Selected version '304.51-0ubuntu2' (Ubuntu:12.10/quantal [i386]) for 'nvidia-settings'
The following packages were automatically installed and are no longer required:
compiz-plugins compiz-plugins-main python-argparse
Use 'apt-get autoremove' to remove them.
The following packages will be DOWNGRADED:
nvidia-settings
0 upgraded, 0 newly installed, 1 downgraded, 0 to remove and 0 not upgraded.
Need to get 1,803 kB of archives.
After this operation, 1,409 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://us.archive.ubuntu.com/ubuntu/ quantal/main nvidia-settings i386 304.51-0ubuntu2 [1,803 kB]
Fetched 1,803 kB in 7s (243 kB/s)
dpkg: warning: downgrading nvidia-settings from 304.84-0ubuntu1~precise~xup1 to 304.51-0ubuntu2
(Reading database ... 305792 files and directories currently installed.)
Preparing to replace nvidia-settings 304.84-0ubuntu1~precise~xup1 (using .../nvidia-settings_304.51-0ubuntu2_i386.deb) ...
Unpacking replacement nvidia-settings ...
Processing triggers for man-db ...
Setting up nvidia-settings (304.51-0ubuntu2) ...
update-alternatives: warning: forcing reinstallation of alternative /usr/lib/nvidia-settings/ld.so.conf because link group nvidia_settings_conf is broken
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
PPA purged successfully
mike@imok-laptop:~$

If none of this works, should I just copy anything I need to this user(+ backup elsewhere), then delete my other user and use this new one? I really don't feel like having to start completely over.

EDIT: I tried rebooting twice with no luck, each time I would see my desktop, then it would turn in this white-grayish color, and I could only see my task bar at the top. Trying to use anything(like a browser, terminal, file manager) was extremely laggy and got me no where.
pepe33l Mar 11, 2013 @ 11:43am 
That should be more than enough to fix the blue screen thing.
BTW, ppas are not installed per user, but for the whole system, so you don't need to run things for every user.
Now, if you still have problems with the desktop, you should try reconfiguring it or renaming the config. folder, but I don't know how to do that for unity, so use google for that. The best thing you could do if to go to that web chat and ask there.
For the original problem with CS:S, you should file a bug report (if there are no similar reports) and wait for a response from valve. From what I read you have an intel graphics card. Are you sure it is supported at all?
imok Mar 11, 2013 @ 11:53am 
Nope, I still have issues when logging on to that account. And as for the ppa's I thought so, though how come this didn't have any effect on the user I am currently on, it has no problems? Would messing with the config really help the lag and other issues I am facing? As for the graphics card... I don't know for 100% if mine is supported, although I know intel is. When I google to try and find out I get results to tell me to do the exact thing that got me in this mess.

What would happen if I was to back everything up and copy it over to this user, then simply delete the user with all the issues? That would take some time, though based on where this is going, well I think it is starting to come down to that.

Yes, even with ppa's removed, I still have issues using that account :(
CausticGoon Mar 11, 2013 @ 12:02pm 
Oh my god, you went from 11.04 in place to 12.10? Yeesh.
pepe33l Mar 11, 2013 @ 12:05pm 
You could copy all the data, yes, but there is no need to do that. In ubuntu/debian, you can fix things by reinstalling/reconfiguring them, all of this from the package manager (apt-get, synaptic, ...). If you want a quick fix, try installing another Desktop Environment. A lightweight one is LXDE, which you can install by running: sudo apt-get install lxde-common (or "lxde", I'm not sure). There are also XFCE (xfce4-session), etc.
imok Mar 11, 2013 @ 12:15pm 
I tried multiple desktop environments, none of them worked.
Showing 1-15 of 23 comments
< >
Per page: 15 30 50
Date Posted: Mar 10, 2013 @ 7:13pm
Posts: 23