Steam for Linux > Algemene discussies > Details van topic
Junior s2 Camila 7 mrt 2013 om 8:55vm
Those having problems with NVIDIA MUST read this!
Gee, such a simple fix for the fps drop! No Kernel upgrade, no scripts, nothing!

Simply open the Terminal and type "sudo nvidia-settings"

Next go to "Nvidia Settings configuration" and there change "Power Mizer Monitor" to 60000 and uncheck that box. There you go =)

http://img585.imageshack.us/img585/4190/selection001a.png

Now only thing left is solve that problem with HDR.

Don't forget to uncheck "Sync to v-blank" as well, to make sure your mouse works properly.

Please respond if this fixed your problems, I'm almost crying here!
Hope it helps more out there!
Laatst bewerkt door Junior s2 Camila; 7 mrt 2013 om 9:06vm
1-10 van 10 reacties weergegeven
< >
compholio 7 mrt 2013 om 10:19vm 
You shouldn't need to change the number of you uncheck the box, that should disable the timer. What card do you have that this was posing a problem?
blackout24 7 mrt 2013 om 10:51vm 
Why change the value when you disable it anyway?
☮ Grimssonur ☮ 7 mrt 2013 om 12:23nm 
Hmm, I changed that option and unchecked the box, but nothing noticeable happened after.
Observing same fps drops in KillingFloor and same high CPU consumption at both PCs (higher than on Windows). Have GTX550Ti 1Gb and GTS450 1Gb, (driver ver. 313.18) With last one have bigger problems (drops to 9-6 fps sometimes, unlike on Windows where it's never lower than 60 on same PC)
Laatst bewerkt door ☮ Grimssonur ☮; 7 mrt 2013 om 12:54nm
Junior s2 Camila 7 mrt 2013 om 12:40nm 
I don't know but just disabling that box didn't fix that for me on TF2. Other games I can't tell.
gutigen o) 7 mrt 2013 om 1:17nm 
Mate, can you switch back to 1000ms and change Power Mizer from Adaptive to Performance and see how this affect your framerate?
Junior s2 Camila 7 mrt 2013 om 1:30nm 
Origineel geplaatst door gutigen o) Gnome:
Mate, can you switch back to 1000ms and change Power Mizer from Adaptive to Performance and see how this affect your framerate?
It usually starts at 10fps, or starts at normal rate then after selecting a dummie it drops to 10.

https://github.com/ValveSoftware/steam-for-linux/issues/2106
CarrotDick 7 mrt 2013 om 5:28nm 
"""MUST READ THIS!!!1111oneoneone"""


Sigh...

Did you happen to do any research as to what those timers do?

Those "timers" simply repoll the GPU for that information to display it in the Nvidia-settings application. Unchecking them is almost guaranteedly doing NOTHING, except making the information in nvidia-settings be inaccurate and out-dated.

If anything, gutigen o) [GNOME] is completely right. My 660 takes "long enough" from Adaptive to ramp up that it makes compositing my window manager and games lag a bit at lulls. Switching PowerMizer to stay in "Prefer Maximum Performance" will cause noticeable changes.

The only problem is, I haven't looked into how to set it at boot. Currently, each time you reboot you must reset that preference.
Laatst bewerkt door CarrotDick; 7 mrt 2013 om 5:39nm
CarrotDick 7 mrt 2013 om 5:35nm 
And in "picture form":

http://i.imgur.com/jaaRebj.png

And I spelled disabling wrong. Oh well, I'll live.
Laatst bewerkt door CarrotDick; 7 mrt 2013 om 5:36nm
thetargos 7 mrt 2013 om 5:38nm 
This is what I don't understand: I do have the same graphics card. The first time I used TF2 on Linux was with my previous machine, an AMD X2 5600+ CPU meager 2GiB RAM DDR2 800; the very same graphics card as the OP, 9800GT 512MiB VRAM (XFX), 1080p resolution and the game (albeit in the training sessions, and off-line playing) worked very well without any major FPS drop (sure depending on the action on screen it would fluctuate, but never drop bellow upper 30s). And this on Fedora 17 (then 18) x86_64, nVidia 304.64 graphics driver (313 has issues with this graphics card in other games such as SC2).

With my current setup I have been able to play other games at higher speeds or with lower load times, but essentially the same.

Edit: I'm not sure if the card of the OP as mine, has only one PowerMizer state, Maximum performance.
Laatst bewerkt door thetargos; 7 mrt 2013 om 5:39nm
Junior s2 Camila 8 mrt 2013 om 5:23vm 
@Atheisto

I really don't know WHY, but this fixes my fps problem. Settings to "Maximum performance" also didn't change the fact that frame rates would drop, or even start at 10. So for me that changes everything.
Also, setting the timer from 1000 to 100 causes the game to hold longer on normal rates. Setting to 60000 and then disabling it fixed my problem. Just because you think it doesn't change anything doesn't mean it actually does nothing.

@thetargos

Offline playing works fine with no changes to the nvidia.cfg, only is the problem.
My card is a MSI 9800GT 512MB
______________________________________

https://github.com/ValveSoftware/steam-for-linux/issues/2110
Laatst bewerkt door Junior s2 Camila; 8 mrt 2013 om 5:25vm
1-10 van 10 reacties weergegeven
< >
Per pagina: 15 30 50
Geplaatst op: 7 mrt 2013 om 8:55vm
Aantal berichten: 10