Steam for Linux > Általános témák > Téma részletei
NA 2013. márc. 6. @ du. 1:31
Xbox 360 controller 'fire' button permanently firing, Team Fortress 2
I was wondering if anybody else has been experiencing the same issue using an Xbox 360 gamepad (wired) with Team Fortress 2.

Everything works except for the 'fire' action (R2).

My character either won't fire to begin with, or, once he starts firing, won't stop. Then, once out of ammo, the character will keep reloading his weapon long after it is full.

Have tried with the console commands 'exec 360controller' and 'exec 360controller-linux'; makes no difference.

Thank you.
Legutóbb szerkesztette: NA; 2013. márc. 6. @ du. 1:37
17/7 megjegyzés mutatása
< >
richi902 2013. márc. 6. @ du. 2:04 
i have the exact same issue, also using a xbox360 wired controller
NA 2013. márc. 6. @ du. 2:14 
If you want to weigh in, I've raised the issue on Valve's github for Source 1 games:

https://github.com/ValveSoftware/Source-1-Games/issues/197
jonaS 2013. márc. 6. @ du. 3:22 
I had this issue because the trigger button was actually broken. The button would return to its normal position but would still be "firing." Just saying.
richi902 2013. márc. 6. @ du. 3:24 
the controller is working perfectly fine in serious sam 3 and other games(custom controller config in cs:s).
NA 2013. márc. 6. @ du. 3:56 
I also have success with Serious Sam 3 (controller works perfectly) along with a number of other games, and with firing normally in Counter-Strike: Source.
SUSEd 2013. márc. 6. @ du. 11:53 
richi902 eredeti hozzászólása:
the controller is working perfectly fine in serious sam 3 and other games(custom controller config in cs:s).
Can you post your config?
Cosmo (HOLIDAY GLORY) 2013. márc. 7. @ de. 5:07 
I had this bug on the 14th of Feb, and then it devolved into complete lack of recognition of my controller (only affected source 1 games) at all by the 16th. Just in case this happens to anyone else:

My Steam for Linux Discussions thread:

http://steamcommunity.com/app/221410/discussions/2/864960354125175880/

A related github issue report (link also on my thread):

http://github.com/ValveSoftware/Source-1-Games/issues/107

As for a way to work around the problem (works for both this issue and mine) I have had to resort to using xboxdrv, a driver similar to xpad (the default driver for 360 controllers etc that comes with some distros including Ubuntu), although it allows configuration, so you can bind buttons to your keyboard/the joysticks to your mouse, etc.

xboxdrv is sort of the linux equivilant of the Joy2Key program used on Windows.

Hopefully it should be available in your repositories, otherwise (for ubuntu) typing "apt-get install xboxdrv" should install it.

You will need to disable xpad each time you use xboxdrv using "rmmod xpad" (and/or blacklist it, use google or ask me for details). and you should write a configuration file.

There is no GUI front-end for xboxdrv I know of, it must be run/configured in a terminal, but it does work well.

Here is the web page for xboxdrv (there is manpage link on this page) http://pingus.seul.org/~grumbel/xboxdrv/

Hope this helps.

Regards,
Marcos Cosmos
Legutóbb szerkesztette: Cosmo (HOLIDAY GLORY); 2013. márc. 7. @ de. 5:09
17/7 megjegyzés mutatása
< >
Laponként: 15 30 50
Küldés ideje: 2013. márc. 6. @ du. 1:31
Hozzászólások: 7