Steam for Linux

Steam for Linux

Wine games in steam launcher
I have been trying to add my wine install of starcraft II into the steam launcher but I can't seem to get it to launch, as anyone else been able to get this to work
< >
Showing 1-9 of 9 comments
Obsidian Spirit Mar 4, 2013 @ 10:03am 
Hello,
I only have Steam games installed through wine, so can't really test this at the moment, but could you tell me the path string you used to create the custom launcher? Maybe there is a minor syntax error. Try using that through terminal and see if it provides any info.
It would be nice if Steams can have a configuration for wine to run games, like how playonlinux does.
If you are able to start the software with a little script then you can add it as external stuff.
Lhanna Mar 6, 2013 @ 8:48pm 
i got some games working with steam and playonlinux (the game installed on POL on linux but launched with steam native) try adding the desktop launcher of the game in steam and then add the line > --run "RANDOM GAME" example of the steam properties > "/usr/share/playonlinux/playonlinux" --run "StarCraft II"
Last edited by Lhanna; Mar 6, 2013 @ 8:54pm
[TIS]Pink_Panther Mar 13, 2013 @ 1:59pm 
I can see the nice part in your suggestions. On the otherhand if I was Valve I would fear that users suddenly would start to ask them for support over a bad wine game :s
omeara4pheonix Mar 28, 2013 @ 7:30pm 
I have tried some of the suggestions notably the one by maromi but it did not work. Steam will clame that I launched the game and other users will see me as in game for about 1 second but the game never loads. Could someone give me an example of what a script to launch it would be like so that i can try that method?
Dusk of Oolacile Mar 28, 2013 @ 7:34pm 
You probably have a wrong working directory.

1. Open a text editor
2. Type this:
cd /wherever/the/game/is/installed
wine whatevergameexe.exe

Save it somewhere and make it executable. Try running it from Steam.

The game path is probably something like /home/you/.wine/drive_c/Program Files (x86)/blablabla.
Last edited by Dusk of Oolacile; Mar 28, 2013 @ 7:36pm
TheCherry Nov 28, 2015 @ 8:14am 
Originally posted by Dusk of Oolacile:
You probably have a wrong working directory.

1. Open a text editor
2. Type this:
cd /wherever/the/game/is/installed
wine whatevergameexe.exe

Save it somewhere and make it executable. Try running it from Steam.

The game path is probably something like /home/you/.wine/drive_c/Program Files (x86)/blablabla.

Did try exactly that. Its dont work :(
I can start the bash manual and the game starts, but not from steam lib.
Want to play Diablo 3 with my SteamController :(
Last edited by TheCherry; Nov 28, 2015 @ 8:14am
Zileene Nov 28, 2015 @ 9:06am 
Here's my old diablo3.sh that I used to use to run D3. I hope it helps:

#!/bin/bash

export WINEARCH=win32 # Set 32bit prefix for wine
export WINEPREFIX="$HOME/.diablo3" # Tell wine where the bottle is
export WINEDEBUG=-all # Stop spamming the terminal with debug messages

# this runs the client. Edit the /desktop flag to fit your screen and the path to fit where the .exe really is.
setarch i686 -3 -L -B -R wine explorer /desktop=demon,1920x1080 $HOME/.diablo3/drive_c/Program\ Files/Diablo\ III/Diablo\ III.exe --opengl #This is supposed to be ONE LINE! Fix it when editing.

wait !$ # Wait for the game to exit (swap the symbols if it doesn't work. I always confuse the order)

unset WINEARCH
unset WINEPREFIX
unset WINEDEBUG

Save this to 'diablo3.sh' in your home directory, make it executable and test from a terminal.
Then add the file to Steam if it works.


Have Fun! :)
Z.
Last edited by Zileene; Nov 28, 2015 @ 9:08am
< >
Showing 1-9 of 9 comments
Per page: 15 30 50

Date Posted: Mar 4, 2013 @ 9:12am
Posts: 9