rodvil Mar 2, 2013 @ 3:56am
[Solved] The book of unwritten tales not starting - mint 14 (64-bit) /AMD Radeon HD 6320
Hello.
Nothing happens when I push play. If anyone can understand what is wrong or if already found a solution for this I would really appreciate the help.
I'm running Linux mint (64bit) . with a AMD Radeon HD 6320 and the graphics driver (open GL render) is listed as "Gallium 0.4 on AMD PALM". I'm using the open source driver (last time I tried the proprietary one some months back it broke my installation).
This is the output:
-------------
Failed to load installscript /home/rodvil/.local/share/Steam/SteamApps/common/The Book of Unwritten Tales/installscript.vdf
Game update: AppID 215160 "The Book of Unwritten Tales", ProcID 12107, IP 0.0.0.0:0
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
terminate called after throwing an instance of 'std::runtime_error'
what(): locale::facet::_S_create_c_locale name not valid
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully
/home/rodvil/.local/share/Steam/SteamApps/common/The Book of Unwritten Tales/bout.sh: line 8: 12109 Aborted (core dumped) LD_LIBRARY_PATH=$BASE_LIB_PATH/$BITS/:$LD_LIBRARY_PATH $BASE_BIN_PATH/$BITS/$EXE_NAME
Game removed: AppID 215160 "The Book of Unwritten Tales", ProcID 12107
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully
Last edited by rodvil; Mar 4, 2013 @ 3:41pm
Showing 1-13 of 13 comments
< >
fac3l3ss Mar 2, 2013 @ 4:16am 
The book of unwritten tales runs great, but I use Ubuntu and proprietary drivers, however it should run with open-source drivers. Install fglrx. Go to terminal and type sudo apt-get install fglrx. Or go to amd website, download the latest drivers and follow the instructions here: http://wiki.cchtml.com/index.php/Ubuntu_Precise_Installation_Guide
Don't forget to check if fglrx is blacklisted. If your /etc/modprobe.d/blacklist-local.conf contains blacklist fglrx make sure you comment out this line by adding a # in front of it.
Seph//roth Mar 2, 2013 @ 4:32am 
I had to disable the game overlay for my game to run! it's a known issue, right click on the game go to properties, then uncheck "enable steam community in-game"
fac3l3ss Mar 2, 2013 @ 4:46am 
Originally posted by Linux Tarron:
I had to disable the game overlay for my game to run! it's a known issue, right click on the game go to properties, then uncheck "enable steam community in-game"

I thought that was fixed by now. Critter chronicles runs with overlay on. But yes as posted above try to disable overlay and see if it works.
rodvil Mar 2, 2013 @ 5:41am 
I tried running it without the Steam overlay and the result is the same.
fac3I3ss: fglrx is the proprietary driver, right?
Did anyone managed to make it run on the open source driver?
towo01 Mar 2, 2013 @ 5:56am 
You have libgl1-mesa-glx:i386 installed?
Thyriel Mar 2, 2013 @ 8:01am 
did you try the community provided fix for 64bit non Ubuntu ?
http://steamcommunity.com/app/215160/discussions/0/864956554850893878/
rodvil Mar 2, 2013 @ 8:39am 
Yes, I have libgl1-mesa-glx:i386 installed.
Thyriel, I think that thread is for non debian distros, and linux mint is based on Ubuntu, so debian based.
But please correct me if I'm wrong...
Thyriel Mar 2, 2013 @ 9:12am 
thats true, but i needed to install that on Kubuntu too to get the options menu working, so i would give it a try
rodvil Mar 2, 2013 @ 10:34am 
I installed that fix, no changes. this is still the log I get:
---
Failed to load installscript /home/rodvil/.local/share/Steam/SteamApps/common/The Book of Unwritten Tales/installscript.vdf
Game update: AppID 215160 "The Book of Unwritten Tales", ProcID 29574, IP 0.0.0.0:0
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
terminate called after throwing an instance of 'std::runtime_error'
what(): locale::facet::_S_create_c_locale name not valid
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully
/home/rodvil/.local/share/Steam/SteamApps/common/The Book of Unwritten Tales/bout.sh: line 22: 29577 Aborted (core dumped) LD_LIBRARY_PATH=$BASE_LIB_PATH/$BITS/:$LD_LIBRARY_PATH $BASE_BIN_PATH/$BITS/$EXE_NAME
Game removed: AppID 215160 "The Book of Unwritten Tales", ProcID 29574
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully
fac3l3ss Mar 2, 2013 @ 6:19pm 
Rodvil, yes fglrx is the proprietary driver. I think you really need to install it.
DarkStarSword Mar 3, 2013 @ 6:07pm 
That sounds familiar, can you try this:

1. Completely close Steam, making sure it's not just running minimised or in the system tray (choosing Exit in the Steam menu should be fine)

2. Open a terminal, and enter these commands:
echo $LANG # (tell us the result)
export LANG=C
steam

3. Launch Book of Unwritten Tales from Steam.



If that works it means your locales are broken, which might cause other problems as well.
IIRC the way to regenerate your locales is by running (this is for Debian, but I think it will work for Mint as well):

dpkg-reconfigure locales

Make sure that the option corresponding to the output of echo $LANG above is selected (e.g for me, echo $LANG gives "en_AU.UTF-8", so I would select "en_AU.UTF-8 UTF-8"), then select OK and make sure it is set as the system default.

Applications that are still running won't get the new locale right away, so you might need to reboot to make sure that your system is now running with the correct locale.
rodvil Mar 4, 2013 @ 3:40pm 
thanks, darkstarsword, just by looking at those commands it reminded me that a couple of days I had solved someproblems I had starting another application. It turned out I had some locale options set to Portuguese but I didn't had that language pack fully installed. When i installed those the application worked fine. Now I tried again to start the game and it worked just fine!
Lesson, get the language packs for the local settings you chose!

Thanks everyone for the effort and help. This is why I love linux! ;)
DarkStarSword Mar 4, 2013 @ 5:02pm 
Glad to help :)
Showing 1-13 of 13 comments
< >
Per page: 15 30 50
Date Posted: Mar 2, 2013 @ 3:56am
Posts: 13