Steam for Linux

Steam for Linux

Steam stealing keyboard focus
I've noticed that some games: namely FTL and Bastion will have their keyboard input stop working sometimes. This is not a problem when launching the games without Steam- it only occurs when Steam is running.

I suspect that Steam is stealing keyboard focus away from the games in the same way that SDL games steal input away from the desktop environment, even though there's no reason for Steam to even need keyboard input at all since I don't even have a Steam window open :/

I have never had this happen with Half Life or TF2, however.

Has anyone else experienced this issue on other games?
< >
Showing 1-15 of 19 comments
640kB Oct 5, 2013 @ 6:41am 
I also experienced this issue with the game Natural Selection 2 and Killing Floor. I think it must be an issue with the windowmanager.

I have this problem under Gnome 3. If I start the game in the windowmanager fluxbox, I have no problems.
Toquinha Oct 5, 2013 @ 10:58am 
I had similar problems on Counter Strike: Condition Zero, under Unity. This is probably fixed for everyone by now but I'm not sure if it's related to the DE. If not, then just report the issue on Github and wait for the fix.
It doesn't happen on openSUSE/Arch with KDE.
Last edited by Toquinha; Oct 5, 2013 @ 12:39pm
640kB Oct 5, 2013 @ 11:12am 
Yeah, I also reported my experiences at github.
Toquinha Oct 5, 2013 @ 11:14am 
640kB, do you have a spare drive to test other DE's or maybe you'd be willing to test them on your current system install?
640kB Oct 5, 2013 @ 11:18am 
Yeah, I could test other DEs oder WMs. Any suggestions? For your information, i am using Arch Linux
Toquinha Oct 5, 2013 @ 11:23am 
You could try KDE. It doesn't happen on KDE for me.

sudo pacman -S kde
sudo systemctl enable kdm
sudo reboot

If you don't want to download the almost 800MB of KDE you can try the minimalistic version with

sudo pacman -S kdebase
Toquinha Oct 5, 2013 @ 11:24am 
Also, feel free to test other DE's, it may be a problem with GNOME.
I would try XFCE, which is roughly 70MB of download (without the xfce4-goodies)
Last edited by Toquinha; Oct 5, 2013 @ 11:25am
640kB Oct 5, 2013 @ 11:28am 
I could imagine, the problem is the window manager "mutter" in gnome 3. Is there a way to replace the window manager? I know, that was possible in gnome 2.

But I will try the minimalistic version of KDE.
Toquinha Oct 5, 2013 @ 11:36am 
There should be a way, yes, but you're gonna have to research on that. The default WM on KDE is Kwin, but you could have good results with others.

I wouldn't recommend you to try a WM that doesn't belong to your DE, but if you know what're doing you should be fine.
Users may prefer to install a full-fledged Desktop Environment,
I'm using Compiz so it's not specific to Mutter.
Toquinha Oct 5, 2013 @ 11:56am 
It happens in specific games, right? So it might not be WM related, but related to specific games.
640kB Oct 5, 2013 @ 12:26pm 
In KDE I have no problems with the keyboard input so far. I will test it for a week. Installing xfce4 now.

Yes, this issue is not present in every game.
Toquinha Oct 5, 2013 @ 12:32pm 
I don't think there will be problems if you 'sudo systemctl enable kdm'

But if problems appear than it's not WM related IMO
Last edited by Toquinha; Oct 5, 2013 @ 12:42pm
640kB Oct 5, 2013 @ 12:41pm 
Why should I enable kdm? Thats only the login manager.

Edit: No Problems in xfce4 so far. For now I can only reproduce this error in Gnome 3.
Last edited by 640kB; Oct 5, 2013 @ 1:20pm
UbuntuAddicted Jan 7, 2014 @ 12:30pm 
it happens to me using XFCE 4.10 in Xubuntu 12.04.3 with the game Deadfall Adventures. It makes the game unplayable pretty much since out of no where my character will be stuck moving forward even when i let go of the w key. sometimes if i hit the sc key it will bring up the menu, i can resume game and continue, other times the keyboard is completely unresponsive. very irritating to say the least.
< >
Showing 1-15 of 19 comments
Per page: 15 30 50

Date Posted: Feb 26, 2013 @ 3:05pm
Posts: 19