Steam for Linux

Steam for Linux

ByteBitten Feb 26, 2013 @ 7:27am
[Solved] (steam:11767): LIBDBUSMENU-GLIB-WARNING
Steam crashes on my Linux.
I had Steam running with an earlier version, but now it flashes for half a second before disappearing.

(steam:11767): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.
/home/[user]/.local/share/Steam/steam.sh: regel 700: 11767 Segmentatiefout $STEAM_DEBUGGER "$STEAMROOT/$PLATFORM/$STEAMEXE" "$@"

How to fix?
Last edited by ByteBitten; Mar 4, 2013 @ 4:21am
< >
Showing 1-7 of 7 comments
Shark Feb 26, 2013 @ 7:36am 
Ubuntu version, graphics card and driver version?
Teisei Feb 26, 2013 @ 7:54am 
> "Trying to remove a child that doesn't believe we're it's parent."
Seems legit.
ByteBitten Feb 26, 2013 @ 8:11am 
I use Linux Mint Cinnamon (Ubuntu packages) with an ATI Mobile Radeon HD5870 (AMD Catalyst Control Center 2.17)
Last edited by ByteBitten; Feb 26, 2013 @ 8:11am
_moo_ Feb 26, 2013 @ 8:27am 
Last edited by _moo_; Feb 26, 2013 @ 8:32am
_moo_ Feb 26, 2013 @ 8:44am 
update:
I could reproduce the error (german debugging)

~/.steam/steam/steam.sh: Zeile 700: 2828 Speicherzugriffsfehler $STEAM_DEBUGGER "$STEAMROOT/$PLATFORM/$STEAMEXE" "$@"

as soon as I used the big picture mode.

update2:
from what I'm reading its an issue with the graphic drivers (fglrx)
Last edited by _moo_; Feb 26, 2013 @ 8:59am
nilhoel Feb 26, 2013 @ 2:12pm 
if u are using a catalzst driver change your AntiAliasing settings to Filter:Box (change it in the AMD Catalzst Control Center)
this fixed the issue for me
ByteBitten Mar 4, 2013 @ 4:21am 
Took me some time before I could test it, but next to the Filter:Box you also need to tag the checkbox for ignoring some settings.
It works!
< >
Showing 1-7 of 7 comments
Per page: 15 30 50

Date Posted: Feb 26, 2013 @ 7:27am
Posts: 7