Steam for Linux > 一般討論 > 主題細節
chaorain 2013 年 02 月 25 日 @ 上午 7 時 08 分
Puddle not starting
When I try to launch Puddle from the GUI the screen flashes black for a second then returns to normal. Here is what happens from command line:

chaorain@CenteralChaos:~/.local/share/Steam/SteamApps/common/puddle$ ./Puddle ./Puddle: error while loading shared libraries: libXrandr.so.2: cannot open shared object file: No such file or directory

Any help would be appreciated.
顯示 1-4,共 4 則回應
< >
gutigen o) 2013 年 02 月 25 日 @ 上午 8 時 00 分 
If you are on Ubuntu (or Mint or other *buntu based distro), try this:
sudo apt-get install libxrandr2:i386
chaorain 2013 年 02 月 25 日 @ 上午 10 時 16 分 
Ok that helped but its not quite working. I got another error which I fixed with this command:
sudo apt-get install libGLU1-mesa:i386

Now I'm recieving the following error:
[S_API FAIL] SteamAPI_Init() failed; Sys_LoadModule failed to load: /home/chaorain/.steam/bin32/steamclient.so
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.dll.
I tried the solution at this link but no dice:
https://github.com/ValveSoftware/steam-for-linux/issues/33
gutigen o) 2013 年 02 月 25 日 @ 上午 10 時 36 分 
This may work, not sure tho: go to Steam folder and delete everything except SteamApps, start Steam.
chaorain 2013 年 02 月 25 日 @ 下午 3 時 03 分 
Nope, same error. By "Steam folder" I assume you meant
~/.local/share/Steam/
顯示 1-4,共 4 則回應
< >
每頁: 15 30 50
張貼日期: 2013 年 02 月 25 日 @ 上午 7 時 08 分
回覆: 4