Steam for Linux > 일반 토론 > 제목 정보
chaorain 2013년 2월 25일 오전 7시 08분
Puddle not starting
When I try to launch Puddle from the GUI the screen flashes black for a second then returns to normal. Here is what happens from command line:

chaorain@CenteralChaos:~/.local/share/Steam/SteamApps/common/puddle$ ./Puddle ./Puddle: error while loading shared libraries: libXrandr.so.2: cannot open shared object file: No such file or directory

Any help would be appreciated.
4개 중 1-4 표시중
< >
gutigen o) 2013년 2월 25일 오전 8시 00분 
If you are on Ubuntu (or Mint or other *buntu based distro), try this:
sudo apt-get install libxrandr2:i386
chaorain 2013년 2월 25일 오전 10시 16분 
Ok that helped but its not quite working. I got another error which I fixed with this command:
sudo apt-get install libGLU1-mesa:i386

Now I'm recieving the following error:
[S_API FAIL] SteamAPI_Init() failed; Sys_LoadModule failed to load: /home/chaorain/.steam/bin32/steamclient.so
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.dll.
I tried the solution at this link but no dice:
https://github.com/ValveSoftware/steam-for-linux/issues/33
gutigen o) 2013년 2월 25일 오전 10시 36분 
This may work, not sure tho: go to Steam folder and delete everything except SteamApps, start Steam.
chaorain 2013년 2월 25일 오후 3시 03분 
Nope, same error. By "Steam folder" I assume you meant
~/.local/share/Steam/
4개 중 1-4 표시중
< >
페이지당: 15 30 50
게시된 날짜: 2013년 2월 25일 오전 7시 08분
게시글: 4