KAKOW! Feb 24, 2013 @ 5:48pm
Help Installing Steam on Ubuntu
When I opened the installer for steam I got this: "Error: Dependency is not satisfiable: curl". Has anyone else encountered this error and have a solution or can point me to another discussion with the same problem/solution? Quick Update: Friend of mines who works with the OS said "curl" means it's pretty much impossible to install Steam, but the funny thing is that this doesn't happen to everyone it's more or less sporadic. If you came here in hopes of finding an answer to this problem, I'm sorry to say you've reached the end of the road, but do please leave a comment if someone has found a definite fix and my friend was wrong.
Last edited by KAKOW!; Feb 24, 2013 @ 7:12pm
Showing 1-9 of 9 comments
< >
Kolito Feb 24, 2013 @ 5:50pm 
Maybe try to put sudo apt-get install curl in a console? Try that and tell me if worked
xifu Feb 24, 2013 @ 6:11pm 
Which version of Ubuntu did you install?
Cosmo Feb 24, 2013 @ 6:30pm 
Actually, and I don't know how, but I've been prompted to install curl 3 times, and accidentally cancelled it the first 2 times, in the last 3 times I started steam, but was able to run despite this cancel. I'm not trying to suggest that you shouldn't install curl, but... how exactly did I do it without curl? Or, what else happened? O.o
KayKye Mar 6, 2013 @ 6:05am 
Easy fix for Ubuntu etc.

Step 1

sudo apt-get update


Then try
sudo apt-get install curl

If that doesnt install curl, proceed to step 2

sudo apt-get upgrade

Then try sudo apt-get install curl



That will work.
Last edited by KayKye; Mar 6, 2013 @ 6:05am
Gutiarist616 Oct 25, 2013 @ 10:58pm 
Worked like a charm. Thanks Kai.
Fb||SOZ I KILL YOUZ Jan 19 @ 10:07am 
I've tried this and it does not work for me. when I do: sudo apt-get upgrade nothing changes 0 updrades 0 installs and 0 removes. and none of the other commands work either.
sparkie5571@sparkie5571 ~> sudo apt-get install curl
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package curl is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'curl' has no installation candidate
This is what i get then trying to get curl
Kaede393 Jan 19 @ 3:36pm 
Maybe you could try: sudo apt-get install -f
That may search for every unsatisfied dependency and offer them to install. Also if the dependencys are not available in the repos it will let you know.
OldeFartz Jan 19 @ 6:26pm 
Read "man apt-get" and note the difference between "upgrade" and "dist-upgrade" (but always do "sudo apt-get update" first). "update" only updates existing packages, but does not install any additional packages or dependencies. "dist-upgrade" is smarter because it also installs any new dependencies.

Athough, normally you should not have to bother with that if you do system updates when the Software Updater comes up on your Unity bar or wherever other than doing "sudo apt-get update" before manually installing any packages from a terminal.

"curl" is similar to "wget" if you were familiar with that, for retrieving files by URL.
LOLCAT Jan 20 @ 3:46pm 
Originally posted by Fb||SOZ I KILL YOUZ:
Package X is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
Usually happens if you're using an ubuntu distro which is past its EOL. The update repos no longer exist, index files cannot be fetched and packages are not found.

What distro are you using?
Showing 1-9 of 9 comments
< >
Per page: 15 30 50