Steam for Linux > Általános témák > Téma részletei
Twister Senpai 2013. febr. 24. @ du. 3:24
Missing 32 bit library
I installed Steam onto Ubuntu and I get the following error message:

"You are missing the following 32-bit libraries, and Steam may not run:
not"

I have no idea what this means, any help would be appreciated!
115/30 megjegyzés mutatása
< >
slouken 2013. febr. 24. @ du. 3:27 
This should be fixed in the latest update:
http://repo.steampowered.com/steam/archive/precise/steam_latest.deb

After you install it, do:
steam --reset
Legutóbb szerkesztette: slouken; 2013. febr. 24. @ du. 3:28
Twister Senpai 2013. febr. 24. @ du. 3:37 
Thank you very much.
slouken 2013. febr. 24. @ du. 3:42 
You're welcome! :)
Professor Pat Pending 2013. febr. 24. @ du. 3:53 
Hi sorry what exactly do you mean by steam --reset ? i know its a silly question but i am quite lost

slouken eredeti hozzászólása:
This should be fixed in the latest update:
http://repo.steampowered.com/steam/archive/precise/steam_latest.deb

After you install it, do:
steam --reset
charis 2013. febr. 24. @ du. 4:20 
problem still persists.
###O?qÿáÓ 2013. febr. 24. @ du. 4:22 
Professor Pat Pending eredeti hozzászólása:
Hi sorry what exactly do you mean by steam --reset ? i know its a silly question but i am quite lost

slouken eredeti hozzászólása:
This should be fixed in the latest update:
http://repo.steampowered.com/steam/archive/precise/steam_latest.deb

After you install it, do:
steam --reset

Run this command in the terminal.

Ctrl + Alt + T.
ConVict | The_Hairy_Baboon 2013. febr. 24. @ du. 4:24 
slouken, I'm getting a similar problem. I downloaded steam, ran it and i get the error:
E: Unable to locate package libgl1-mesa-dri
E: Unable to locate package libgl1-mesa-glx
E: Unable to locate package libc6

and I redownloaded through the link you posted.

I tried doing steam --reset in the terminal, but that did not fix it.

I'm using ubuntu 12.10 64 bit


When I type steam into the terminal, i get this and the package installer that always fails.

Package libgl1-mesa-dri:i386 needs to be installed
Package libgl1-mesa-glx:i386 needs to be installed
Package libc6:i386 needs to be installed

How do i fix this?
slouken 2013. febr. 24. @ du. 4:49 
Thanks to Aikari Tsero, we figured this out.

if [ "$(dpkg --print-architecture)" = "amd64" ] && ! dpkg --print-foreign-architectures | grep i386 >/dev/null; then
echo "Fixing architectures..."
sudo dpkg --add-architecture i386
fi

I'm going to add this to steamdeps so it's automatically taken care of in the future.

Thanks!
grogbor 2013. febr. 24. @ du. 4:57 
I am having the same problem. Would you just suggest to wait? Or should I perform some sort of task to expedite the process?
###O?qÿáÓ 2013. febr. 24. @ du. 4:57 
grogbor eredeti hozzászólása:
I am having the same problem. Would you just suggest to wait? Or should I perform some sort of task to expedite the process?


slouken eredeti hozzászólása:
Thanks to Aikari Tsero, we figured this out.

if [ "$(dpkg --print-architecture)" = "amd64" ] && ! dpkg --print-foreign-architectures | grep i386 >/dev/null; then
echo "Fixing architectures..."
sudo dpkg --add-architecture i386
fi

I'm going to add this to steamdeps so it's automatically taken care of in the future.

Thanks!
grogbor 2013. febr. 24. @ du. 5:05 
Forgive me, I don't understand, do I type that into terminal or do I just wait. Thanks.
grogbor 2013. febr. 24. @ du. 5:17 
slouken, you wonderful adonis of a man, thank you.
ConVict | The_Hairy_Baboon 2013. febr. 24. @ du. 6:16 
slouken eredeti hozzászólása:
Thanks to Aikari Tsero, we figured this out.

if [ "$(dpkg --print-architecture)" = "amd64" ] && ! dpkg --print-foreign-architectures | grep i386 >/dev/null; then
echo "Fixing architectures..."
sudo dpkg --add-architecture i386
fi

I'm going to add this to steamdeps so it's automatically taken care of in the future.

Thanks!

Problem solved. found another thread with it where you said to run it. Ran that, steam worked. Thank you very much. Also, ubuntu has a lot of options windows should have. Like be connected to wifi and ethernet yet choose which to actually use when you want.
slouken 2013. febr. 24. @ du. 6:47 
Okay, for anyone who hasn't solved it already, you can do this:
sudo apt-get update
sudo apt-get install steam-launcher
steam

(Or you can use update-manager to update steam-launcher)
ZbynA 2013. febr. 26. @ du. 4:11 
Hi, problem persists: LinuxMint 14 (nadia), GCC 4.7 (x86_64-linux-gnu)
115/30 megjegyzés mutatása
< >
Laponként: 15 30 50
Küldés ideje: 2013. febr. 24. @ du. 3:24
Hozzászólások: 30