Steam for Linux > Общи дискусии > Подробности за темата
Mr. Twister The Sister Fister 24 февруари 2013 в 3:24след.
Missing 32 bit library
I installed Steam onto Ubuntu and I get the following error message:

"You are missing the following 32-bit libraries, and Steam may not run:
not"

I have no idea what this means, any help would be appreciated!
Показване на 1-15 от 30 коментара
< >
slouken 24 февруари 2013 в 3:27след. 
This should be fixed in the latest update:
http://repo.steampowered.com/steam/archive/precise/steam_latest.deb

After you install it, do:
steam --reset
Последно редактиран от slouken; 24 февруари 2013 в 3:28след.
Mr. Twister The Sister Fister 24 февруари 2013 в 3:37след. 
Thank you very much.
slouken 24 февруари 2013 в 3:42след. 
You're welcome! :)
Professor Pat Pending 24 февруари 2013 в 3:53след. 
Hi sorry what exactly do you mean by steam --reset ? i know its a silly question but i am quite lost

Първоначално публикувано от slouken:
This should be fixed in the latest update:
http://repo.steampowered.com/steam/archive/precise/steam_latest.deb

After you install it, do:
steam --reset
charis 24 февруари 2013 в 4:20след. 
problem still persists.
###O?qÿáÓ 24 февруари 2013 в 4:22след. 
Първоначално публикувано от Professor Pat Pending:
Hi sorry what exactly do you mean by steam --reset ? i know its a silly question but i am quite lost

Първоначално публикувано от slouken:
This should be fixed in the latest update:
http://repo.steampowered.com/steam/archive/precise/steam_latest.deb

After you install it, do:
steam --reset

Run this command in the terminal.

Ctrl + Alt + T.
ConVict | The_Hairy_Baboon 24 февруари 2013 в 4:24след. 
slouken, I'm getting a similar problem. I downloaded steam, ran it and i get the error:
E: Unable to locate package libgl1-mesa-dri
E: Unable to locate package libgl1-mesa-glx
E: Unable to locate package libc6

and I redownloaded through the link you posted.

I tried doing steam --reset in the terminal, but that did not fix it.

I'm using ubuntu 12.10 64 bit


When I type steam into the terminal, i get this and the package installer that always fails.

Package libgl1-mesa-dri:i386 needs to be installed
Package libgl1-mesa-glx:i386 needs to be installed
Package libc6:i386 needs to be installed

How do i fix this?
slouken 24 февруари 2013 в 4:49след. 
Thanks to Aikari Tsero, we figured this out.

if [ "$(dpkg --print-architecture)" = "amd64" ] && ! dpkg --print-foreign-architectures | grep i386 >/dev/null; then
echo "Fixing architectures..."
sudo dpkg --add-architecture i386
fi

I'm going to add this to steamdeps so it's automatically taken care of in the future.

Thanks!
grogbor 24 февруари 2013 в 4:57след. 
I am having the same problem. Would you just suggest to wait? Or should I perform some sort of task to expedite the process?
###O?qÿáÓ 24 февруари 2013 в 4:57след. 
Първоначално публикувано от grogbor:
I am having the same problem. Would you just suggest to wait? Or should I perform some sort of task to expedite the process?


Първоначално публикувано от slouken:
Thanks to Aikari Tsero, we figured this out.

if [ "$(dpkg --print-architecture)" = "amd64" ] && ! dpkg --print-foreign-architectures | grep i386 >/dev/null; then
echo "Fixing architectures..."
sudo dpkg --add-architecture i386
fi

I'm going to add this to steamdeps so it's automatically taken care of in the future.

Thanks!
grogbor 24 февруари 2013 в 5:05след. 
Forgive me, I don't understand, do I type that into terminal or do I just wait. Thanks.
grogbor 24 февруари 2013 в 5:17след. 
slouken, you wonderful adonis of a man, thank you.
ConVict | The_Hairy_Baboon 24 февруари 2013 в 6:16след. 
Първоначално публикувано от slouken:
Thanks to Aikari Tsero, we figured this out.

if [ "$(dpkg --print-architecture)" = "amd64" ] && ! dpkg --print-foreign-architectures | grep i386 >/dev/null; then
echo "Fixing architectures..."
sudo dpkg --add-architecture i386
fi

I'm going to add this to steamdeps so it's automatically taken care of in the future.

Thanks!

Problem solved. found another thread with it where you said to run it. Ran that, steam worked. Thank you very much. Also, ubuntu has a lot of options windows should have. Like be connected to wifi and ethernet yet choose which to actually use when you want.
slouken 24 февруари 2013 в 6:47след. 
Okay, for anyone who hasn't solved it already, you can do this:
sudo apt-get update
sudo apt-get install steam-launcher
steam

(Or you can use update-manager to update steam-launcher)
ZbynA 26 февруари 2013 в 4:11след. 
Hi, problem persists: LinuxMint 14 (nadia), GCC 4.7 (x86_64-linux-gnu)
Показване на 1-15 от 30 коментара
< >
На страница: 15 30 50
Дата на публикуване: 24 февруари 2013 в 3:24след.
Публикации: 30