Asian Dementia Feb 24, 2013 @ 11:21am
TF2 Black Screen on Load
Hey, everyone! I just installed TF2 on Linux, and when it comes up, I can hear the load sound, and then it starts playing the load music, but the screen is totally black. I click around with my mouse, and I can hear that the mouse does manage to hit a few buttons, so the game itself is responsive. It's just that TF2 loads with a black screen. I have tried the LANG=C, etc. edits, and here are my launch settings: "-window -nojoy -dxlevel 85 -console". I have no idea why it's still not launching. If someone could help me, I'd greatly appreciate it! Thanks!
Showing 1-15 of 18 comments
< >
Costco Wholesale Market Feb 24, 2013 @ 1:05pm 
I had this problem with Mint 14 cinnamon , cinnamon seems to have a problem with fullscreen games in general to fix to problem I used -windowed and tf2 worked hope this helps
Last edited by Costco Wholesale Market; Feb 24, 2013 @ 1:05pm
Asian Dementia Feb 24, 2013 @ 1:07pm 
Thanks for the suggestion, but I've tried that already, and it didn't work.
supermariolinux Feb 24, 2013 @ 3:08pm 
Can you run steam from a terminal and notice any messages that appear when the game is running? You should be able to usr CTRL-ALT-T to launch a terminal or use your application launcher and search for it. when your terminal is open just type steam alone to start it. You wil need to close steam if it is currently running.
Asian Dementia Feb 24, 2013 @ 5:42pm 
Nothing seemed irregular, just regular loading stuff. After I pressed Ctrl-C though (by accident, stupid Windows reflex), this stuff popped up:
32pipe write 7225/2951056192 failed 32 - remote process seems dead
##### CTexture::LoadTextureBitsFromFile couldn't find materials/effects/flashlight001.vtfprocesspipe_posix.cpp (357) : Assertion Failed: false
pipes.cpp (711) : Assertion Failed: CClientPipe::BWriteAndReadResult: BWrite failed
steamclient.cpp (540) : Assertion Failed: pClientPipe->BWriteAndReadResult( buf, bufRet )
steamclient.cpp (551) : Assertion Failed: bufRet.TellPut() == sizeof(uint8)
steamclient.cpp (552) : Assertion Failed: bufRet.GetUint8() == k_EClientCommandDisconnectUser
pipe write 7225/2951056192 failed 32 - remote process seems dead 32

Other than that, nothing seemed out of place. It seemed like it was loading perfectly fine.
HarlemSquirrel Feb 24, 2013 @ 6:30pm 
Asian Dementia, are you launching TF2 from Unity desktop, or something else?
Anorak Man Feb 25, 2013 @ 1:54am 
A lot of people have this problem if they've not installed the right drivers for their graphics cards.
What graphics card do you have?
Asian Dementia Apr 16, 2013 @ 9:03pm 
I'm launching TF2 from Gnome, and also I have an integrated Intel Graphics card.
Anorak Man Apr 17, 2013 @ 2:37am 
What kind of Intel integrated graphics card? If you search the forum, you'll find that many people with older Intel cards have this problem.

It's because Intel's Linux drivers don't support GL 1.3, only 1.2. Please post the output of steam-> system information.
Last edited by Anorak Man; Apr 17, 2013 @ 2:37am
Asian Dementia Apr 17, 2013 @ 5:55am 
I believe it's either Intel HD Graphics 3000 or 4000. I can run TF2 fine on the PC.
Anorak Man Apr 17, 2013 @ 7:18am 
Try running this in the terminal:

glxinfo | grep "OpenGL version"

If it's the 3000 you're probably out of luck. If it's the 4000 you might be able to update to the latest version of MESA.

Can you also run steam for the terminal, try to launch TF2, then post the terminal results?
Asian Dementia Apr 17, 2013 @ 7:32am 
I tried, but there's way too much junk in the results. Like, at least a few thousand. It seems like it's trying to render the graphics with the vectors and etc. but it isn't showing anything in the actual game. Also, what is MESA?
Anorak Man Apr 17, 2013 @ 7:39am 
mesa is the opengl library that intel chips use. Did you run:

glxinfo | grep "OpenGL version"
?

If you've got too much crap in the terminal, run steam like this instead:

$steam > steamout.log

This will put all the output into steamout.log.

Then put that log file on pastebin or something similar.
Anorak Man Apr 17, 2013 @ 7:52am 
Oh, and what were the results from Steam System Information?
Asian Dementia Apr 17, 2013 @ 8:01am 
I don't have my computer at the moment, so I haven't tried this yet. I'll try it at 1 PM EST.
Asian Dementia Apr 17, 2013 @ 1:10pm 
Here's my System Information:

Processor Information:
Vendor: GenuineIntel
Speed: 2400 Mhz
4 logical processors
2 physical processors
HyperThreading: Supported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Supported
SSE42: Supported

Network Information:
Network Speed:

Operating System Version:
Ubuntu 12.10 (32 bit)
Kernel Name: Linux
Kernel Version: 3.5.0-25-generic
X Server Vendor: The X.Org Foundation
X Server Release: 11300000
X Window Manager: Compiz
Steam Runtime Version: steam-runtime-release-i386_2013-03-25

Video Card:
Driver: Intel Open Source Technology Center Mesa DRI Intel(R) Ironlake Mobile x86/MMX/SSE2

Driver Version: 2.1 Mesa 9.0
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 60 Hz
VendorID: 0x8086
DeviceID: 0x46
Number of Monitors: 1
Number of Logical Video Cards: 1
Primary Display Resolution: 1600 x 900
Desktop Resolution: 1600 x 900
Primary Display Size: 15.04" x 8.46" (17.24" diag)
38.2cm x 21.5cm (43.8cm diag)
Primary VRAM Not Detected

Sound card:
Audio device: Intel IbexPeak HDMI

Memory:
RAM: 5860 Mb

Miscellaneous:
UI Language: English
LANG: C
Microphone: Not set
Total Hard Disk Space Available: 22528 Mb
Largest Free Hard Disk Block: 2406 Mb

Installed software:

Recent Failure Reports:


And that's it. What's the problem?
Showing 1-15 of 18 comments
< >
Per page: 15 30 50
Date Posted: Feb 24, 2013 @ 11:21am
Posts: 18