KaLEVr1 Feb 24, 2013 @ 5:53am
TF2 Dies On Open
I installed TF2 on Ubuntu 12.04 but when I try to run it it dies with seg fault. The first time I ran it in a terminal it halted asking me to install package "curl" so I put in root password to let it install successfully. If this is a necessary package it should probably be installed with Steam. After this, I no longer get that prompt but TF2 still seg faults. Here is the terminal output:


roaming config store loaded successfully - 3786 bytes.
migrating temporary roaming config store
ExecCommandLine: "/home/john/.local/share/Steam/ubuntu12_32/steam steam://rungameid/440"
ExecSteamURL: "steam://rungameid/440"

(steam:26355): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(steam:26355): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(steam:26355): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(steam:26355): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(steam:26355): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(steam:26355): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(steam:26355): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(steam:26355): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(steam:26355): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(steam:26355): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(steam:26355): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(steam:26355): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(steam:26355): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(steam:26355): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.
Generating new string page texture 66: 128x256, total string texture memory is 442.37 KB
System startup time: 10.84 seconds
Running Steam on ubuntu 12.10 64-bit
STEAM_RUNTIME has been set by the user to: /home/john/.local/share/Steam/ubuntu12_32/steam-runtime
ExecCommandLine: "/home/john/.steam/root/ubuntu12_32/steam steam://open/driverhelperready"
ExecSteamURL: "steam://open/driverhelperready"
Generating new string page texture 69: 64x256, total string texture memory is 507.90 KB
Generating new string page texture 72: 32x256, total string texture memory is 540.67 KB
Game update: AppID 440 "Team Fortress 2", ProcID 26857, IP 0.0.0.0:0
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.

(steam:26355): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(steam:26355): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(steam:26355): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(steam:26355): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(steam:26355): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(steam:26355): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(steam:26355): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(steam:26355): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(steam:26355): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(steam:26355): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(steam:26355): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(steam:26355): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(steam:26355): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(steam:26355): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully
SDL video target is 'x11'
SDL video target is 'x11'
This system supports the OpenGL extension GL_EXT_framebuffer_object.
This system supports the OpenGL extension GL_EXT_framebuffer_blit.
This system supports the OpenGL extension GL_EXT_framebuffer_multisample.
This system DOES NOT support the OpenGL extension GL_APPLE_fence.
This system DOES NOT support the OpenGL extension GL_NV_fence.
This system supports the OpenGL extension GL_ARB_sync.
This system supports the OpenGL extension GL_EXT_draw_buffers2.
This system supports the OpenGL extension GL_EXT_bindable_uniform.
This system DOES NOT support the OpenGL extension GL_APPLE_flush_buffer_range.
This system supports the OpenGL extension GL_ARB_map_buffer_range.
This system supports the OpenGL extension GL_ARB_vertex_buffer_object.
This system supports the OpenGL extension GL_ARB_occlusion_query.
This system DOES NOT support the OpenGL extension GL_APPLE_texture_range.
This system DOES NOT support the OpenGL extension GL_APPLE_client_storage.
This system DOES NOT support the OpenGL extension GL_ARB_uniform_buffer.
This system supports the OpenGL extension GL_ARB_vertex_array_bgra.
This system supports the OpenGL extension GL_EXT_vertex_array_bgra.
This system supports the OpenGL extension GL_ARB_framebuffer_object.
This system DOES NOT support the OpenGL extension GL_GREMEDY_string_marker.
This system DOES NOT support the OpenGL extension GL_ARB_debug_output.
This system supports the OpenGL extension GL_EXT_direct_state_access.
This system DOES NOT support the OpenGL extension GL_NV_bindless_texture.
This system supports the OpenGL extension GL_AMD_pinned_memory.
This system DOES NOT support the OpenGL extension GL_EXT_framebuffer_multisample_blit_scaled.
This system supports the OpenGL extension GL_EXT_texture_sRGB_decode.
This system DOES NOT support the OpenGL extension GL_NVX_gpu_memory_info.
This system supports the OpenGL extension GL_ATI_meminfo.
This system supports the OpenGL extension GL_EXT_texture_compression_s3tc.
This system DOES NOT support the OpenGL extension GLX_EXT_swap_control_tear.
GL_NV_bindless_texture: DISABLED
GL_AMD_pinned_memory: DISABLED
GL_EXT_texture_sRGB_decode: AVAILABLE
Installing breakpad exception handler for appid(gameoverlayui)/version(20130223124517_client)
Installing breakpad exception handler for appid(gameoverlayui)/version(1.0_client)
Installing breakpad exception handler for appid(gameoverlayui)/version(1.0_client)
Installing breakpad exception handler for appid(gameoverlayui)/version(1.0_client)
[0224/144320:WARNING:proxy_service.cc(646)] PAC support disabled because there is no system implementation
Using breakpad crash handler
Setting breakpad minidump AppID = 440
Forcing breakpad minidump interfaces to load
Looking up breakpad interfaces from steamclient
Calling BreakpadMiniDumpSystemInit
Looking up breakpad interfaces from steamclient
Calling BreakpadMiniDumpSystemInit
Steam_SetMinidumpSteamID: Caching Steam ID: 76561197970341384 [API loaded yes]
Steam_SetMinidumpSteamID: Setting Steam ID: 76561197970341384
Did not detect any valid joysticks.
GL_NVX_gpu_memory_info: UNAVAILABLE
GL_ATI_meminfo: AVAILABLE
GL_ATI_meminfo: GL_TEXTURE_FREE_MEMORY_ATI: Total Free: 844273, Largest Avail: 672992, Total Aux: 1648568, Largest Aux Avail: 7168
GL_MAX_SAMPLES_EXT: 8
[0224/144324:ERROR:resource_bundle.cc(411)] Failed to load /home/john/.local/share/Steam/SteamApps/kalevr1/Team Fortress 2/cef_gtk.pak
Some features may not be available.
[0224/144324:WARNING:proxy_service.cc(646)] PAC support disabled because there is no system implementation
CShaderDeviceMgrBase::GetRecommendedConfigurationInfo: CPU speed: 2393 MHz, Processor: GenuineIntel
GlobalMemoryStatus: 4141875200
CShaderDeviceMgrBase::GetRecommendedConfigurationInfo: CPU speed: 2393 MHz, Processor: GenuineIntel
GlobalMemoryStatus: 4141875200
IDirect3DDevice9::Create: BackBufWidth: 1920, BackBufHeight: 1080, D3DFMT: 3, BackBufCount: 1, MultisampleType: 0, MultisampleQuality: 0
/home/john/.local/share/Steam/SteamApps/kalevr1/Team Fortress 2/hl2.sh: line 72: 26863 Segmentation fault (core dumped) ${GAME_DEBUGGER} "${GAMEROOT}"/${GAMEEXE} "$@"
Game removed: AppID 440 "Team Fortress 2", ProcID 26863
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully

Showing 1-11 of 11 comments
< >
^1Gentoo Feb 24, 2013 @ 6:24am 
Did you check the wiki for Steam about minimun driver version & etc.?
instabilis Feb 24, 2013 @ 6:27am 
Have you installed the latest AMD/ATI drivers for your graphics card from the 'Additonal Drivers' tab in the Ubuntu Software Center?
KaLEVr1 Feb 24, 2013 @ 6:28am 
The only version newer than the one I have is a beta, so no.

Originally posted by ^1Gentoo:
Did you check the wiki for Steam about minimun driver version & etc.?
instabilis Feb 24, 2013 @ 6:40am 
Have you varified the local game cache? Right click on TF2 in your library, select Properties > Local Files > 'Verify integrity of game cache...'
^1Gentoo Feb 24, 2013 @ 7:36am 
Originally posted by KaLEVr1:
The only version newer than the one I have is a beta, so no.

Originally posted by ^1Gentoo:
Did you check the wiki for Steam about minimun driver version & etc.?

The minimum driver your supposed to use is a beta driver... For nVidia cards atleast.
KaLEVr1 Feb 24, 2013 @ 7:54am 
Yes, tried that.


Originally posted by instabilis:
Have you varified the local game cache? Right click on TF2 in your library, select Properties > Local Files > 'Verify integrity of game cache...'
KaLEVr1 Feb 24, 2013 @ 7:56am 
I've got an ATI card. Do you have the wiki url?


Originally posted by ^1Gentoo:
Originally posted by KaLEVr1:
The only version newer than the one I have is a beta, so no.

The minimum driver your supposed to use is a beta driver... For nVidia cards atleast.
Shane Feb 24, 2013 @ 8:01am 
open a terminal ( ctrl + alt + t )

sudo apt-add-repository ppa:xorg-edgers/ppa
reboot
And get the last drivers and reboot.

Edit1 : i don't think its a related problem with drivers. But you can give a try.
Last edited by Shane; Feb 24, 2013 @ 8:43am
KaLEVr1 Mar 15, 2013 @ 5:30pm 
Solved. I recompiled custom packages from Catalyst driver set 13.1. It made 3 packages to install manually. The install program died several times because of missing prerequisites such as kernel headers before completing successfully but after loading those 3 packages and rebooting the problem seems to be solved.
Thyriel Mar 16, 2013 @ 12:03am 
sounds like you missed to install some prerequisities for the amd drivers.
try the following in case your still missing some:

sudo apt-get install build-essential cdbs fakeroot dh-make debhelper debconf libstdc++6 dkms libqtgui4 wget execstack libelfg0 dh-modaliases
sudo apt-get install ia32-libs ia32-libs-multiarch i386 lib32gcc1 libc6-i386
KaLEVr1 Mar 17, 2013 @ 9:07am 
The faq for the amd driver on the AMD website lists required packages for installing the driver and I had already installed those that were part of the Ubuntu repositories. If you want to build a custom package then you need several additional support packages for the build process alone. You should not need those additional packages unless you make your own build. The packages that the fglrx error log (under /usr/share/ati/fglrx-install.log) told me to install are in your list. As a rule I try not to install anything unless I know for sure I need it.
Showing 1-11 of 11 comments
< >
Per page: 15 30 50
Date Posted: Feb 24, 2013 @ 5:53am
Posts: 11