Dark Light Feb 23, 2013 @ 4:17pm
Can't install Steam - Dependency is not satisfiable: libc6 (>= 2.15) \ Wrong architecture 'i386'
I am running 11.10 (x64), I have tried almost everything that has been suggested, I just can't seem to get it to work. When I try to install it via downloading the .deb file it tells me that my Dependency is not satisfiable although it use to say that I had the wrong architecture, I am not sure what I did to change that as I did multiple things and a restart solved it. However if I try to install it though the command line it still gives me the wrong architecture error.
Showing 1-13 of 13 comments
< >
^1Gentoo Feb 23, 2013 @ 4:20pm 
The minimun requirement for Steam for Linux is Ubuntu 12.04 LTS.
Dark Light Feb 23, 2013 @ 4:22pm 
I have seen people suggest that they have managed to get it running on older versions, and I have seen people run it on other distributions.
Cuda - making stuff! 🐱 Feb 23, 2013 @ 8:53pm 
Try:

sudo apt-get install ia32-libs

if you don't already have them installed.
Dark Light Feb 23, 2013 @ 8:57pm 
I had already done that, I gave up in the end and just updated to 12.04. Only for Steam not to work and crash when I try to create an install directory. Linux is unprofessional and Steam for Linux should be in alpha, let alone beta or release.

All this for a penguin.
[Linux] unbridledExüberance Feb 23, 2013 @ 9:03pm 
What do you mean "LInux is unprofessional"? Your problem has nothing to do with the Linux kernel at all. Ubuntu ≠ Linux, and dependency problems are the fault of the packager, not the operating system.

What error message, if any, did you get when it crashed and what directory did you attempt to install it to?
CarrotDick Feb 23, 2013 @ 9:11pm 
Originally posted by Dark Light:
All this for a penguin.
*You're* the one doing it and whining about it for a useless trinket. At least you could not be an ♥♥♥ about it.

I had already done that, I gave up in the end and just updated to 12.04.
You mean the declared minimum supported version? Shocker.

Steam for Linux should be in alpha, let alone beta or release.
I can agree with that. But mostly for reasons that have nothing to do with your rants.

Linux is unprofessional
Which of course is why it's used on virtually all super-computers, used on a huge majority of servers of all kinds, is preferred by developers and is widely used in the fastest growing-ever operating system. Okay buddy; whatever you say.

---

Also, whatever you do, don't run it in a Terminal and give us crash output because then we might actually be able to help you.
Last edited by CarrotDick; Feb 23, 2013 @ 9:12pm
{MF} Mr. Potato Head Apr 11, 2013 @ 5:53am 
I am running mint 12 as ubuntu was just much of a punk to learn to use . I get the error // Error: Dependency is not satisfiable: libc6 (>= 2.15)
Last edited by {MF} Mr. Potato Head; Apr 11, 2013 @ 5:54am
Cheogh Apr 11, 2013 @ 7:24am 
It's probably because libc6 is too old, I just looked up op's version and that was 2.13 and is why he was getting that error message. I can't seem to find mint's even though http://packages.linuxmint.com
Last edited by Cheogh; Apr 11, 2013 @ 7:24am
Teisei Apr 11, 2013 @ 5:47pm 
Originally posted by Dark Light:
I am running 11.10 (x64), I have tried almost everything that has been suggested, I just can't seem to get it to work. When I try to install it via downloading the .deb file it tells me that my Dependency is not satisfiable although it use to say that I had the wrong architecture, I am not sure what I did to change that as I did multiple things and a restart solved it. However if I try to install it though the command line it still gives me the wrong architecture error.

Anything older than 12.04 is not supported. Consider upgrading to at least 12.04.
=U= LetLoose Apr 23, 2013 @ 12:49am 
only thing why i cant update to 12.04 is because i cant get my wireless usb adapter to work and it only works on 10.04 and 10.10 and idk for 11.xx i tried on 12.04.2 and it just stopped i tried everything ... i would like help cuz i want steam so bad :( (tplink tl-wn322g v3.4) i posted this problem here because i think u are smarter then those guys on askubuntu and stuff they couldnt help me at all
Shark Apr 23, 2013 @ 11:37am 
Mint 12 is also to old I think, try mint 13.
Striker May 23, 2013 @ 8:45am 
I had the same issue on Kubuntu (13.04?), I did the following and resolved the issue.

Open terminal and type the these commands:

1. sudo apt-get install ia32-libs
2. sudo apt-get install xterm
3. sudo apt-get install libcurl3
4. sudo apt-get install curl

Note that these might be different depending your installation of Linux.
paul.bettes Mar 10 @ 6:43pm 
Libc6 has been replaced by glibc. Ubuntu 12.04 was the last version of it to support libc6. Is the installer for steam going to be updated to reflect this change in Linux distros?
Last edited by paul.bettes; Mar 10 @ 6:44pm
Showing 1-13 of 13 comments
< >
Per page: 15 30 50
Date Posted: Feb 23, 2013 @ 4:17pm
Posts: 13