Ledmaster2 Feb 23, 2013 @ 4:19am
TF2 Black Screen
Alright so while I know there are threads about this already consider this one a bit more specific.

1. Have ubuntu 12.10 x86 have had it for some time I did not just get it for the release of steam on Linux I am a longtime linux user and ubuntu 12.10 happens to be the distro I am using at the moment.
2. Getting the black screen issue when running TF2. I have installed 32bit libraries, I have tried the LANG=C and numeric posix workarounds and either I am placing the code improperly in the script in nano or more likely it doesnt work.
3. Game starts and runs fine, I can hear the menu music, I can even hear when my mouse passes over one of the buttons on the main menu of the game, but of course all I have is a black screen.
4. Currently trying to find the app id so I can try maybe just running the program directly from terminal instead of its own launcher but.
5. Anyone know a working workaround for this? Also when you place the export LANG=C or whatever you do that directly under #bin/bash right? Meaning you delete the spare # line.

Normally I find workarounds myself, but this is proving to be rather annoying. I was considering purging steam and tf2 and re-installing but since its technically "working" its just not scaling properly I figured maybe it can be bypassed as is.
Showing 1-15 of 15 comments
< >
Anorak Man Feb 23, 2013 @ 4:23am 
what graphics chipset do you have?
instabilis Feb 23, 2013 @ 4:24am 
You have the proprietary graphics drivers install?

Have you tried forcing the game to start in windowed mode?
Marentis Feb 23, 2013 @ 4:34am 
On Ubuntu it's helpful to install all updates and then the binary drivers. That should fix most quirks and should let you start everything out of the box.
Ledmaster2 Feb 23, 2013 @ 4:35am 
No I have not tried forcing windowed mode (unless its that ctrl f1 thing). Got a terminal code for doing that?

Graphics are unknown according to ubuntu's system manager. However I can tell you that the computer itself is a 2010 hp pavillion dv6 so its running some form of Intel R-HD internal graphics. I will be right back I am going to go find out exactly what it is.
Ledmaster2 Feb 23, 2013 @ 4:36am 
Originally posted by Marentis:
On Ubuntu it's helpful to install all updates and then the binary drivers. That should fix most quirks and should let you start everything out of the box.

My system is up to date. Its possible I am missing a driver but I doubt it or I wouldn't be sitting here talking to you with my monitor working just fine while plugged into the laptop while on ubuntu.
instabilis Feb 23, 2013 @ 4:39am 
Originally posted by Ledmaster2:
No I have not tried forcing windowed mode (unless its that ctrl f1 thing). Got a terminal code for doing that?
Right click on TF2 in your Library, select 'Properties', then click on 'Set Launch Options...'
-window -w 800 -h 600

More commands:
https://developer.valvesoftware.com/wiki/Command_Line_Options#Source_Games
Last edited by instabilis; Feb 23, 2013 @ 4:40am
Marentis Feb 23, 2013 @ 5:07am 
Originally posted by Ledmaster2:
Originally posted by Marentis:
On Ubuntu it's helpful to install all updates and then the binary drivers. That should fix most quirks and should let you start everything out of the box.

My system is up to date. Its possible I am missing a driver but I doubt it or I wouldn't be sitting here talking to you with my monitor working just fine while plugged into the laptop while on ubuntu.

Yes and no, there are two kinds of drivers: the binary blob and the open source drivers. So it's very well possible to write here with your monitor working fine, but getting trouble when trying to run an OpenGL application.

Are you using an nVidia or AMD graphic's card? Which driver are you using?
Anorak Man Feb 23, 2013 @ 5:17am 
They're using an intel something or other - which worries me. If it's older than the 2000 HD, Source won't work in linux :(
Marentis Feb 23, 2013 @ 5:23am 
Originally posted by Anorak Man:
They're using an intel something or other - which worries me. If it's older than the 2000 HD, Source won't work in linux :(

Aw, shoot :(.
Anorak Man Feb 23, 2013 @ 5:31am 
Actually, looking at the "hp pavillion dv6", it might be AMD - but it's a legacy card if it is.
Ledmaster2 Feb 26, 2013 @ 11:44am 
Okay so finally found my bloody graphics card info:

ATI Mobility Radeon HD 5650
GPU Madison
Device ID 1002-68C1
Subvendor HP (103C)
Current Performance Level Level 1
Voltage 1.000 V
Release Date Jan 7, 2010
DirectX Support 11.0
DirectX Shader Model 5.0
OpenGL Support 3.2
GPU Clock 0.0 MHz
Driver version 8.771.1.0
BIOS Version BR40439.001
ROPs 8
Shaders 400 unified
Count of performance levels : 1
Level 1
OpenGL
Version 4.0.10188 Compatibility Profile Context
Ledmaster2 Feb 26, 2013 @ 11:45am 
Also, on running this thing in windowed mode, when you (instalblis) said do it from the library, you mean my gaming library in steam or my directory library in linux system files?
instabilis Feb 26, 2013 @ 11:55am 
Originally posted by Ledmaster2:
Also, on running this thing in windowed mode, when you (instalblis) said do it from the library, you mean my gaming library in steam or my directory library in linux system files?
Yes, in Steam
Ledmaster2 Feb 26, 2013 @ 12:46pm 
Ill give it a go later today and see what happens
DrMrBlueX Feb 26, 2013 @ 3:34pm 
I know exactly what you mean, and I found a fix that works.

1) Go to your Steam Library.

2) Right click on Team Fortress 2 and click "Properties".

3) Click Launch Settings, and enter "-nod3d9ex".

4) Run Team Fortress 2 and hopefully it works :)

WARNING: People have said that this does slow your game.
Last edited by DrMrBlueX; Feb 26, 2013 @ 3:34pm
Showing 1-15 of 15 comments
< >
Per page: 15 30 50
Date Posted: Feb 23, 2013 @ 4:19am
Posts: 15