Steam for Linux

Steam for Linux

Steam for Linux > Dyskusje ogólne > Szczegóły tematu
Open GL error. Can't start TF2
Hi I recently installed linux ubuntu 12.04 on my imac. I tried staring TF2 but it gave me a open gl error saying something about gl_ext_texture_srgb_decode. How do I fix this? I'm new to linux so detailed solutions would be nice. I also have a radeon 2400 HD gpu.
< >
Wyświetlanie 1-15 z 15 komentarzy
[TUX]pab.lo 22 lutego 2013 o 19:16 
Have you installed the proprietary drivers or are you using the default open source ones?. System administration --> Additional drivers should do it.
I already installed the additional drivers ati thing.
Anorak Man 23 lutego 2013 o 0:23 
The radeon 2400 HD needs the newest legacy drivers, which are not in the official repositories yet ( i think ).
There are instructions here for 12.10,
but you're in 12.04.
I think you'll have to install the driver yourself.

Try reading this post
Thanks but how do I install the drivers correctly? Do I just un zip them?
Anorak Man 23 lutego 2013 o 6:31 
Actually, you might be able to use this ppa:

From a terminal, run the following:

sudo add-apt-repository ppa:makson96/fglrx
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install fglrx-legacy

Then reboot.
Ostatnio edytowany przez: Anorak Man; 23 lutego 2013 o 6:33
I did all of the commands but the last one says it was unable to locate package fglrx-legacy
Anorak Man 23 lutego 2013 o 7:32 
I hoped that would work. The PPA is for 12.10 but I found someone saying it was working on 12.04 too.

Can you try rebooting and trying again? I sincerely doubt it will work, but just in case. Otherwise it's manual driver install time.
Yep it didn't work again. So how do I manually install the driver? Also thanks for the help so far :)
Anorak Man 23 lutego 2013 o 7:41 
Manual driver install:
//this command downloads the driver #wget //this command unzips the driver #unzip //this command removes any other ATI drivers #sudo apt-get remove fglrx* //this prepares the system. There's a lot of stuff in here and it would take all day to explain it #sudo apt-get install debhelper dh-modaliases execstack build-essential cdbs fakeroot dh-make debhelper debconf libstdc++5 dkms linux-headers-$(uname -r) //this actually does the install #sudo sh ./amd-driver-installer-**-* --buildandinstallpkg //this configures it. #sudo /usr/bin/aticonfig --initial

After this, reboot.
Okay I quess it worked but now I'm getting a new error. It says to require open GL extension "GL_EXT_texture_compression_s3tc" is not supported please install S3TC texture support.
Anorak Man 23 lutego 2013 o 8:16 
Which one worked? The PPA or the manual install?
Manual install.
Anorak Man 23 lutego 2013 o 8:18 
Ok. Can you please run steam from the terminal, and paste the output from steam to here?
Oh crap I thought reinstalling the ati drivers form te additional drivers thing would fix the problem but it just gives me the same problem with the srgb texture thing.
< >
Wyświetlanie 1-15 z 15 komentarzy
Na stronę: 15 30 50

Steam for Linux > Dyskusje ogólne > Szczegóły tematu
Data napisania: 22 lutego 2013 o 18:42
Posty: 15