Steam for Linux > Discussioni generali > Dettagli della discussione
lonchaneyjr 22 feb 2013, ore 1:59
Problem running TF2 or Half-Life on Ubuntu with Xmonad
I've been having trouble running some games on steam, probably due to problems with xmonad (and my xmonad.hs). I run Xubuntu 12.04, and if I use Unity or Xfce then Steam and the games seem to work fine. However, when I use Xmonad as my window manager, I can't seem to run TF2 or Half-Life. When I click play, these games go to a full, black screen, and then seem to hang. I then either have to log out or kill steam. The steam client seems to work ok, and other games seem to work ok (I have tested SpaceChem and FTL).

This seems a bit different to other posts about Xmonad, since those users struggled to get Steam itself working. For me, steam works ok, as do some games, but not TF2 or Half-Life.

I would be very grateful if anyone has any idea how to change xmonad.hs to sort this out. Thanks.

Relevant (I think) parts of xmonad.hs:
http://pastebin.com/x3dg8N8D

Xubuntu 12.04
Xfce 4.8.6
Xmonad 0.10-3
Visualizzazione di 1-5 commenti su 5
< >
Greenbikerdude 22 feb 2013, ore 2:38 
isn't xmonad a twm? I encountered these kind of problems with awesome, i3 etc too and I find installing openbox with menu entries of your installed games is the best way.
1. you aren't tempted to play while working
2. you have all your games one click away without any cluttering :)
3. openbox is lightweight so maximum power for your games :P

It isn't a solution but it is a nice way of handling things.
Ultima modifica da Greenbikerdude; 22 feb 2013, ore 2:39
bitcrusher 22 feb 2013, ore 4:41 
Easy, put it in window mode. "-windowed" in set launch options
Ultima modifica da bitcrusher; 22 feb 2013, ore 4:42
lonchaneyjr 22 feb 2013, ore 7:55 
Messaggio originale di Bitcrusher:
Easy, put it in window mode. "-windowed" in set launch options

Sorry, can I just check what I should launch in windowed mode? Is that steam, or TF2, or something in xmonad.hs? And if TF2, where can I set that option?

Thanks a lot for the help!
Ultima modifica da lonchaneyjr; 22 feb 2013, ore 7:58
Shane 22 feb 2013, ore 8:28 
Library -> Team Fortress 2 -> Properties -> Set launch option

I think.
lonchaneyjr 24 feb 2013, ore 2:54 
That works great, thanks a lot.
Visualizzazione di 1-5 commenti su 5
< >
Per pagina: 15 30 50
Data di pubblicazione: 22 feb 2013, ore 1:59
Messaggi: 5