arc| Gps Feb 21, 2013 @ 6:09pm
Serious Sam 3
When I watch the intro movies, I get some stutter, when a camara view changes.
( I compared it to windows 7 pro 32 bit, it runs perfectly smooth there, so its not a hardware problem)

I forced the game to look for my hardware, and that did improve it a bit.
On the command line I saw my cpu "changing" from 2.6 to 3.2 ( which is right)

In game it often runs very smooth but in some areas, it does not make me happy.

I have been looking around for solutions, and I found this in one of the log files.

WRN: CPU Power saving is enabled and performance governor is not used

First question
Do I need to change that ? I remeber reading something about this, but can't remeber exactly what it was.
If so how do I change this?

second question
Should I try the beta catalyst driver ?
I now use 13.1

Third question. ( I would like to hear youre thoughts on this)
Should I try openSUSE thumbleweed ?

Quote from opensuse portal:
The Tumbleweed project provides a rolling updates version of openSUSE containing the latest stable versions of all software instead of relying on rigid periodic release cycles. The project does this for users that want the newest, but stable software.

The difference to Factory is that Factory is bleeding edge, often experimental, not yet stabilized software that needs more work to become useful. Tumbleweed contains the latest stable applications and is ready for daily use.

Other sugetions are welcome too.

Processor Information:
Vendor: AuthenticAMD
Speed: 3200 Mhz
4 logical processors
4 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Supported
SSE41: Unsupported
SSE42: Unsupported

Network Information:
Network Speed:

Operating System Version:
"openSUSE 12.2 (x86_64)" (64 bit)
Kernel Name: Linux
Kernel Version: 3.4.28-2.20-desktop
X Server Vendor: The X.Org Foundation
X Server Release: 11203000
X Window Manager: KWin
Steam Runtime Version: <Runtime enabled>

Video Card:
Driver: ATI Technologies Inc. ATI Radeon HD 5700 Series (5750)

Driver Version: 4.2.12002 Compatibility Profile Context 9.012 (13.1)
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 59 Hz
VendorID Not Detected
DeviceID Not Detected
Number of Monitors: 1
Number of Video Cards Not Detected
Primary Display Resolution: 1680 x 1050
Desktop Resolution: 1680 x 1050
Primary Display Size: 17,05" x 10,67" (20,08" diag)
43,3cm x 27,1cm (51,0cm diag)
Primary VRAM Not Detected

Sound card:
Audio device: Realtek ALC892

Memory:
RAM: 3959 Mb

Miscellaneous:
UI Language: English
LANG: nl_NL.UTF-8
Microphone: Not set
Total Hard Disk Space Available: 302381 Mb
Largest Free Hard Disk Block: 261802 Mb
Showing 1-12 of 12 comments
< >
[TUX]pab.lo Feb 21, 2013 @ 6:19pm 
Acording to the developers, it is needed to disable the CPU power saving features to run SS3 correctly.
To do that you need to enter the BIOS setup, you'll find the options as Cool n' Quiet, C1E, etc, these are the ones you should disable.

As of the beta drivers, I'm currently using 13.2 beta 6 and it has some improvement over the 13.1 (running with a 6870). I think it's worth the try.

Regards,
arc| Gps Feb 21, 2013 @ 6:22pm 
Thank you, I will go into the bios, and see were to disable it.
I just downloaded 13.2 beta 6.

When I click big picture mode, steam tells me to install 13.2 first. ( just found that out 2 min agoo)
[TUX]pab.lo Feb 21, 2013 @ 6:24pm 
Yes actually I couldn't get big picture mode to work until I installed beta 6 drivers (the release notes actually specify the resolution of that issue).

Check in advanced or CPU settings, something like it, should be there.
[Linux]sulman Feb 21, 2013 @ 6:30pm 
There is an alternative, as I quite like having a variable CPU for temperature and power conservation.

You can get a desktop applet for it, or as root or sudo do:

cpupower frequency-set -g [ondemand|performance]

Dependent on which one you want. Works for me - I need it set to Performance for SS3 or I get the stutter you describe.

Game's an utter hoot, by the way.
Last edited by [Linux]sulman; Feb 21, 2013 @ 6:30pm
arc| Gps Feb 21, 2013 @ 7:04pm 
I love the game, it makes me laugh. The cheesy comments of Sam.

put a sock in it
ow ♥♥♥♥ :)

You mean the phone you just called ?

Then the melee kills.

Grahics are great.

I realy like your sugestion, specialy the desktop applet, were can I find this, or do I have to make it my self ?
[Linux]sulman Feb 21, 2013 @ 8:04pm 
Originally posted by arc| Gps:
I love the game, it makes me laugh. The cheesy comments of Sam.

put a sock in it
ow ♥♥♥♥ :)

You mean the phone you just called ?

Then the melee kills.

Grahics are great.

I realy like your sugestion, specialy the desktop applet, were can I find this, or do I have to make it my self ?

I run Gnome 3 and it's available as a gnome extension. Nearly all of the DE's should have something similar :) Look under Cpu Frequency, Cpupower etc.
Last edited by [Linux]sulman; Feb 21, 2013 @ 8:05pm
arc| Gps Feb 22, 2013 @ 6:20am 
I use kde, but it has applets. I will search for it.

Thank you both for the feedback.
keks Feb 22, 2013 @ 6:31am 
Performance is usually better if cpu power saving is disabled in the bios, as opposed to using "performance" cpu scaling mode. You can always try and see if the improvement is worth it.
SUSEd Feb 22, 2013 @ 8:36am 
I have core i5-3570k and GTX660.
Game on all ultra settings shows 50-80 FPS. After enabling all graphical setting FPS lowers to 20.
blackout24 Feb 22, 2013 @ 9:09am 
Originally posted by shished.tux.sus:
I have core i5-3570k and GTX660.
Game on all ultra settings shows 50-80 FPS. After enabling all graphical setting FPS lowers to 20.

It's kind of expected that performance goes down the drain, when you try get the last bit of super moster anti-aliasing 16x on high resolution.

I also use cpupower to change my scaling governor but it run's great on "ondemand" aswell it's not like the BIOS method or performance give me 10% speed increase. It's hard to measure anything at all. At least on my i7 2600K 4.5 Ghz / GTX 580 - 313.18 Driver.


Last edited by blackout24; Feb 22, 2013 @ 9:11am
arc| Gps Feb 23, 2013 @ 12:00pm 
It took me longer then espected to find some tool.

it was in the end as simple as start yast

mark cpu CPU Frequency Utility.

Install that.
Then copy paste from a page three commands, or all in one, on to the commandline
to make a bash script.

I still do not know what a bash script it, but it works.
And this setting is lost at reboot.
https://forums.opensuse.org/blogs/jdmcdaniel3/c-f-u-cpu-frequency-utilitiy-version-1-10-use-cpufrequtils-package-40/

Power setting was set to on demand.

Changed it to performance.

Which changed the frq from 2,1 to 3,2
SS3 runs much better. Very happy !
arc| Gps Feb 24, 2013 @ 10:06am 
It looks like TF2 is running better too, today install 13.2 beta 6 and TF2 is smoother then it was.
Nu more stuttering. Atleast in game. SS3 vids still are not running totaly smooth.
Showing 1-12 of 12 comments
< >
Per page: 15 30 50
Date Posted: Feb 21, 2013 @ 6:09pm
Posts: 12