torteloni.de Feb 19, 2013 @ 2:54am
Can't find Steam in the Software Center
Hi all! At the moment I am trying to install steam on Ubuntu 12.04. However I'm not as successful as I'd like to be:

* When searching through the Software-Center I receive the message "not found"
* When browsing through the Ubuntu Apps-Page https://apps.ubuntu.com/cat/applications/precise/steam/ and choosing to install via the Software-Center I receive the same "not found" message
* When downloading the steam_latest.deb I can't install due to dependencies from "libgl1-mesa-dri" and "libgl1-mesa-glx". I don't find these packages in Synaptic Package manager.

What should I try to successfully install steam?
Showing 1-6 of 6 comments
< >
[LINUX] RyuzakiKK Feb 19, 2013 @ 3:14am 
Have you updated ubuntu from software updater?
[citation needed] Feb 20, 2013 @ 9:25am 
I have this same issue. I ran a gaggle of updates and rebooted, but it still behaved like this in Ubuntu 12.04 64 bit. It seemed to think it was up-to-date briefly after this, but I had to leave and I plan to check again for further updates that it needs.
BattlePenguin Feb 20, 2013 @ 9:36am 
Just noticed the same thing on Ubuntu 12.10 under the Software Center. Fresh 12.10 x64 install this morning, completely updated.

steam_latest.deb did install for me. It asked to install the mesa libs and did it automatically. I haven't updated any graphics drivers, still the defaults for my AMD card.
Last edited by BattlePenguin; Feb 20, 2013 @ 9:50am
Shens Feb 20, 2013 @ 11:38am 
I also can't see steam in the USC on a fully updated install of 12.04. It's a fresh install as of last night. I tried installing steam_latest.deb, but the install is broken and won't launch, I didn't get any prompt to install additional libraries during the install. I did get a window asking me to launch steam to complete installation after running dpkg, but I can't launch steam.
DerrickG™ Feb 20, 2013 @ 12:45pm 
Download the latest .deb here:
http://media.steampowered.com/client/installer/steam.deb

Double click on it to install Steam.
mxup Feb 21, 2013 @ 2:12pm 
weird, I also don't find steam in the software center (system fully updated). I thought it was because I installed the beta last year through the deb. So I uninstalled the deb, but no improvement. Going to install it again from the deb :)

update: when I now click on the deb to install, the USC opens with the steam deb. When I press install, it shows a progress bar, but when it's finished, it keeps being not installed..
update2: so I tried using dpkg, now it does install!
Last edited by mxup; Feb 21, 2013 @ 2:16pm
Showing 1-6 of 6 comments
< >
Per page: 15 30 50
Date Posted: Feb 19, 2013 @ 2:54am
Posts: 6