M1GU31[ABK] Feb 18, 2013 @ 5:30pm
TF2 Linux Mint 14 64bit, lag issues.
So I made a partition for mint and installed tf2, I usedd the latest amd drivers for 64 bit and everything was going well. The issue is when I play I get huge fps drops compared to windows 7, running about 30-45 maxed on linux and run 75-90 maxed on windows 7. Also i'm geting this ridiculous mouse lag . Had to turn off AA in linux to get it playable but the mouse lag makes it unplayble. So I was wondering if there's a fix for this issue. I've done a couple updates so far and installed the graphic drivers from amds site so far. Any help would be appreciated, I know it's not my hardware. It's more then enough and I can play 2012 games with dx11 on high with better fps then this.

Specifications:
OS:Linux Mint 14 64bit(the linux os i'm using)
cpu:Althon II 640 x4 (O.C) 3.6GHz
motherboard:M5A78L-MLX Plus
HDD:500gb
ram: 4 gb ddr3
video card: xfx 6870 1gb
mouse:Logitech Optical Gaming Mouse G400
Showing 1-13 of 13 comments
< >
[Linux]sulman Feb 18, 2013 @ 5:35pm 
Why did you install the drivers from AMD's site? Probably much safer to use the repos.

Your hardware's fine - something else is awry. AMD drivers on Linux suck but it should be doing better than that. Your mouse lag is not normal.
M1GU31[ABK] Feb 18, 2013 @ 5:37pm 
Can you link me to these drivers? Also how do I uninstall these current ones? Been tinkering a lot lately the past 3 days with linux just to get installed and geting drivers on.
omegadot Feb 18, 2013 @ 5:38pm 
If you installed them from AMD's site via the shell script then sudo aticonfig --uninstall should do it.

edit:
I got mouse lag with vync enabled. I disabled that and all was well. I am running the latest beta AMD drivers installed from the site, not repos.
M1GU31[ABK] Feb 18, 2013 @ 5:51pm 
Ok thank you for responding will try this. Question what other drivers should I use? Sorry bit new to linux so i'm learning as I go. Should of mentioned that currently the beta drivers are installed. Going to try turning off v-sync before geting other drivers. Does it matter if you use amd drivers or these repo drivers? Were can I find these repo drivers?
Bitu Feb 18, 2013 @ 11:44pm 
I have lags too ( Mint 14 64bit). On windows TF2 is smooth, but on Mint i have 20-30fps and pretty lags...
My specs:
cpu: Intel i3-2330m
gpu: Intel HD 3000
ram: 8gb ddr3
hdd: 500gb
os: mint 14 64bit
Jugularis Feb 19, 2013 @ 2:53am 
I have very similar issues. Huge frame drops and lagging on HD6870. Just formated secondary drive with Ubuntu and installed Ubuntu 12.10 with latest AMD beta driver and still huge performance diference between Win and Ubuntu. I have bad fps, texture problems in MvM, Hoodoo map etc. Just like this http://steamcommunity.com/sharedfiles/filedetails/?id=128126480
M1GU31[ABK] Feb 19, 2013 @ 3:04am 
Originally posted by Jugularis:
I have very similar issues. Huge frame drops and lagging on HD6870. Just formated secondary drive with Ubuntu and installed Ubuntu 12.10 with latest AMD beta driver and still huge performance diference between Win and Ubuntu. I have bad fps, texture problems in MvM, Hoodoo map etc. Just like this http://steamcommunity.com/sharedfiles/filedetails/?id=128126480
Yea I had those texture glitches ealier also. Game needs another patch or better drivers.
richi902 Feb 19, 2013 @ 3:05am 
i'm using ubuntu 12.04 x64 with amd 13.2beta 3, i have ~100fps but i also have that stupid mouse input lag, atleast it feels so, but only in tf2 not in cs:s.
Yourself{AU} Mar 5, 2013 @ 9:17pm 
For AMD Graphics card users, DON'T ENABLE V-SYNC!!! The reason why is that v-sync is nvidia software and will absolutely kill your FPS instead of capping it at your screen's refresh rate like it's supposed to. If you have nvidia architecture, go ahead and use it because it gets rid of screen tearing when the FPS is too high (Yes, there is such a thing as too high FPS!)
Miku Philosophiæ Mar 5, 2013 @ 9:33pm 
welcome to the wonderful world of fglrx... I have had mixed luck. But as a general measure, fglrx simply gives out less fps than the windows drivers do.

I dunno why, but around 80 fps sounds a bit low for even in windows with that card. I get around 200 fps with a gtx 560 Ti SC, even in linux.
M1GU31[ABK] Mar 5, 2013 @ 10:34pm 
it's cause i run in 1080p with full aa, that would be my guess. Yea anyways i have 8 gb ram now seems to not stutter now and my sytems be running 4.5gbs in the ram. Like it wasn't lag but you could feel it didn't feel smooth. I kind of got upset messing with drivers and haven't touched linux over a week and kept playing on windows. Maybe my cpu bottle neck idk or just some setting i have in ccc. Yea couldn't get it to run better under linux , I might retry it later when tf2 matures on linux. Oh and i only get 80fps avg when on 32 player severs with a bunch of havoc and dips. a regular size sever i get around 140fps when stuff happens with dips to like 90 somtimes and when nothing happens like 180. Anyways I have v-sync enabled and stays at 60 most of the time but i noticed that in linux if i put it on i got terrible mouse lag and more lag in general. I think I just have bad drivers, anyways just fresh installed windows and seems snappier with higher fps. I think somthing might of been conflcting not sure. Anyways Trying not to confuse you guys just stating this.
Thyriel Mar 5, 2013 @ 10:47pm 
Originally posted by Linuxsulman:
Why did you install the drivers from AMD's site? Probably much safer to use the repos.

Your hardware's fine - something else is awry. AMD drivers on Linux suck but it should be doing better than that. Your mouse lag is not normal.
TF2 does not even start if you use older drivers then 13.1
the 13.2 beta do run much smoother too so i would install those
Rods Mar 6, 2013 @ 3:57am 
I can run it smooth on a fresh Linux Mint 14 x64 with AMD's site beta drivers installed(13.2). My specs are ASUS SABERTOOTH 990fx, AMD FX Vishera 8350, Radeon 6850 1gb. I've noticed that it runs better without enabling the multicore rendering , doesn't make sense but okay. Everything on high/very high, antialiasing 16x, FXAA 8x (not necessarily in that order). I was getting a HUGE lag in this game with Ubuntu 12.04 LTS and driver 13.1, i just dont know if it was the drivers or the OS.
Showing 1-13 of 13 comments
< >
Per page: 15 30 50
Date Posted: Feb 18, 2013 @ 5:30pm
Posts: 13