DudeAmI Feb 18, 2013 @ 4:52pm
Steam not using default browser
I've been using Steam for a while on Xubuntu 12.10, and it works fine except for one annoyance. I had at one time both chromium and firefox installed, as I used chromium for testing (I'm a web developer). Even though firefox was my default, it kept trying to use /usr/bin/chromium-browser for any links in steam (chat, etc). I eventually uninstalled chromium-browser, which ended up doing nothing but it saying it doesn't exist. Finally, I just did sudo ln /usr/bin/firefox /usr/bin/chromium-browser, which works but is very hackish. Would love if steam would use the default browser, and run a check once in a while to see if it has changed.
Showing 1-4 of 4 comments
< >
[dirrty]gsharp Feb 18, 2013 @ 5:00pm 
Isn't there something in System Settings that specifies a default browser?

EDIT: System Settings -> Details -> Default Applications. What is listed for "Web" ?
Last edited by [dirrty]gsharp; Feb 18, 2013 @ 5:02pm
DudeAmI Feb 18, 2013 @ 7:13pm 
Guess I was relying on firefox too much (firefox settings said it was the default). I changed it successfully in Settings Manager > Personal > Preferred Applications. Saved me a ton of trouble, thanks ^^
[dirrty]gsharp Feb 18, 2013 @ 7:41pm 
Originally posted by DudeAmI:
Guess I was relying on firefox too much (firefox settings said it was the default). I changed it successfully in Settings Manager > Personal > Preferred Applications. Saved me a ton of trouble, thanks ^^

Woohoo!
broder Sedin Jan 23, 2014 @ 7:50am 
The above solution did not work for me.

This did:
sudo update-alternatives --config x-www-browser
Showing 1-4 of 4 comments
< >
Per page: 15 30 50
Date Posted: Feb 18, 2013 @ 4:52pm
Posts: 4