Steam for Linux > Discusiones generales > Detalles del tema
Junior s2 Camila 18 de Feb, 2013 a las 14:06
How's Steam on openSUSE?
I'm only waiting for EA to reply on how to deauthorize Crysis 2 so I can move out of Windows. I'd like to know from our suse users how's Steam doing? Still the need of commands to get audio working? Is the rpm repository working?
Mostrando 1-15 de 28 comentarios
< >
blackout24 18 de Feb, 2013 a las 14:10 
Since they ship with KDE as default (you can choose Gnome during the installation though) it won't be using pulseaudio. You can install pulseaudio and set it up for KDE or you can launch steam with export SDL_AUDIODRIVER=alsa.
Junior s2 Camila 18 de Feb, 2013 a las 14:13 
Publicado originalmente por t.jp Linux:
Since they ship with KDE as default (you can choose Gnome during the installation though) it won't be using pulseaudio. You can install pulseaudio and set it up for KDE or you can launch steam with export SDL_AUDIODRIVER=alsa.
They ship with:

KDE
Gnome
XFCE
LXDE

But the problem is having to start Steam with that command, I can't imagine why they didn't fix this, IF, of course, it's still needed.
arc| Gps 18 de Feb, 2013 a las 16:56 
Publicado originalmente por t.jp Linux:
Since they ship with KDE as default (you can choose Gnome during the installation though) it won't be using pulseaudio. You can install pulseaudio and set it up for KDE or you can launch steam with export SDL_AUDIODRIVER=alsa.

Could you explain something to me ?

If openSUSE kde does not use pulse, then how is it possible, that I start steam with:
SDL_AUDIODRIVER=pulseaudio steam

This solution works for arch as well.

The problem is Ubuntu on one side vs Arch and openSUSE on the other side.

The guy from opensuse, who makes the package explained to me that Ubuntu is using a different name for some part of pulse audio.

Arch and openSUSE use the same name, Ubuntu does not.
That why SDL_AUDIODRIVER=pulseaudio steam also works for Arch.

My topic on the github about this is still open. ( although it now has a different number after they cleaned up github )

https://github.com/ValveSoftware/Source-1-Games/issues/26

So I am still optemistic, it will get fixed.

Besides this, steam is working great.
I finished Half Life on linux, counterstrike is working, and I played over 50 hours of TF2

The legal issues are solved, I managed to bring the right people from SUSE(not openSUSE) and Valve together.

http://software.opensuse.org/package/steam

I used this to update my steam client, but it has also been tested on a clean install of openSUSE.

I do not have to type that command every time.
I open the console, and then hit the up arrow. (openSUSE remembers also after a reboot, the last 10 or so comands you entered, you can scroll through them with the up and down arrow keys)
Última edición por arc| Gps; 18 de Feb, 2013 a las 16:57
arc| Gps 18 de Feb, 2013 a las 17:10 
I used google and think I know were ths comes from.
OpenSUSE 12.2 does use pulse audio.

11.2 did not use it as default
Junior s2 Camila 18 de Feb, 2013 a las 20:01 
t.jp do you also have to open Steam via Terminal?
blackout24 18 de Feb, 2013 a las 23:55 
Publicado originalmente por Linux Junior s2 Camila:
t.jp do you also have to open Steam via Terminal?

No I use Arch Linux with KDE 4.10 and made pulseaudio simply my default sound server. Arch Linux installs everything without modification. Seems like openSUSE doesn't roll out standard KDE. You can always let Linux set the SDL_AUDIODRIVER variable on start up automatically.
Junior s2 Camila 18 de Feb, 2013 a las 23:56 
Publicado originalmente por t.jp Linux:
You can always let Linux set the SDL_AUDIODRIVER variable on start up automatically.
How?
arc| Gps 19 de Feb, 2013 a las 2:18 
I think you better wait a bit.

https://github.com/ValveSoftware/steam-for-linux/issues/1849#issuecomment-13756243

As far as I understand things, and if the openSUSE guy is right, this should fix the sound "problem", for Arch and openSUSE
arc| Gps 19 de Feb, 2013 a las 2:25 
Publicado originalmente por t.jp Linux:
Publicado originalmente por Linux Junior s2 Camila:
t.jp do you also have to open Steam via Terminal?

No I use Arch Linux with KDE 4.10 and made pulseaudio simply my default sound server. Arch Linux installs everything without modification. Seems like openSUSE doesn't roll out standard KDE. You can always let Linux set the SDL_AUDIODRIVER variable on start up automatically.

I do not know how much the difference is, but this I can confrim. openSUSE intergrates kde with SUSE, more then other distro do.
arc| Gps 19 de Feb, 2013 a las 11:33 
Minor update

My Issue nr 26 on the github is closed ( because all TF2 issues are solved)
But they reopend number 158.

Steam related problems as Valve told me.

I agree, not that it changes anything, but TF2 is running great on my pc.
The start up of TF2 is allot faster then it was before.

Now only the sound issue remains, but I am looking foward to the next update,
because of what is said by Valve in issue nr 1849 on the github.
Última edición por arc| Gps; 19 de Feb, 2013 a las 11:35
Corionos 19 de Feb, 2013 a las 12:20 
I thanged the Steam shortcut in the menu to "export SDL_AUDIODRIVER=alsa && steam". This works but I have to change a shortcut for each game every time I install a new game. Also you have to uninstall jack package - there is no sound when jack is installed!
arc| Gps 19 de Feb, 2013 a las 14:56 
Publicado originalmente por Squerator:
I thanged the Steam shortcut in the menu to "export SDL_AUDIODRIVER=alsa && steam". This works but I have to change a shortcut for each game every time I install a new game. Also you have to uninstall jack package - there is no sound when jack is installed!

https://github.com/ValveSoftware/steam-for-linux/issues/1849#issuecomment-13756243
arc| Gps 19 de Feb, 2013 a las 15:27 
I just got a confirmation, from an openSUSE friend.

The things discussed, in the github topic, and Valve's reply should fix the sound problems, for openSUSE and Arch.

Thank you Valve.

Junior s2 Camila 19 de Feb, 2013 a las 17:00 
Publicado originalmente por arc| Gps:
I just got a confirmation, from an openSUSE friend.

The things discussed, in the github topic, and Valve's reply should fix the sound problems, for openSUSE and Arch.

Thank you Valve.
What really annoys me is those bugs. If they get fixed I'll use openSUSE for life =)
67168 5 de May, 2013 a las 20:36 
Just now stumbled onto this, kinda late huh.
The public Beta release of Steam was my only reason for live dist upgrading from 12.1 to 12.2.
I have had no issues at all and i've always had pulseaudio as default (listed under alsa).
So after installing from "obs://build.opensuse.org/games," i just created a "link to Application" on desktop ( KDE ) and specified "SDL_AUDIODRIVER=alsa steam" for the command. It has run like butter ever since.

Games:
Counter-Strike: Source
Darkest Hour: Europe '44-'45
Half-Life
Half-Life 2: Deathmatch
Red Orchestra: Ostfront 41-45
Serious Sam 3 BFE
Team Fortress 2

ASRock AM3 Socket mobo
Phenom II X6 1090T ( 2 cores disabled.Clocked@3895MHz )
8 GB ddr2
EVGA gtx 560 ti 448
Mostrando 1-15 de 28 comentarios
< >
Por página: 15 30 50
Publicado el: 18 de Feb, 2013 a las 14:06
Mensajes: 28