Steam for Linux

Steam for Linux

alamarjan Feb 18, 2013 @ 11:58am
[SOLVED] Issue Report: Steam segfaults randomly, TF segfaults on launch after updates (XUbuntu 12.10, compiz, fglrx)
So after the last update, I'm getting Steam crashing on me time and again when I switch to one of its windows or open a menu. Sometimes it takes no more than a couple of clicks to suddenly get it down and restarting. So I've checked the ~/Steam/steam.sh output, and it turned out it's segfaulting on me with no obvious explanation (by the way, I think it's supposed to launch a debugger but fails at that) : http://pastebin.com/apr46KKS

TF2 doesn't work either, segfaulting on launch, and actually as I tried to run it once again to get the error log, it now switched to a different error, telling me this:

tr@sftetra:~/.steam/steam/SteamApps/alamarjan/Team Fortress 2$ ./hl2_linux -game tf failed to dlopen /home/tr/Steam/SteamApps/alamarjan/Team Fortress 2/bin/filesystem_steam.so error=libsteam_api.so: невозможно открыть разделяемый объектный файл: Нет такого файла или каталога AppFramework : Unable to load module /home/tr/Steam/SteamApps/alamarjan/Team Fortress 2/bin/filesystem_steam.so! Unable to load /home/tr/Steam/SteamApps/alamarjan/Team Fortress 2/bin/filesystem_steam.so

Obviously, both filesystem_steam.so and libsteam.api.so are there and untouched. Other games, like Dungeons of Dredmor or Solar 2, seem to run fine.

Also, on an unrelated note, cairo-dock shows all the subwindows as 'steam' for some reason:
http://i.imgur.com/v97NAka.jpg

I believe the crash dumps are uploaded.

Hardware info:
Processor Information: Vendor: AuthenticAMD Speed: 1600 Mhz 4 logical processors 4 physical processors HyperThreading: Unsupported FCMOV: Supported SSE2: Supported SSE3: Supported SSSE3: Supported SSE4a: Supported SSE41: Unsupported SSE42: Unsupported Network Information: Network Speed: Operating System Version: Ubuntu 12.10 (64 bit) Kernel Name: Linux Kernel Version: 3.5.0-18-generic X Server Vendor: The X.Org Foundation X Server Release: 11300000 X Window Manager: Compiz Steam Runtime Version: <Runtime enabled> Video Card: Driver: ATI Technologies Inc. AMD Radeon HD 6620G Driver Version: 4.2.11903 Compatibility Profile Context Desktop Color Depth: 24 bits per pixel Monitor Refresh Rate: 60 Hz VendorID: 0x1002 DeviceID: 0x6760 Number of Monitors: 1 Number of Logical Video Cards: 2 Primary Display Resolution: 1600 x 900 Desktop Resolution: 1600 x 900 Primary Display Size: 15,04" x 8,43" (17,20" diag) 38,2cm x 21,4cm (43,7cm diag) Primary VRAM Not Detected Sound card: Audio device: ATI R6xx HDMI Memory: RAM: 3430 Mb Miscellaneous: UI Language: English LANG: ru_RU.UTF-8 Microphone: Not set Total Hard Disk Space Available: 26688 Mb Largest Free Hard Disk Block: 1146 Mb Installed software: Recent Failure Reports: Mon Feb 18 18:31:53 2013 GMT: file ''/tmp/dumps/assert_20130218223145_1.dmp'', upload yes: ''CrashID=bp-656e38b6-e5c8-40cc-8b56-b90882130218'' Mon Feb 18 19:05:37 2013 GMT: file ''/tmp/dumps/assert_20130218230527_1.dmp'', upload yes: ''CrashID=bp-d39ce89a-b86a-4b8e-95ff-b73612130218''
Last edited by alamarjan; Feb 18, 2013 @ 2:50pm
< >
Showing 1-5 of 5 comments
Tweakedenigma Feb 18, 2013 @ 12:08pm 
You probably wanna report this over here : https://github.com/ValveSoftware/steam-for-linux

To ensure it gets the proper attention.
alamarjan Feb 18, 2013 @ 12:15pm 
Originally posted by Tweakedenigma:
You probably wanna report this over here : https://github.com/ValveSoftware/steam-for-linux

To ensure it gets the proper attention.

Sure, done already.
Last edited by alamarjan; Feb 18, 2013 @ 12:17pm
Dusk of Oolacile Feb 18, 2013 @ 12:30pm 
I would run memtest86 if I were you, just to be sure.
alamarjan Feb 18, 2013 @ 12:39pm 
Originally posted by LOLCAT:
I would run memtest86 if I were you, just to be sure.
I don't really believe that could be a hardware issue (I've seen some), but you've got a point. I'll probably check later.
alamarjan Feb 18, 2013 @ 2:50pm 
Pasted from the github thread:

I actually just solved the problem! Using minidump I was able to trace the issue to fgrlx_dri.so, so I tried to remove the fgrlx driver and manually install the version currently provided on AMD website (http://www2.ati.com/drivers/linux/amd-driver-installer-catalyst-13.1-linux-x86.x86_64.zip). It worked perfectly with linux kernel 3.5.0-18-generic, and now I don't have any trouble running Steam or launching TF2 (well, at least is shows me the intro and the loading screen); so it seems that the recent 12.10 updates broke the supplied fglrx driver.
< >
Showing 1-5 of 5 comments
Per page: 15 30 50

Date Posted: Feb 18, 2013 @ 11:58am
Posts: 5