Steam for Linux

Steam for Linux

BHXSpecter Feb 17, 2013 @ 7:27am
Ubuntu and Steam Woes
I'm utterly baffled on this one. I had Ubuntu up-to-date, just short of upgrading to Ubuntu 12.10 in fact. Update Manager showed no updates to install when checking. I installed Steam, and got it running, though it only showed Killing Floor as my only Linux game (never showed TF2). Upon running Steam a popup appeared recommending to add the PPA x-swat/x-updates to my other repositories, which I did and got several updates upon that check. Got the error that lib-mesa-driv and lib-mesa-dri:i386 depends on libdrm-nouveau2 which is not installed. The down side is that now I can't update, install any programs, or remove anything because it gives that error about mesa on every action. This has really stumped me on how to fix it due to all this.

I can get Steam to play, but it constantly has a popup saying to install lib-mesa-dri and just today it started saying things about xterm, python, and a couple of others.
< >
Showing 1-15 of 39 comments
SN4T14³ Feb 17, 2013 @ 7:42am 
Open up a terminal and run this: apt-get install libdrm-nouveau2 lib-mesa-driv lib-mesa-dri:i386
BHXSpecter Feb 17, 2013 @ 7:52am 
Wonderful went from going on about dependencies to giving an error while reading the package list upon hitting 75%.

sudo apt-get install libdrm-nouveau2 lib-mesa-driv lib-mesa-dri:i386
Reading package lists... Error!
E: Read error - read (5: Input/output error)
E: The package lists or status file could not be parsed or opened.

Wake up to more trouble, go figure.
Oerthling Feb 17, 2013 @ 8:11am 
Please try this and see if that solves the problem:
sudo apt-get update
sudo apt-get upgrade

Though I have to wonder about that PPA recommendation. Nouveau is the open source driver for NVidia. That driver is great for standard 2D stuff - but AFAIK it aint ready for high-power 3D gaming - not even with getting the up-to-date stable upstream drivers from http://www.ubuntuupdates.org/ppa/ubuntu-x-swat.

If you want to game on your machine I recommend disabling that enty in Ubuntu Software Center and enabling the proprietary driver under "Additional drivers" (also in Ubuntu Software Center).
BHXSpecter Feb 17, 2013 @ 8:35am 
Well until I can figure out how to fix the Read error I can't do any updates/removes/upgrades because it will just keep telling me "Reading package lists...Error! etc" over and over.

Linux definitely has an interesting issue I hope gets fixed soon. I have 34 games according to the site, but according to Steam client for Linux I only have 25 games in total and only 1 Linux game out of them :(.
Last edited by BHXSpecter; Feb 17, 2013 @ 8:53am
[Linux] unbridledExüberance Feb 17, 2013 @ 8:56am 
What is the exact error message you get?
BHXSpecter Feb 17, 2013 @ 9:01am 
Reading package lists... Error!
E: Read error - read (5: Input/output error)
E: The package lists or status file could not be parsed or opened.

I've tried removing the files in the list directory and do sudo apt-get update and will get to about 97% then it goes to that error every time.
Last edited by BHXSpecter; Feb 17, 2013 @ 9:01am
[Linux] unbridledExüberance Feb 17, 2013 @ 9:09am 
Huh.
Well, I haven't seen that one before.

Are you able to run sudo apt-get check? And can you post your /etc/apt/sources.list file and the contents of your /etc/apt/sources.list.d directory?
Oerthling Feb 17, 2013 @ 9:37am 
Like mr.exuberant I never had that problem.
I guess some file in your apt cache got corrupted (a crash or network disconnect during writing the file or some such).

Please try removing or disabling the x-swat entries from your sources.list (you can do so through Ubuntu Software Center).
Then:
sudo apt-get clean
sudo apt-get update
sudo apt-get upgrade
BHXSpecter Feb 17, 2013 @ 9:45am 
NOTE* I commented out x-swat lines in the file below even though it didn't show it here, but it didn't work.
Alright, that is a lot to run, but here it is:
sudo apt-get anything (check/update/install) return:
Reading package lists... Error!
E: Read error - read (5: Input/output error)
E: The package lists or status file could not be parsed or opened.
My sources.list file has

# deb cdrom:[Ubuntu 10.10 _Maverick Meerkat_ - Release amd64 (20101007)]/ maverick main restricted
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.

deb http://us.archive.ubuntu.com/ubuntu/ precise main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ precise main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://us.archive.ubuntu.com/ubuntu/ precise-updates main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ precise-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://us.archive.ubuntu.com/ubuntu/ precise universe
deb-src http://us.archive.ubuntu.com/ubuntu/ precise universe
deb http://us.archive.ubuntu.com/ubuntu/ precise-updates universe
deb-src http://us.archive.ubuntu.com/ubuntu/ precise-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://us.archive.ubuntu.com/ubuntu/ precise multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ precise multiverse
deb http://us.archive.ubuntu.com/ubuntu/ precise-updates multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ precise-updates multiverse

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb http://us.archive.ubuntu.com/ubuntu/ maverick-backports main restricted universe multiverse
# deb-src http://us.archive.ubuntu.com/ubuntu/ maverick-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu maverick partner
# deb-src http://archive.canonical.com/ubuntu maverick partner

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
# deb http://extras.ubuntu.com/ubuntu precise main
# deb-src http://extras.ubuntu.com/ubuntu precise main

deb http://security.ubuntu.com/ubuntu precise-security main restricted
deb-src http://security.ubuntu.com/ubuntu precise-security main restricted
deb http://security.ubuntu.com/ubuntu precise-security universe
deb-src http://security.ubuntu.com/ubuntu precise-security universe
deb http://security.ubuntu.com/ubuntu precise-security multiverse
deb-src http://security.ubuntu.com/ubuntu precise-security multiverse
deb http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu precise main
deb-src http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu precise main
While my directory has the following:

ls -a /etc/apt/sources.list.d
.
..
glasen-intel-driver-precise.list
glasen-intel-driver-precise.list.distUpgrade
glasen-intel-driver-precise.list.save
google-earth.list
google-earth.list.distUpgrade
google-earth.list.save
maverick-partner.list
maverick-partner.list.distUpgrade
maverick-partner.list.save
medibuntu.list
medibuntu.list.distUpgrade
medibuntu.list.save
noobslab-themes-precise.list
noobslab-themes-precise.list.distUpgrade
noobslab-themes-precise.list.save
otto-kesselgulasch-gimp-precise.list
otto-kesselgulasch-gimp-precise.list.distUpgrade
otto-kesselgulasch-gimp-precise.list.save
steam.list
steam.list.distUpgrade
steam.list.save
tiheum-equinox-precise.list
tiheum-equinox-precise.list.distUpgrade
tiheum-equinox-precise.list.save
tualatrix-ppa-precise.list
tualatrix-ppa-precise.list.distUpgrade
tualatrix-ppa-precise.list.save
ubuntu-wine-ppa-precise.list
ubuntu-wine-ppa-precise.list.distUpgrade
ubuntu-wine-ppa-precise.list.save
ubuntu-x-swat-x-updates-precise.list
ubuntu-x-swat-x-updates-precise.list.distUpgrade
ubuntu-x-swat-x-updates-precise.list.save
webupd8team-java-precise.list
webupd8team-java-precise.list.distUpgrade
webupd8team-java-precise.list.save
Last edited by BHXSpecter; Feb 17, 2013 @ 9:52am
[Linux] unbridledExüberance Feb 17, 2013 @ 9:56am 
Try this:
sudo rm /var/lib/dpkg/status
sudo cp /var/lib/dpkg/status-old /var/lib/dpkg/status
sudo mv /var/lib/apt/lists/ /var/lib/apt/lists-backup/
sudo mkdir /var/lib/apt/lists
sudo mkdir /var/lib/apt/lists/partial
sudo dpkg --configure -a
sudo apt-get update
This cleans your cache, replaces your status file with an older (hopefully valid) one, clears your lists, then attempts to update.

EDIT: added sudo mkdir /var/lib/apt/lists/partial to the list of commads.
EDIT2: removed sudo apt-cache clean. That hasn't been a valid command for a while
Last edited by [Linux] unbridledExüberance; Feb 17, 2013 @ 10:08am
BHXSpecter Feb 17, 2013 @ 10:03am 
Tells me clean is an invalid operation when I type the first line.
[Linux] unbridledExüberance Feb 17, 2013 @ 10:06am 
Sorry, ignore that first line. That was for an older version and isn't necessary anyways. (Now it's apt-get clean which doesn't work until you fix it haha)

Try doing the other lines.
Last edited by [Linux] unbridledExüberance; Feb 17, 2013 @ 10:07am
BHXSpecter Feb 17, 2013 @ 10:10am 
That worked, but the sudo dpkg --configure -a returned this:
sudo dpkg --configure -a
dpkg: dependency problems prevent configuration of libgl1-mesa-dri:
libgl1-mesa-dri depends on libdrm-nouveau2 (>= 2.4.34); however:
Package libdrm-nouveau2 is not installed.
dpkg: error processing libgl1-mesa-dri (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgl1-mesa-dri:i386:
libgl1-mesa-dri:i386 depends on libdrm-nouveau2 (>= 2.4.34); however:
Package libdrm-nouveau2:i386 is not installed.
dpkg: error processing libgl1-mesa-dri:i386 (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
libgl1-mesa-dri
libgl1-mesa-dri:i386

Otherwise the package list read finished 100% and said Done instead of Error at least.
[Linux] unbridledExüberance Feb 17, 2013 @ 10:20am 
Excellent.

Okay, this should fix your dependency problems:
sudo apt-get install libgl1-mesa-dri libgl1-mesa-dri:i386

If all goes well, then do
sudo apt-get clean
sudo apt-get update
sudo apt-get upgrade
sudo apt-get autoremove --purge
To clean up and make sure everything is up to date
Last edited by [Linux] unbridledExüberance; Feb 17, 2013 @ 10:28am
BHXSpecter Feb 17, 2013 @ 11:53am 
Ugh, sadly I got new errors when I tried to install what I was told to install. t tells me to install nouveau2 still and upon adding that I get this:
sudo apt-get install libdrm-nouveau2 libdrm-nouveau2:i386 libgl1-mesa-dri libgl1-mesa-dri:i386
Reading package lists... Done
Building dependency tree
Reading state information... Done
libgl1-mesa-dri is already the newest version.
libgl1-mesa-dri:i386 is already the newest version.
libgl1-mesa-dri:i386 set to manually installed.
The following packages were automatically installed and are no longer required:
libdrm-nouveau1a:i386 libllvm3.0:i386
Use 'apt-get autoremove' to remove them.
The following NEW packages will be installed:
libdrm-nouveau2 libdrm-nouveau2:i386
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
Need to get 0 B/31.1 kB of archives.
After this operation, 179 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
(Reading database ... 543711 files and directories currently installed.)
Unpacking libdrm-nouveau2:i386 (from .../libdrm-nouveau2_2.4.39-0ubuntu0.1_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libdrm-nouveau2_2.4.39-0ubuntu0.1_i386.deb (--unpack):
trying to overwrite '/usr/lib/i386-linux-gnu/libdrm_nouveau.so.2.0.0', which is also in package libdrm-nouveau1a:i386 2.4.40~precise~ppa1
Unpacking libdrm-nouveau2 (from .../libdrm-nouveau2_2.4.39-0ubuntu0.1_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/libdrm-nouveau2_2.4.39-0ubuntu0.1_amd64.deb (--unpack):
trying to overwrite '/usr/lib/x86_64-linux-gnu/libdrm_nouveau.so.2.0.0', which is also in package libdrm-nouveau1a 2.4.40~precise~ppa1
Errors were encountered while processing:
/var/cache/apt/archives/libdrm-nouveau2_2.4.39-0ubuntu0.1_i386.deb
/var/cache/apt/archives/libdrm-nouveau2_2.4.39-0ubuntu0.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
< >
Showing 1-15 of 39 comments
Per page: 15 30 50

Date Posted: Feb 17, 2013 @ 7:27am
Posts: 39