Steam for Linux

Steam for Linux

Sirik Feb 17, 2013 @ 6:44am
Big Picture Mode Causes Steam to Quit
Does anyone know of a fix to start Big Picture mode?
If i click the Big Picture button, steam just quits and i need to restart it. if i set steam to launch in big picture mode, it never launches and i need to delete the registry.vdf before it works again.

any suggestions?
< >
Showing 1-15 of 20 comments
fac3l3ss Feb 17, 2013 @ 6:46am 
No matter which AMD proprietary drivers I use I have the same problem. However, with open-source drivers it seems to work. I haven't found a solution to this.
Sirik Feb 17, 2013 @ 6:54am 
i dont know if it helps or not, but when i tried to run steam from terminal, and then click big picture, i see this in the terminal:

ExecCommandLine: "/home/sirik/.steam/root/ubuntu12_32/steam steam://open/driverhelperready"
ExecSteamURL: "steam://open/driverhelperready"
Installing breakpad exception handler for appid(steam)/version(1360966495_client)
Opening joystick 0 : Microsoft X-Box 360 pad
AL lib: pulseaudio.c:331: PulseAudio returned minreq > tlength/2; expect break up
/home/sirik/.local/share/Steam/ line 561: 5029 Segmentation fault (core dumped) $STEAM_DEBUGGER "$STEAMROOT/$PLATFORM/$STEAMEXE" "$@"

i am running ubuntu 12.04 Unity, with ATi 6870 13.2 beta drivers.
_donda_ Feb 17, 2013 @ 7:26am 
the line
PulseAudio returned minreq > tlength/2; expect break up
looks like you got a sound problem, which makes sense since big picture plays that startup sound. i cant tell you more about that problem, but id recommend to google for that error message.

you can also try to make steam use alsa instead of pulseaudio, try to give the command
in a terminal, before you start steam from that same terminal. no guarantees though...
Sirik Feb 17, 2013 @ 7:36am 
thanks, i tried that but it returns the same error.
it does look like a sound issue, but my sound sounds ok.
fac3l3ss Feb 17, 2013 @ 12:01pm 
this is what i get when trying to open Big Picture:

Running Steam on ubuntu 12.04 64-bit
STEAM_RUNTIME has been set by the user to: /home/user/.local/share/Steam/ubuntu12_32/steam-runtime
ExecCommandLine: "/home/user/.steam/root/ubuntu12_32/steam steam://open/driverhelperready"
ExecSteamURL: "steam://open/driverhelperready"
Installing breakpad exception handler for appid(steam)/version(1360966495_client)
[xcb] Unknown sequence number while appending request
[xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
[xcb] Aborting, sorry about that.
steam: ../../src/xcb_io.c:160: append_pending_request: Assertion `!xcb_xlib_unknown_seq_number' failed.
/home/user/.local/share/Steam/ linha 561: 32200 Segmentation fault (core dumped) $STEAM_DEBUGGER "$STEAMROOT/$PLATFORM/$STEAMEXE" "$@"
Last edited by fac3l3ss; Feb 17, 2013 @ 12:02pm
Shark Feb 17, 2013 @ 12:25pm 
According to my steam client you need 13.2 beta drivers to get big picture to work, dunno if that's true tho.
fac3l3ss Feb 17, 2013 @ 12:30pm 
Sometimes Big Picture works, but rarely, most of the times I try to run it I get the segmentation fault posted above.
Also I'm having troubles to install 13.2 drivers in Ubuntu, had them installed before. But I also can't seem to install them properly in Windows 8 :P Way to go AMD...

EDIT: my problem is described here:

and here:

AMD driver issue! Hope they fix it soon, this is my major issue with steam 4 linux ATM.
Last edited by fac3l3ss; Feb 17, 2013 @ 12:58pm
Sirik Feb 17, 2013 @ 1:28pm 
Well maybe there will be an update at some point which fixes it... either by Steam or AMD.. but i think in a few weeks time i'll re-format my Linux partition and put Mint Linux on instead.. i think i have settled on Cinnamon over Unity.. maybe Mint will work :)
Alexander Feb 18, 2013 @ 2:46am 
I'm having the same problem here. Running an Asus EAH5850, big picture mode makes steam crash every time. I only hear the first +- 100 milliseconds of the intro movie, accompanied by a black screen before the client crashes to the desktop...

I tried all current proprietary drivers (13.1 and 13.2 beta) but none work...
bluenoser Feb 18, 2013 @ 4:57am 
It is a driver issue, it's been reported on Github apparently amd is working on it.
xondak Feb 18, 2013 @ 5:21am 
Same issue. I've got an AMD Radeon HD 6620G with 13.1 drivers. I -can- launch Big Picture with Radeon drivers, but not with the prorprietary drivers.
acreda1234 Mar 3, 2013 @ 3:58am 
big pic mode is hit and miss for me, its started inside steam a couple of times but i do get looked out if I try to start it big picture mode by default...

ps if anyone has stumbled on to this thread you don't need to delete your whole registry.vdf just edit the line at the bottom for startup mode from 1 to 0
sorath Mar 19, 2013 @ 11:50am 
Big Picture now works again with Catalyst 13.3_beta2 on Gentoo.
(But there is another issue takes place with switching to terminal via Ctrl+Alt+F1)
9 Ukrainka=)* Mar 30, 2013 @ 9:05pm 
9 Ukrainka=)* Mar 30, 2013 @ 9:12pm 
see file:///C:/Documents%20and%20Settings/User/%D0%A0%D0%B0%D0%B1%D0%BE%D1%87%D0%B8%D0%B9%20%D1%81%D1%82%D0%BE%D0%BB/capture-20130331-101050.jpg.png
< >
Showing 1-15 of 20 comments
Per page: 15 30 50

Date Posted: Feb 17, 2013 @ 6:44am
Posts: 20