Steam for Linux > Discusiones generales > Detalles del tema
♫Revolutionary Holiday Quilly 16 de Feb, 2013 a las 15:30
[Solved] Steam - Cannot install 'libc6:i386'
I've been trying for two days to get Steam installed, but no luck. Might be that I'm new to this OS but it's still really frustrating.

Keep getting Cannot install 'libc6:i386'

Specs: ASUS N45SL
Intel Core i5-2450M CPU@2.50 GHz
Windows 7 64-bit
nvidia Geforce GT 635M 2GB
Última edición por ♫Revolutionary Holiday Quilly; 20 de Feb, 2013 a las 17:33
Mostrando 1-15 de 22 comentarios
< >
s.plisskin [Archlinux] 16 de Feb, 2013 a las 15:43 
Your using 64 bit and trying to install an 32bit package. You need multiarch. ia32-libs.
♫Revolutionary Holiday Quilly 16 de Feb, 2013 a las 15:46 
I don't know what that is, but the Ubuntu Software Page says the one I downloaded is Steam (64-bit)
s.plisskin [Archlinux] 16 de Feb, 2013 a las 15:49 
sudo apt-get install ia32-libs. Try that. Then attempt to install Steam. I use Archlinux myself and been a while since i been around Ubuntu. If there are additional steps, i'm sure somebody will give some feedback.
Última edición por s.plisskin [Archlinux]; 16 de Feb, 2013 a las 15:51
♫Revolutionary Holiday Quilly 16 de Feb, 2013 a las 16:02 
Thanks for the feedback, I was able to install it (a big improvement) but when I start it it says the below I pasted. I'm new to this so I really have no idea how to get these things like when people of forums just say
Publicado originalmente por s.plisskin Archlinux:
sudo apt-get install ia32-libs. Try that.
I have no idea how I'm supposed to try that let alone understand what that is... sorry if it sounds stupid and thanks for the patience!


You are missing the following 32-bit libraries, and Steam may not run:
libXrandr.so.2
libpangoft2-1.0.so.0
libpango-1.0.so.0
libfreetype.so.6
libfontconfig.so.1
libgobject-2.0.so.0
libgtk-x11-2.0.so.0
libgtk-x11-2.0.so.0
libgdk-x11-2.0.so.0
libpangocairo-1.0.so.0
libgdk_pixbuf-2.0.so.0
libcairo.so.2
libpango-1.0.so.0
libfreetype.so.6
libfontconfig.so.1
libgobject-2.0.so.0
libXi.so.6
libasound.so.2
libXrender.so.1
libnss3.so
libnssutil3.so
libsmime3.so
libplc4.so
libnspr4.so
libcups.so.2

Cow 16 de Feb, 2013 a las 16:04 
I'm having a similar problem.
The downloads on the website don't lead to a proper steam.
It says, "Wrong architecture 'i836'"
s.plisskin [Archlinux] 16 de Feb, 2013 a las 16:07 
Open up a terminal.

sudo apt-get update
sudo apt-get install ia32-libs
sudo apt-get upgrade

Then a reboot is probably required.
Doctor Holmes 16 de Feb, 2013 a las 16:08 
Publicado originalmente por Doctor Professor Medic:
I'm having a similar problem.
The downloads on the website don't lead to a proper steam.
It says, "Wrong architecture 'i836'"

sudo dpkg --add-architecture i386
sudo apt-get update

it should fix your problem
Cow 16 de Feb, 2013 a las 16:09 
Publicado originalmente por Rimski:
Publicado originalmente por Doctor Professor Medic:
I'm having a similar problem.
The downloads on the website don't lead to a proper steam.
It says, "Wrong architecture 'i836'"

sudo dpkg --add-architecture i386
sudo apt-get update

it should fix your problem
Where exactly do I put that in?
I don't know how to get to terminal.
Doctor Holmes 16 de Feb, 2013 a las 16:10 
Publicado originalmente por Doctor Professor Medic:
Publicado originalmente por Rimski:

sudo dpkg --add-architecture i386
sudo apt-get update

it should fix your problem
Where exactly do I put that in?
I don't know how to get to terminal.

Ctrl+Alt+t
Cow 16 de Feb, 2013 a las 16:11 
Publicado originalmente por Rimski:
Publicado originalmente por Doctor Professor Medic:
Where exactly do I put that in?
I don't know how to get to terminal.

Ctrl+Alt+t
Thank you. After I enter in the first one, it asks for a password. Should I enter them in both at once?
EDIT: Nevermind
Última edición por Cow; 16 de Feb, 2013 a las 16:15
♫Revolutionary Holiday Quilly 16 de Feb, 2013 a las 16:24 
Hmm, I updated by going to the update center, and it downloaded a bunch of stuff. Then I rebooted - then it got stuck on a black screen... I rebooted it 3 times and it's still a black screen. I switched back to Windows now to reply to this, any suggestions?
Cow 16 de Feb, 2013 a las 16:26 
Mine works. Thank you all so much.
♫Revolutionary Holiday Quilly 20 de Feb, 2013 a las 17:33 
Thanks a lot for the help everyone! I finally managed to run Steam and Team Fortress 2, it's all thanks to the great and helpful community, you guys are awesome!
Mostrando 1-15 de 22 comentarios
< >
Por página: 15 30 50
Publicado el: 16 de Feb, 2013 a las 15:30
Mensajes: 22