Corionos Feb 15, 2013 @ 5:29am
Issue report: no sound when jack is installed
I use openSUSE 12.2. When I installed steam there was no sound neither in lobby nor in the game Team Fortress 2.

The sound can be enabled only by doing the following (the both steps are necessary):

1. Ininstalling the package jack

2. Running export SDL_AUDIODRIVER=alsa before running Steam

Ther package jack is needed by several applications I use so there is no way to run the game with sound without uninstalling those applications.

Running export SDL_AUDIODRIVER=alsa is needed when not using pulseaudio. But using pulseaudio is optional in openSUSE: it can be enabled or disabled by a checkbox in the system control center. Pulseaudio is very buggy and I was unable to make it work properly so I disabled it.

Last edited by Corionos; Feb 15, 2013 @ 11:32am
Date Posted: Feb 15, 2013 @ 5:29am
Posts: 0