Taddis Feb 15, 2013 @ 3:21am
Cant launch installed steam and out of ideas. Please help
Hello, i've been trying to get steam to work by using wubi installer at first and couldn't install it at all. Now decided to install linux properly by using bootable usb and picked 12.04 ubuntu 32bit version as heard its most stable one. So at this point i've got steam installed and when i try to run it i get terminal message: "Steam needs to install these additional packages:
libgl1-mesa-dri:i386, libgl1-mesa-glx:i386"
when i try to do it at the end i get this error:
"The following packages have unmet dependencies:
libgl1-mesa-dri : Depends: libglapi-mesa
libgl1-mesa-glx : Depends: libglapi-mesa (= 9.2.0~git20130211.44a5d737-0ubuntu0sarvatt~precise)
E: Unable to correct problems, you have held broken packages."

I have updated system before steam installation, installed nvidia drivers as well . I've no idea what else can i do. Thanks for any help in advance.
Showing 1-15 of 17 comments
< >
Shark Feb 15, 2013 @ 3:26am 
You probably need newer nvidia drivers, open the additional drivers program and install the 310 beta drivers.
Greenbikerdude Feb 15, 2013 @ 3:27am 
have you restarted? is opengl installed? you also could try the .deb from steam's website.
Taddis Feb 15, 2013 @ 3:33am 
Trying to reinstall nvidia to 310 one, had 313. I think there were opengl update on autoupdate i ran right after ubuntu instalation. When i try to launch auto updater it says everything up to date.
Taddis Feb 15, 2013 @ 3:38am 
Just installed 310 nvidia drivers, also reinstalled steam client , but very same problem persists .
Shark Feb 15, 2013 @ 4:01am 
This is weird, steam usually works almost out of the box. try installing nvidia-settings to check if your drivers are actually working.
Taddis Feb 15, 2013 @ 4:11am 
Tried to launch steam several more times and after closing that error message in terminal last time, steam launched out of nowhere after ~20 seconds.
Taddis Feb 15, 2013 @ 4:33am 
UPDATE: steam seems to work even with that error showing up now, but when i launch team fortress 2 i get error : "Required OpenGl extension "GL_ext_texture_compression_s3tc" is not supported. Please install s3tc texture support" . Tried to find solution on google, but no luck yet
Shark Feb 15, 2013 @ 4:37am 
Try this just to make sure:
open a terminal window and type the following commands:
sudo apt-get instal linux-headers-`uname -r`
sudo apt-get install libgl1-mesa-dri:i386 libgl1-mesa-glx:i386

you probably get an error at the second one, but it's worth a try.
if that doesn't work I would advice you to do an update to the system with these commands:
sudo apt-get update
sudo apt-get upgrade

then reboot and see if it worked.
Last edited by Shark; Feb 15, 2013 @ 4:39am
Taddis Feb 15, 2013 @ 4:56am 
first command gives 'invalid operation instal' error
second one : 'The following packages have unmet dependencies:
libgl1-mesa-dri : Depends: libglapi-mesa
libgl1-mesa-glx : Depends: libglapi-mesa (= 9.2.0~git20130211.44a5d737-0ubuntu0sarvatt~precise)
E: Unable to correct problems, you have held broken packages.'

did the 3rd and 4th commands, some things were updated and upgraded but didin't solve the issue.
Shark Feb 15, 2013 @ 4:57am 
oh, I made a typo on the first one, should be install with 2 l's.
Taddis Feb 15, 2013 @ 5:00am 
'Reading state information... Done
linux-headers-3.5.0-23-generic is already the newest version.
linux-headers-3.5.0-23-generic set to manually installed.
The following packages were automatically installed and are no longer required:
linux-headers-3.2.0-37 linux-headers-3.2.0-37-generic
linux-headers-3.2.0-37-generic-pae
Use 'apt-get autoremove' to remove them.'

Then this is what i get from that 1st command .
Shark Feb 15, 2013 @ 5:04am 
well, that is a good thing, but I'm running out of ideas about what it could be. I remember having an issue like this, but I really don't know what fixed it. Maybe running
sudo apt-get install -f
in terminal might do something, but I doubt it.
Taddis Feb 15, 2013 @ 5:05am 
Thanks for help anyways, i think ill give up and go back to windows 7...
ThOR27 Feb 15, 2013 @ 5:30am 
You probably have installed newer drivers, that installed newer version of libgl, probably using a beta source or something like that.

Try that:
sudo apt-get remove libgl1-mesa-dri libgl1-mesa-glx libglapi-mesa steam

know you need to open Ubuntu software center and search where you choose software source (I'm on kubuntu now and don't know where to do that) and remove xorg-edgers or any other source you might have added to install 313 drivers.

After that try to install steam package again

If it doesn't work, you could try to reinstall Ubuntu and install 310 version of driver, update system and install steam. Not the best approach but it's easier than trying to teach you how to fix your apt-get.

Good Luck!
Taddis Feb 15, 2013 @ 6:37am 
Just reinstalled linux, updated it and got 310 drivers straight away as you told and its not working again, even after closing terminal steam doesn't start up now. The error code a bit different :
The following packages have unmet dependencies:
libgl1-mesa-glx : Depends: libglapi-mesa (= 9.0-0ubuntu1)
E: Unable to correct problems, you have held broken packages

Is it hopeless already ?
Showing 1-15 of 17 comments
< >
Per page: 15 30 50
Date Posted: Feb 15, 2013 @ 3:21am
Posts: 17