I'm A Shig Now Feb 15, 2013 @ 2:51am
Absolute driver hell.
Can someone just provide me with a CLEAR, step by step guide on how to uninstall all existing fglrx drivers and install the latest AMD proprietary drivers on Ubuntu? This is seriously driving me up the wall, ubuntu seems to be completely stuck in fallback graphics mode no matter what I do.
Showing 1-15 of 15 comments
< >
Shark Feb 15, 2013 @ 2:56am 
Ubuntu 12.04:
open a terminal window
Type this: sudo jockey-gtk
pick the last beta driver and click install
reboot

Ubuntu 12.10:
open a terminal window
type this: sudo apt-get install linux-headers-`uname -r`
press enter a few times
open the program software sources
under the tab aditional drivers select the latest beta driver for your card and click install
reboot

If you have an amd hd 4000 series card or older, this will not work tho.
Last edited by Shark; Feb 15, 2013 @ 2:57am
I'm A Shig Now Feb 15, 2013 @ 3:03am 
@Wouter
Instructions for 12.10 didn't seem to do anything, command ran without any prompting from me, nothing changed in the Additional Drivers section..

@Greenbikerdude
Those instructions were what got me into this problem in the first place
Last edited by I'm A Shig Now; Feb 15, 2013 @ 3:13am
Oerthling Feb 15, 2013 @ 3:03am 
You already did tried this?:
Ubuntu Software Center
Edit -> Software Sources ... -> Additional Drivers
Click the version you want.

The current driver that you have installed - did you download that from AMD? Or via a PPA?

Generally it's always a good idea to provide some basic information about your system so people can provide better help.
What version of Ubuntu (12.04 or 12.10?, 32 or 64 bit?). How did you install the previous driver?
Is the default that was installed when you installed Ubuntu?
What's the model of your raphics card?

Note: For gaming on Linux Nvidia is by far the best option. If you have the option to replace with an NViodia card, I recommend you do that
Shark Feb 15, 2013 @ 3:05am 
Originally posted by Casual Jerk Shig:
@Wouter
Instructions for 12.10 didn't seem to do anything, command ran with any prompting from me, nothing changed in the Additional Drivers section..

@Greenbikerdude
Those instructions were what got me into this problem in the first place
You just need to search for software sources in unity, not in the terminal. Srry if this wasn't clear.
I'm A Shig Now Feb 15, 2013 @ 3:09am 
@JUSTME
Ubuntu 12.10 x64, i7 2600k @ 4.4ghz, AMD Radeon 6970. 16gb ddr3.

FIrst tried the fglrx in software sources, slowed system to a crawl. Then a friend recommended I try manually downloading and installing AMD proprietary drivers and installing them according to this https://help.ubuntu.com/community/BinaryDriverHowto/ATI. Obviously I messed that up somehow cause it is still stuck in fallback mode.
I'm A Shig Now Feb 15, 2013 @ 3:11am 
@Wouter
no I understand that part, I'm saying that the options you said would be there aren't. There is no "latest beta" under the additional drivers tab
Shark Feb 15, 2013 @ 3:16am 
Which driver version were you trying to install?
it does not literaly say latest beta btw, just select some amd beta and it will work.

Last edited by Shark; Feb 15, 2013 @ 3:17am
Egomaster Feb 15, 2013 @ 3:20am 
Originally posted by JUSTME:
You already did tried this?:
Ubuntu Software Center
Edit -> Software Sources ... -> Additional Drivers
Click the version you want.

where is Edit?
DerRidda Feb 15, 2013 @ 3:29am 
Originally posted by Egomaster:
where is Edit?

It's in the menu bar which is integrated into the "task bar" at the top of the screen (that isn't a task bar), it's hidden until you mouse over it.
Egomaster Feb 15, 2013 @ 3:32am 
Originally posted by DerRidda:
Originally posted by Egomaster:
where is Edit?

It's in the menu bar which is integrated into the "task bar" at the top of the screen (that isn't a task bar), it's hidden until you mouse over it.

Thanks!
I'm A Shig Now Feb 15, 2013 @ 3:35am 
Okay, I randomly got proper graphics after a second restart and replacing Unity with Gnome, but there is now randomly a bloody great "AMD testing use only" watermark in the corner of the screen. I also seem to have lost the ability to extend my desktop onto my second monitor (the selected configuration could not be applied?).

Any ideas?
ThOR27 Feb 15, 2013 @ 4:30am 
Originally posted by Casual Jerk Shig:
I also seem to have lost the ability to extend my desktop onto my second monitor (the selected configuration could not be applied?).

Any ideas?


Two monitor under AMD sometimes is bugged, had this issue before in a friend computer and still couldn't fix it.

What I would like to suggest to you is to open AMD Catalyst as root (I think there is a link to that) and try to set there. If doesn't work, try this: http://forums.opensuse.org/english/get-technical-help-here/hardware/472570-dual-head-amd-ati-monitor-setup-old-home-directory.html

But just do this stuff in this link if you are prepared to get strange stuff and needing to use terminal to fix.
Shark Feb 15, 2013 @ 4:32am 
True, AMD is not the best pick for linux, overall Nvidia does a better job with it's linux drivers.
Showing 1-15 of 15 comments
< >
Per page: 15 30 50
Date Posted: Feb 15, 2013 @ 2:51am
Posts: 15