Kasey Burke Feb 14, 2013 @ 10:13pm
TV overscan
I have linux mint 14 Nadia and everything works fine, im okay with linux but eversince the overscan feature was removed from the nvidia drivers my screen is cut off and my linux os is just useless now. Does anyone know any fixes, looked every where but havent found anything that woks. P.S. the tv has no options to turn off overscan.
Showing 1-1 of 1 comments
< >
Shiny Penny🐧 Feb 15, 2013 @ 7:02pm 
I hope I will be able to help with my given knowledge and research.
I Had the same problem and the fix worked for me. I'll write it in the easiest terminology here so anyone new to Linux can also see it.

Too bad it's a Guess and Test method because not everyone's overscan is the same.
I am using:
Ubuntu 12.10 and Nvidia 310.19 driver with a 50" sony tv over hdmi.

*This fix should work for any Linux using Nivida driver that recognizes viewport option.

Assuming that you are only using one monitor.

1) Open up the "NIVIDIA X Server Setting"
I am using Ubuntu so I just search it up from the dock.
Locate and remember what your Monitor type is.
In this screenshot the Monitor Type is a "DFP-0"[www.phoronix.net]

(DFP means Digital Flat Panel and the 0 is means he only has one DFP monitor hooked up, yours might be different so check)


2) Still inside the "NIVIDIA X Server Setting" find the "X server Display Configuration"
and on the bottom there should be a save config option.
(this is to set up some config for your updated driver if you haven't)

A)-= Side track =-
This may help and I suggest you try this first.
Open Terminal and type in:

sudo nvidia-settings --assign 0/ CurrentMetaMode="DFP-0: 1920x1080 { ViewPortOut=1820x1020+50+30 }

DFP-0 Replace that with what you found in the X server setting thing. and the "--assign 0" the 0 is the monitor you are tying to change. The main monitor is 0 and 1 may be the other monitor you hooked up but again I assume you are using one monitor.

Change around with the 1820x1020 till you get something that fits your monitor then continue down this and in step 3 you will replace the working ViewPortOut will the test resolution you got in this side step.

3)Open a terminal and make sure the X is capital for X11, type in:

sudo gedit /etc/X11/xorg.conf



locate "Monitor" inside the file (You may want to try "Screen" if monitor doesn't work)
Here is another screenshot from another site to help[sakuriw.files.wordpress.com]

above EndSection (there are multiple EndSection so make sure its in the correct boundary like in the picture within the black marked selection.)

4) Now we write in a new option into the xorg.conf file.(remember what monitor type you have and replace DFP-0 with it)

Option "MetaModes" "DFP-0: 1920x1080 { ViewPortOut=1820x1020+50+30 }"

(I like the put a few space in between Option and "MetaModes" to line up everything.)

the 1920x1080 is the Ideal Resolution.
the 1820x1020 is overscan compensation
and the +50+30 is the X and Y where your mouse cursor will try to compensate for the overscan to sync up with the new resolution.

A little Guess and test is required till you get the desired result.
other people suggest that for the X and Y. Those numbers be doubled and subtracted from the ViewPortOut resolution.

"ViewPortOut=1820x1020+50+30"
So that means the 50 and 30 is doubled and added respectively to the X and Y resolution 1820 and 1020, to get to the ideal resolution of 1920x1080 in this example.

1820+(50*2)=1920 [X axis]
1020+(30*2)=1080 [Y axis]

*I didn't really follow the double of x and y because it caused too much out of sync with my mouse. But it's what they suggest so try it first then tweak it to your liking.

So reboot and if it doesn't work just try a diff resolution in the ViewPortOut.

5)-Only if you encounter an error-
If all hell breaks loose and you enter a command line when you reboot.
just sign in and type in:

startx

if that wont work, find the error. (Shift+Page Up) to scroll up in command line
may be a parse error, and you wrote something wrong.

type in

sudo nano /etc/X11/xorg.conf

and just delete what you wrote and forget all this.
and to save just press CTRL+O to save your change and CTRL+X to exit.
and reboot by typing.

sudo reboot
Well that fixed it for me.

*Extra note, if you are getting artifacts on your screen, you may have set up your monitor to handle a resolution that it was not suppose too. Lower the resolution in the viewportout option a bit smaller than the IdealResolution than you have and work your way up. I started with an ideal resolution of 1920x1080 with a viewportout 1680x980+120+50. I got tons of artifacts when I was able to pan around the screen.


This page helped the most:
http://www.nvnews.net/vbulletin/showthread.php?t=180674

I hope you were able to solve the problem as I have, please leave a message below so I know if this was of help or how I can make it better.
Showing 1-1 of 1 comments
< >
Per page: 15 30 50
Date Posted: Feb 14, 2013 @ 10:13pm
Posts: 1