mike.licudi Feb 14, 2013 @ 2:48pm
Unauthorized - "This version of Steam is currently in closed beta..."
"...Please log in with an authorized account".

Updated the repository, pretty sure I downloaded and installed the latest version, but whenever I try to load it up and log in, I get a a pop-up with this message, and then Steam closes. The most frustrating thing is that I can see all the Steam sale goodness behind the pop-up XD

How do I fix this? Thanks!
Showing 1-4 of 4 comments
< >
Tweakedenigma Feb 14, 2013 @ 3:00pm 
Try running a system update. This normally fixes this up.
mike.licudi Feb 14, 2013 @ 3:15pm 
Just seen someone posted a fix on another forum, got it! Thanks :)
rayden12 Feb 17, 2013 @ 8:05pm 
I'm getting the same error. I've tried updating Ubuntu and uninstalling and reinstalling Steam.
|-|19|-|j4|<|<00R Mar 15, 2013 @ 7:05am 
mike.licudi a linkto that post would have been nice;-)
Showing 1-4 of 4 comments
< >
Per page: 15 30 50
Date Posted: Feb 14, 2013 @ 2:48pm
Posts: 4