e633 Feb 14, 2013 @ 1:53am
Fresh install, unable to launch any game
Hi,
just reinstalled Steam + CSS + TF2;
My system is a fresh Linux Mint 14 x64 with an NVIDIA GTX550Ti (drivers 310.32 installed via downloaded package directly from nvidia.com)
specs are the following:
~ $ sudo lshw
http://pastebin.com/EiJawrbm

~ $ glxinfo |grep rendering
direct rendering: Yes

~ $ LIBGL_DEBUG=verbose; glxinfo
http://pastebin.com/bmWeQxfm

I'm having the following issues:
- CS:S won't start
- TF2 won't start

Relevant console output:
[repeated multiple times]
libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/tls/swrast_dri.so
libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/swrast_dri.so
libGL error: failed to load driver: swrast

Even though i have:
~ $ locate swrast_dri.so
/usr/lib/i386-linux-gnu/dri/swrast_dri.so
/usr/lib/x86_64-linux-gnu/dri/swrast_dri.so
-------------------------------------------
More relevant console output:
---
surface_linux.cpp (1667) : Assertion Failed: X context is not using direct rendering (vis 0x027). Unfasten your seatbelt...
Assert( Assertion Failed: X context is not using direct rendering (vis 0x027). Unfasten your seatbelt...
):/home/buildbot/buildslave_steam/steam_rel_client_ubuntu12_linux/build/src/vgui2/src/surface_linux.cpp:1667
---
Game update: AppID 240 "Counter-Strike: Source", ProcID 12042, IP 0.0.0.0:0
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored. [Repeated 4 more times]

(steam:11922): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent. [repeated 11 more times]
---
SDL video target is 'x11'
SDL video target is 'x11'
SDL failed to create GL compatibility profile (whichProfile=0!
PROBLEM: You appear to have OpenGL 1.4.0, but we need at least 2.0.0!
Could not find required OpenGL entry point 'glGetError'! Either your video card is unsupported, or your OpenGL driver needs to be updated.
Game removed: AppID 240 "Counter-Strike: Source", ProcID 12042
Showing 1-14 of 14 comments
< >
towo01 Feb 14, 2013 @ 2:07am 
(drivers 310.32 installed via downloaded package directly from nvidia.com)
That's the problem.
You should never install with the installer, if you are running 64bit Debian/Ubuntu.
e633 Feb 14, 2013 @ 2:11am 
Goddammit... can you be more specific?
The Triggerhappy Innocent Feb 14, 2013 @ 2:54am 
install ia32-libs from synaptic or sudo apt-get install ia32-libs
in Terminal: sudo sh -c 'echo "/usr/lib32\n/usr/lib/i386-linux-gnu/mesa\n" >> /etc/ld.so.conf.d/steam.conf' && sudo ldconfig
e633 Feb 14, 2013 @ 3:05am 
Done, nothing changed.
I also get this now:
libGL: screen 0 does not appear to be DRI2 capable
towo01 Feb 14, 2013 @ 4:12am 
You need the 32bit glx from the nvidia driver and the installer puts this in the wrong location, if you have choosen to install the 32bit libs.
e633 Feb 14, 2013 @ 9:00am 
So, in short, what have i done wrong?
What can i do?
MrTheSoulzツ Feb 14, 2013 @ 9:08am 
try to install the drivers from the repos.
installing drivers manualy isnt recommened
Last edited by MrTheSoulzツ; Feb 14, 2013 @ 9:08am
e633 Feb 14, 2013 @ 9:11am 
So the official driver is not supported? WTF is wrong with these people?
MrTheSoulzツ Feb 14, 2013 @ 9:18am 
it is supported, but they usualy build the divers and then the distros repack it for easy and stable install, they also add any dependencis it might need.
e633 Feb 14, 2013 @ 9:24am 
So i am simply missing some 32 bit dependancy and\or it has been installed in the wrong directory?
MrTheSoulzツ Feb 14, 2013 @ 9:29am 
maybe...
just install it from the distro repositoy and see what happens, but frist you will need to uninstall the drivers you installed manualy, wich also is a pain.
Installing drivers manualy is never a good idea they even recommend that you use the drivers from the distro themselfs.

Heres a quote from nvidia:
"Note that many Linux distributions provide their own packages of the NVIDIA Linux Graphics Driver in the distribution's native package management format. This may interact better with the rest of your distribution's framework, and you may want to use this rather than NVIDIA's official package."
e633 Feb 14, 2013 @ 9:37am 
Oh well... i always installed them manually up to when i switched to x64 and never had a problem.
Nor i have problems now with other 3d programs. Just steam. -.-
Let's try these repos then...
Last edited by e633; Feb 14, 2013 @ 9:38am
MrTheSoulzツ Feb 14, 2013 @ 9:48am 
give us a heads up after you tried and if it works or not :)
Maxrunner Mar 12, 2013 @ 3:05pm 
Im also having this problem, i did a fresh install and am using the nvidia 313.26 drivers and it works with non steam games...
Showing 1-14 of 14 comments
< >
Per page: 15 30 50
Date Posted: Feb 14, 2013 @ 1:53am
Posts: 14