Steam for Linux > Algemene discussies > Details van topic
Rusky 14 feb 2013 om 12:48vm
primus config file location?
I'm trying to do a "primusrun steam" but am getting an error regarding driver paths it looks like.

primus: fatal: failed to load any of the libraries: /usr/lib/nvidia-current/libGL.so.1:/usr/lib32/nvidia-current/libGL.so.1
/usr/lib/nvidia-current/libGL.so.1: cannot open shared object file: No such file or directory
/usr/lib32/nvidia-current/libGL.so.1: cannot open shared object file: No such file or directory


That directory doesn't exist anymore because I'm running the 310 experimental drivers. I tried looking for a primus config file in order to change the path but could not find one. Can someone point me in the right direction?
Laatst bewerkt door Rusky; 20 feb 2013 om 7:35nm
1-4 van 4 reacties weergegeven
< >
Rusky 14 feb 2013 om 12:59vm 
This is really strange because I can run steam using optirun just fine but primusrun is giving me this particular error.
Wallsfantasy 16 feb 2013 om 12:07vm 
I believe you're looking for /usr/bin/primusrun. I faced the same problem so let me explain in details for others who stumble upon this page in google.

1. If you're using Ubuntu 64-bit also install primus-lib:i386 to allow optimus runs 32-bit applications (steam, apparently)
sudo apt-get install primus-lib:i386

2. Edit /usr/bin/primusrun with a text editor.
sudo gedit /usr/bin/primusrun
At line 16, change nvidia library path from nvidia-current to nvidia-experimental-310. So it looks like..
export PRIMUS_libGLa=${PRIMUS_libGLa:-'/usr/lib/nvidia-experimental-310/libGL.so.1:/usr/lib32/nvidia-experimental-310/libGL.so.1'}
At line 27, change path in the case statement so it becomes..
/usr/lib*/nvidia-experimental-310*|'') # nvidia is used by default

3. Run optimus again.
Rusky 20 feb 2013 om 7:35nm 
Thank you for the reply! I'll try it out and will report back.
Laatst bewerkt door Rusky; 20 feb 2013 om 7:35nm
Rusky 20 feb 2013 om 9:03nm 
The 64-bit packages were already installed, I just got hung up on the location of the config file. Makes sense now that I didnt find it, I was doing a find / -name primus not primusrun. Directory paths changed and everything runs like a charm!
1-4 van 4 reacties weergegeven
< >
Per pagina: 15 30 50
Geplaatst op: 14 feb 2013 om 12:48vm
Aantal berichten: 4