Steam for Linux > Obecné diskuze > Detaily tématu
Rusky 14. úno. 2013 v 12.48 dop.
primus config file location?
I'm trying to do a "primusrun steam" but am getting an error regarding driver paths it looks like.

primus: fatal: failed to load any of the libraries: /usr/lib/nvidia-current/libGL.so.1:/usr/lib32/nvidia-current/libGL.so.1
/usr/lib/nvidia-current/libGL.so.1: cannot open shared object file: No such file or directory
/usr/lib32/nvidia-current/libGL.so.1: cannot open shared object file: No such file or directory


That directory doesn't exist anymore because I'm running the 310 experimental drivers. I tried looking for a primus config file in order to change the path but could not find one. Can someone point me in the right direction?
Naposledy upravil Rusky; 20. úno. 2013 v 7.35 odp.
Zobrazeno 1-4 z 4 komentářů
< >
Rusky 14. úno. 2013 v 12.59 dop. 
This is really strange because I can run steam using optirun just fine but primusrun is giving me this particular error.
Wallsfantasy 16. úno. 2013 v 12.07 dop. 
I believe you're looking for /usr/bin/primusrun. I faced the same problem so let me explain in details for others who stumble upon this page in google.

1. If you're using Ubuntu 64-bit also install primus-lib:i386 to allow optimus runs 32-bit applications (steam, apparently)
sudo apt-get install primus-lib:i386

2. Edit /usr/bin/primusrun with a text editor.
sudo gedit /usr/bin/primusrun
At line 16, change nvidia library path from nvidia-current to nvidia-experimental-310. So it looks like..
export PRIMUS_libGLa=${PRIMUS_libGLa:-'/usr/lib/nvidia-experimental-310/libGL.so.1:/usr/lib32/nvidia-experimental-310/libGL.so.1'}
At line 27, change path in the case statement so it becomes..
/usr/lib*/nvidia-experimental-310*|'') # nvidia is used by default

3. Run optimus again.
Rusky 20. úno. 2013 v 7.35 odp. 
Thank you for the reply! I'll try it out and will report back.
Naposledy upravil Rusky; 20. úno. 2013 v 7.35 odp.
Rusky 20. úno. 2013 v 9.03 odp. 
The 64-bit packages were already installed, I just got hung up on the location of the config file. Makes sense now that I didnt find it, I was doing a find / -name primus not primusrun. Directory paths changed and everything runs like a charm!
Zobrazeno 1-4 z 4 komentářů
< >
Na stránku: 15 30 50
Datum odeslání: 14. úno. 2013 v 12.48 dop.
Počet příspěvků: 4