Steam for Linux

Steam for Linux

How to run steam games with apitrace (for OpenGL driver debugging)
After reproducing a bug in Counter Strike - Source ( ) that is supposed to be an Intel graphics driver issue ( ). I wanted to know if there is any way to run CS-S with apitrace ( )
Dernière modification de Gustavo; 11 févr. 2013 à 21h46
< >
Affichage des commentaires 1 à 7 sur 7
Dra'bla 10 févr. 2013 à 14h31 

what have you tried?
I did:
apitrace trace --api egl /home/username/.local/share/Steam/
both with gl and egl to see a difference.

Steam starts in both cases and i can run CS:S

Sadly the trace always failed with:
ERROR: objecc '/usr/local/lib/x86_64-linux-gnu/apitrace/wrappers/' from LD_PRELOAD cannot be preloaded: ignored. and no .trace file created.

A user with more experience with apitrace might see some usefull info in the console output this generates.

Looks to me like a permission thingy. Running the command with sudo generates a Steam Error (failed to create /home/root/ ).

Will have more time tomorrow. Would be nice if you could share your progress/experience.
because you need a lib32 apitrace, i've built one on archlinux.
Dra'bla 11 févr. 2013 à 14h52 
Yes lordheady, my mistake.

Compiled it now for 32bit. I do get some errors on startup (LD_PRELOAD failed) but it starts tracing.

Sadly when i now start a game from the steam library i get the following error in Steam:
sdl_gl_loadlibrary(null) failed: opengl context already created

Perhaps i shouldn't do this on an experimental debian ;) Tomorrow i'll try again on a 32bit ubuntu or arch.

lordheavy: you are able to get traces from cs:s (and other games)?
Dernière modification de Dra'bla; 11 févr. 2013 à 14h53
Gustavo 11 févr. 2013 à 21h48 
Dra'bla: I'm having the same problem as you mention:

sdl_gl_loadlibrary(null) failed: opengl context already created

under Kubuntu 12.10, 64 bits (but compiling apitrace for 32 bits. I can trace apps that I can run from the command line, but not when I run them through Steam.
gQuigs 18 févr. 2013 à 18h30 
I think I am getting closer.. first I:
export GAME_DEBUGGER="apitrace trace "

then I run the game, but it fails missing
GAME_DEBUGGER="apitrace trace " steam works for me with Counter Strike: Source
Or apitrace32 if you're running 64-bit Arch Linux and installed lib32-apitrace from the AUR package.
< >
Affichage des commentaires 1 à 7 sur 7
Par page : 15 30 50