Steam for Linux > 一般的な話題 > トピックの詳細
gektor3000 2013年2月9日 5時44分
nvidia drivers v310.32 on ubuntu
Hello.
I'm using Ubuntu 12.04 x64, I have Geforce 580 GTX.
Drivers were installed nvidia-current - all worked fine, but the game slowed down and offered to upgrade the video driver. Available from the repository drivers nvidia-experemental-304 and nvidia-experemental-310 (310.14) are not compatible with my graphics card (X-server will not start.) I downloaded from the site of nvidia driver 310.32 for my system and he got well, but does not run steam and games.
Now when I run steam, it show this error: "You are missing the following 32-bit libraries, and Steam may not run: libGL.so.1."
how can I solve this problem?
1-10 / 10 のコメントを表示
< >
ツ MrTheSoulz™ 2013年2月9日 5時48分 
hello, if you are using ubuntu 12.10 you need to install linux-source and linux-headers from the software center and only then you can install the nvidia drivers,
however if you upgrade to ubuntu 13.04 you will not have this issue so you can install nvidia drivers without any addicional steps. keep in mind tho ubuntu 13.04 is a alpha and does have bugs, i been using has my main OS and its stable enough for me tho.
^1Gentoo 2013年2月9日 6時14分 
Sounds to me like your missing alot of the 32-bit libraries that are needed for Steam and the games to function.
[dirrty]gsharp 2013年2月9日 10時02分 
OP, ensure you have libgl1-mesa-glx installed.

That might not be the only thing missing though. So, if your system generates another error, please post it.
最近の変更は[dirrty]gsharpが行いました; 2013年2月9日 10時03分
Morganza 2013年2月9日 19時23分 
This seem to happen on every 64bits OS. Full bug report here:

https://github.com/ValveSoftware/steam-for-linux/issues/321

Solution:

sudo gedit /etc/ld.so.conf.d/steam.conf

Add next two lines to file:

/usr/lib32
/usr/lib/i386-linux-gnu/mesa

Then execute:

sudo ldconfig

Now you should be able to run Steam
gektor3000 2013年2月9日 23時08分 
Morganza の投稿を引用:
This seem to happen on every 64bits OS.:
Thank you! it is a helpful solution
最近の変更はgektor3000が行いました; 2013年2月9日 23時08分
TeknoTroll 2013年2月9日 23時35分 
I had the same issue. I'm running Mint 14 Cinnamon. What I did was re-install the libgl1-mesa:386 package in Synaptic and voila!
Bradsha 2013年2月10日 11時28分 
Hey if you still have this problem never use the ubuntu software centre it has problems downloading copyrighted or not in the ubuntu repo dependises, also in 12.10 the ubuntu modified kernel broke support for alot of graphics cards with no fix from ubuntu. I had to leave 12.10 for this problem, also steam is based so far on 12.04. The nvdia 3.10 did not work for me under 12.10 sadly but, I would try what somepeople found working useing the ppa on this site over trying for the official methoed http://www.upubuntu.com/2012/11/install-nvidia-31019-linux-driver-in.html Edit you also must like noted above install the linux and headers becasue 12.10 for some reason doesin't use them or install them by default
最近の変更はBradshaが行いました; 2013年2月10日 11時42分
The Black Hole[FR] 2013年2月20日 5時37分 
fawkingsheet の投稿を引用:
I had the same issue. I'm running Mint 14 Cinnamon. What I did was re-install the libgl1-mesa:386 package in Synaptic and voila!

I re-installed these packages via Synaptic : http://image.noelshack.com/fichiers/2013/08/1361367346-screenshot-from-2013-02-20-14-34-45.png
And it works !
Thanks a lot ! :)
pankid 2013年2月28日 17時36分 
Thank you so much for the fix. After re-installing the mesa packages steam works fine. I was having the same error after updating my graphics drivers.
xPrzybyŁx 2013年7月20日 14時23分 
on my Nvidia GTX 760 with 319.32 drivers I install OpenGL 32bit libraries and
add this to the file:

/etc/ld.so.conf.d/steam.conf

/usr/lib32
/emul/ia32-linux/usr/lib/

note that second folder name and after adding the lines run:

ldconfig

done.

1-10 / 10 のコメントを表示
< >
ページ毎: 15 30 50
投稿日: 2013年2月9日 5時44分
投稿数: 10