Murphyfish 8. Feb. 2013 um 12:53 Uhr
Couldn't find Steam install license agreement, aborting!
I'm getting the error message in the subject when trying to run steam after installing it. The message pops up and steam never starts. I'm running 32-bit Ubuntu 12.04 and I've run steam on this machine before. I just reinstalled the system and for some reason I'm having this issue. I've also uninstalled steam with 'sudo dpkg --purge steam' redownloaded the installation file and tried again with the same result.

Has anyone had this issue?
Beiträge 1-10 von 10
< >
TheMagDudeVikingyDoge!©[DKK] 8. Feb. 2013 um 13:12 Uhr 
No but i can see what i can do/check.....
Ramiro 8. Feb. 2013 um 13:23 Uhr 
I'm having the same problem here. I also just reinstalled the system (Ubuntu 12.04 LTS 64 bits). I atempted all installation methods shown at https://wiki.ubuntu.com/Valve.

I noticed that Ubuntu Software Center indeed mention that there is no license information in the package.

I did also purge the package between installation attempts.
Zuletzt bearbeitet von Ramiro; 8. Feb. 2013 um 13:27 Uhr
Murphyfish 8. Feb. 2013 um 13:29 Uhr 
The License is located here /usr/share/doc/steam/steam_install_agreement.txt.gz - I executed 'zcat steam_install_agreement.txt.gz' and it cats the contents normally. The permissions seem okay too -

-rw-r--r-- 1 root root 3434 Feb 7 14:55 steam_install_agreement.txt.gz
Ramiro 8. Feb. 2013 um 13:31 Uhr 
A workaround has been posted at https://github.com/ValveSoftware/steam-for-linux/issues/1386. Worked for me.
Murphyfish 8. Feb. 2013 um 13:32 Uhr 
Hmm - look at the last 2 changes in /usr/share/doc/steam/changelog.gz - Seems they introduced a bug with this change. ; )

steam (1.0.0.25) precise; urgency=low

* Added license to bootstrap so fresh installs work correctly

-- Valve Corporation <linux@steampowered.com> Thu, 7 Feb 2013 18:19:00 -0800

steam (1.0.0.24) precise; urgency=low

* Added license to allow repackaging for other Linux distributions

-- Valve Corporation <linux@steampowered.com> Thu, 7 Feb 2013 11:03:58 -0800

Murphyfish 8. Feb. 2013 um 13:37 Uhr 
Thanks Ramiro - I performed the workaround it seems to be working now. Although, the license agreement that first pops up is blank. If I had to guess I'd say the license file needs to be copied to the users home directory but that's not happening for some reason. Thanks again for helping find the solution!
Ramiro 8. Feb. 2013 um 13:38 Uhr 
Sure, no problem!
ClanHost.co 24. Feb. 2013 um 16:18 Uhr 
Can someone repost the work around as it is currently now running.
slouken 24. Feb. 2013 um 16:50 Uhr 
Please don't use that workaround. Are you still seeing the problem with the latest installer?
http://repo.steampowered.com/steam/archive/precise/steam_latest.deb
[SS] [OFCC] obi 3. Apr. 2013 um 21:02 Uhr 
workaround still works, problems still exists with latest download, yes. missing libc.so.6 related?
Beiträge 1-10 von 10
< >
Pro Seite: 15 30 50
Geschrieben am: 8. Feb. 2013 um 12:53 Uhr
Beiträge: 10