Steam for Linux

Steam for Linux

Murphyfish Feb 8, 2013 @ 12:53pm
Couldn't find Steam install license agreement, aborting!
I'm getting the error message in the subject when trying to run steam after installing it. The message pops up and steam never starts. I'm running 32-bit Ubuntu 12.04 and I've run steam on this machine before. I just reinstalled the system and for some reason I'm having this issue. I've also uninstalled steam with 'sudo dpkg --purge steam' redownloaded the installation file and tried again with the same result.

Has anyone had this issue?
< >
Showing 1-10 of 10 comments
No but i can see what i can do/check.....
Ramiro Feb 8, 2013 @ 1:23pm 
I'm having the same problem here. I also just reinstalled the system (Ubuntu 12.04 LTS 64 bits). I atempted all installation methods shown at

I noticed that Ubuntu Software Center indeed mention that there is no license information in the package.

I did also purge the package between installation attempts.
Last edited by Ramiro; Feb 8, 2013 @ 1:27pm
Murphyfish Feb 8, 2013 @ 1:29pm 
The License is located here /usr/share/doc/steam/steam_install_agreement.txt.gz - I executed 'zcat steam_install_agreement.txt.gz' and it cats the contents normally. The permissions seem okay too -

-rw-r--r-- 1 root root 3434 Feb 7 14:55 steam_install_agreement.txt.gz
Ramiro Feb 8, 2013 @ 1:31pm 
A workaround has been posted at Worked for me.
Murphyfish Feb 8, 2013 @ 1:32pm 
Hmm - look at the last 2 changes in /usr/share/doc/steam/changelog.gz - Seems they introduced a bug with this change. ; )

steam ( precise; urgency=low

* Added license to bootstrap so fresh installs work correctly

-- Valve Corporation <> Thu, 7 Feb 2013 18:19:00 -0800

steam ( precise; urgency=low

* Added license to allow repackaging for other Linux distributions

-- Valve Corporation <> Thu, 7 Feb 2013 11:03:58 -0800

Murphyfish Feb 8, 2013 @ 1:37pm 
Thanks Ramiro - I performed the workaround it seems to be working now. Although, the license agreement that first pops up is blank. If I had to guess I'd say the license file needs to be copied to the users home directory but that's not happening for some reason. Thanks again for helping find the solution!
Ramiro Feb 8, 2013 @ 1:38pm 
Sure, no problem!
Can someone repost the work around as it is currently now running.
slouken Feb 24, 2013 @ 4:50pm 
Please don't use that workaround. Are you still seeing the problem with the latest installer?
[SS] Apr 3, 2013 @ 9:02pm 
workaround still works, problems still exists with latest download, yes. missing related?
< >
Showing 1-10 of 10 comments
Per page: 15 30 50

Date Posted: Feb 8, 2013 @ 12:53pm
Posts: 10